Solved

Exchange 2000 problems sending mail...

Posted on 2004-04-18
9
13,954 Views
Last Modified: 2010-05-18
Hi Everyone

I have recently setup an additional domain controller at a remote site, I have also setup a secondary Exchange Server down there.  I have setup two sites in the Active Directory using the same domain.

I have moved over one mailbox from the primary Exchange server at site 1 to the secondary Exchange server at site 2 to test that it is working ok.  I want users to login to their mailboxs locally and not accross the VPN (which is slow!),    Now at first when I had various DNS issues I was unable to login to Outlook on the client machine who's mailbox I'd moved.  After resolving some DNS probs I was then able to login, but was not able to send and receive mail.  I would receive the following error:

"The e-mail system was unable to deliver the message, but did not report a specific reason."

I then continued looking into this...  I added the second Exchange server under Administrative Groups, First Administrative Group, Routing Groups, Connectors, (my connector) and Local Bridgeheads; as it wasn't already there.  I can now send and receive external emails from my Hotmail test account.  (I dont have a solid understanding of what a Local Bridgehead is however).  

I have one last problem, I cant send internal emails on the mailbox I moved to the new server.  I can receive internal emails, but not reply or send.  I dont get any failed receipt or error message.

I'm no expert on exchange so it may well be something I haven't configured correctly or missed.

Any help on this is much appreciated.

Many Thanks,

Alan

 
0
Comment
Question by:Alan-Yeo
9 Comments
 
LVL 57

Expert Comment

by:Pete Long
Comment Utility
If you havnt allready done so see http://www.mcse.ms/message540247.html looks like a DNS/MX record problem :)
0
 
LVL 57

Expert Comment

by:Pete Long
Comment Utility
Also try

On the DNS server:
Open the DNS Console.
Click to expand your DNS server name, and then click to expand Forward Lookup Zones. The root zone is listed as a dot (.). If the root zone is displayed under Forward Lookup Zones, delete the root zone.
Right-click the DNS server object, and then click Properties on the shortcut menu. Click the Forwarders tab, and then type the IP addresses of one or more DNS servers with Internet name resolution. This allows Exchange 2000 to properly route outbound mail.
Because there was a root zone, there are not any root hint servers available. Simply restart the DNS server, and it should restart configured with root hint servers. However, if you cannot restart the DNS server, you must stop and restart the DNS service. To stop and restart the DNS service on the DNS server:
Click Start, click Run, type cmd, and then click OK.
At the command prompt, type net stop dns, and then press the ENTER key.
Type net stop netlogon, and then press the ENTER key.
Type net start netlogon, and then press the ENTER key.
Type net start dns, and then press the ENTER key.
Go to the server that is running Exchange 2000 or Exchange 2003. Use the following steps to flush and then re-register the DNS cache on the server that is running Exchange 2000 or Exchange 2003:
Open a command prompt window.
Type the following command:
ipconfig /flushdns

Type the following command:
ipconfig /registerdns

WORKAROUND
If you do not have access to the DNS Console and cannot make changes to the configuration of your DNS server, or if you want to keep DNS resolution local to your internal network and want to retain the forward lookup zone for the root (.) domain, use the following procedure to work around this issue:
Go to the server that is running Exchange 2000 or Exchange 2003.
Open the properties of the SMTP virtual server.
Click the Delivery tab, click Advanced, and then click Configure to configure external DNS servers. Specify the address of one or more DNS servers with external name resolution.
From KB KB289045
0
 
LVL 57

Expert Comment

by:Pete Long
Comment Utility
0
 
LVL 57

Expert Comment

by:Pete Long
Comment Utility
Also see XIMS: Cannot Send Mail After Re-Installing the IIS SMTP Service
http://support.microsoft.com/default.aspx?scid=kb;en-us;q290290
0
Integrate social media with email signatures

Is your company active on social media? Do you also use email signatures? Including social media icons in your email signature is a great way to get fans for free. Let all your email users know you’re on social media quickly and easily, in a single click.

 

Author Comment

by:Alan-Yeo
Comment Utility
PeteLong,

Thanks for your posts but I have already tried the above articals without any success.

This issue is only that internal email cannot be sent from any mailboxes I move to the new Exchange server.  External email works fine going in and out and also enternal email beening sent to the recipient who has been moved to the new server works, its just sending internal thats screwed.  Does this point to a problem with the second server relaying mail to the primary?

Is there any configuration I can check in the SMTP virtual server for both servers?

Many Thanks,

Alan
0
 
LVL 24

Expert Comment

by:David Wilhoit
Comment Utility
Does the first server have an SMTP connector on the SMTP VS? Are you forwarding to smarthost?

D
0
 

Author Comment

by:Alan-Yeo
Comment Utility
I dont have SMTP connectors under the virtual servers on either machine.  I have an SMTP conector under Routing Groups, First Routing Group, Connectors.

Its a same you cant add pictures when posting comments on EE as I could have taken a screen shoot of my System Manager structure.  Below is how the structure looks:

Company1 (Exchange)
│
├ Global Settings
├ Recipients
├ Administrative Group
│    ├ First Administrative Group
│        ├ Servers
│        │    ├ Server01
│        │    │    ├ Protocols
│        │    │    │     ├ HTTP
│        │    │    │     ├ IMAP4
│        │    │    │     ├ NNTP
│        │    │    │     ├ POP3
│        │    │    │     ├ SMTP
│        │    │    │     │    ├ Default SMTP Virtual Server
│        │    │    │     │          ├ Current Sessions
│        │    │    │     │          ├  Queues
│        │    │    │     ├ X.400
│        │    │    ├ First Storage Group
│        │    ├ Server02
│        │          ├ Protocols
│        │          │     ├ HTTP
│        │          │     ├ IMAP4
│        │          │     ├ NNTP
│        │          │     ├ POP3
│        │          │     ├ SMTP
│        │          │     │    ├ Default SMTP Virtual Server
│        │          │     │          ├ Current Sessions
│        │          │     │          ├ Queues
│        │          │     │                ├ Domain_Name1.com (Local delivery)
│        │          │     │                ├ PreSubmissionQueue (Messages pending submission)
│        │          │     │                ├ Messages awaiting directory lookup
│        │          │     │                ├ Messages waiting to be routed
│        │          │     │                ├ Server01.Domain.Domain_Name.co.uk (Remote delivery)
│        │          │     ├ X.400
│        │          ├ First Storage Group
│        ├ Routing Groups
│        │     ├ Connectors
│        │     │     ├ SMTP Connector
│        │     ├ Members
│        ├ Folders
├ Tools

That's basically my structure in System manager, as you can see I dont have SMTP connectors under each server, just one under Routing Groups.  Is this what you'd expect?  On the SMTP Connector it is using DNS to deliver mail, not forwarding to a Smart Host.

If you look at my structire under Server02, Protocols, SMTP, Default SMTP Virtual Server, Queues and Server01.Domain.Domain_Name.co.uk.  This is where any internal mail I send from the mailbox I moved to the second server is getting stuck, it just sits in there retrying.  If I right clicked and choose "Delete All Messages (Send NDR)", I then receive a Non Delivery Report that says the following:

"This message was rejected due to the current administrative policy by the destination server.  Please retry at a later time.  If that fails, contact your system administrator."

(I'm not sure if this was generated by me deleting the messages from the qeueue or if this is the actual reason its not being delivered)

I also noticed this morning that it has a foler with a red Exclamation Mark on it, followed be the text "Enumerate messages from the queue node".

Thanks,

Alan
0
 
LVL 20

Accepted Solution

by:
ikm7176 earned 500 total points
Comment Utility
follow the link below to configure the smtp connector on the secondary site exchange server.

http://support.microsoft.com/default.aspx?scid=kb;en-us;q265293

If you have configured  with connector to use DNS and still having the problem. i think the DNS is the problem.
Configure the connector to use smart host  and try again.

test the telnet connection to first site exchange server on port 25.(just to make sure that smtp communication is not a problem)

hope you'll find this helpful.



0
 

Author Comment

by:Alan-Yeo
Comment Utility
ikm7176,

I added another SMTP mail connector and made the second server the local bridge head.  This seems to have resolved the issue.

Thanks for your help!
0

Featured Post

Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

Join & Write a Comment

Not sure what the best email signature size is? Are you worried about email signature image size? Follow this best practice guide.
Local Continuous Replication is a cost effective and quick way of backing up Exchange server data. The following article describes the steps required to configure Local Continuous Replication. Also, the article tells you how to restore from a backup…
In this video we show how to create a Contact in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Contact ta…
In this video we show how to create a Resource Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: Navigate to the Recipients >> Resources tab.: "Recipients" is our default selection …

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now