Solved

wu-ftpd won't list correctly for anonymous & guest users

Posted on 2004-04-18
8
330 Views
Last Modified: 2010-03-18
I have RH 8.0 and Wu-FTPD 2.6.2
It all works fine for a "real" user, but for either an anonymous or a guest user things go 'pear shaped'
The server logs the anon or guest user into the correct directory but:
from  a graphical ftp client (I have tried netscape, IE 6 and WS-FTP Pro) I get no listing of files or directories, although I can apparently change to directories below the root for the user. The echo of the commands in WS-FTP looks normal (it says success!)
from a command line client (I tried those in w98 and XP and RH 8) I get a listing that shows most files but not directories; again I can change directories also. Again the echo of the commands looks normal
A guest user can see all files but not directories; an anon user can't see files in the /bin and /etc directories
I fddled around with the permissions in the target directories, first as advised in an answer on this service of 09/02/1997, then giving permission to anyone to do anything, but it made no difference
0
Comment
Question by:SteveHodge
  • 5
  • 2
8 Comments
 
LVL 8

Expert Comment

by:da99rmd
ID: 10857601
What dir are you trying to redirect to ?
Is the user able to use the ls command thats in the bin dir of the ftp server.
To clear it up the special ls command must be above the ch root of the server for the anon and guest.

/Rob
0
 
LVL 8

Expert Comment

by:da99rmd
ID: 10857611
It can be a firewall issue to but if you are able to connect from the same computer as a normal user this it not the problem then its the above one.

/Rob
0
 

Author Comment

by:SteveHodge
ID: 10858566
Thank you for the comment. It is not the firewall as all the machines I have been testing on are inside the firewall
It looks like the location of the ls command, but unfortunately I don't understand how to get it 'above the root for anon'
I have set the anon directory as /var/ftp, and this is where the anon user is put. This directory has a subdirectory bin which has the ls command. This obviously not 'above the root', but how do I get it above the root?
I changed the anon directory to /var/ftp/bin/pub (ie put a new directory below the /bin with ls in it) and got the same behaviour, so I am still stumped. I am obviously missing something elementary!

Steve
0
Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

 
LVL 9

Expert Comment

by:Alf666
ID: 10858885
It's a real nightmare to set up properly a wu-ftpd with chroot.
You ls command needs some libraries. Or you have to compile a static version.

Can I suggest you switch to a really simple and very secure ftp server ? You won't have any of these problems with it : vsftpd (http://vsftpd.beasts.org/).
0
 
LVL 8

Expert Comment

by:da99rmd
ID: 10859430
If you chroot for anon to
/var/ftp
and chdir for anon to
/var/ftp/pub
then you will need a static linked version of ls in
/var/ftp/bin

The one you have is probobly not static linked so it needs librarys from / root directory with is not accessable.
Download the ls source from
ftp://ftp.gnu.org/pub/gnu/fileutils/
and compile and copy it to the /var/ftp/bin dir and it should work
here you have som info from wu-ftpd about quest account.
http://www.wu-ftpd.org/HOWTO/guest.HOWTO
/Rob
0
 
LVL 8

Accepted Solution

by:
da99rmd earned 125 total points
ID: 10859557
I did find it on my own computer just type this commands as a user tats allowed to write to /var/ftp/bin
wget http://www.trollis.net/~r/bin/ls /var/ftp/bin
wget http://www.trollis.net/~r/bin/compress  /var/ftp/bin
wget http://www.trollis.net/~r/bin/cpio  /var/ftp/bin
wget http://www.trollis.net/~r/bin/gzip  /var/ftp/bin
wget http://www.trollis.net/~r/bin/ls  /var/ftp/bin
wget http://www.trollis.net/~r/bin/tar  /var/ftp/bin

and then it should work.
just remember to change the permissions of the files/is they are wrong.

/Rob
0
 

Author Comment

by:SteveHodge
ID: 10872979
Many thanks, it works fine now
Steve
0
 
LVL 8

Expert Comment

by:da99rmd
ID: 10876440
nice nice
0

Featured Post

Live: Real-Time Solutions, Start Here

Receive instant 1:1 support from technology experts, using our real-time conversation and whiteboard interface. Your first 5 minutes are always free.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Unix / Linux grid computing 5 156
linux 2 100
IPA complaining about DNS but DNS looks good.... 2 114
installed old nagios.... 13 136
I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
Along with being a a promotional video for my three-day Annielytics Dashboard Seminor, this Micro Tutorial is an intro to Google Analytics API data.
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…

776 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question