SATA Hard Drive vs New XP Install

Greetings,
  Like others, I'm having problems with a fresh XP install on my Mobo and SATA Harddrive.   I am able to install and operate Windows 98, just unable to upgrade.  I receive the infamous "Setup did not find any hard disk drives installed in your computer."

System Info:
  ASUS K8V SE Deluxe motherboard
  Seagate ST3160023AS 160 GB SATA hard drive
  Windows XP Home Edition (no SP 1)

Items I have done:
1.  Load Windows 98 - done
     a.  Hard drive is detected and usuable.
2.  Push F6 and load ASUS driver "WinXP Promise FastTrak 376/378 Controller" - problem persist
3.  Update BIOS - only initial release for K8V SE board
4.  Ensure SATA is plugged into correct slot (SATA1), not RAID SATA plug (PRI_SATA)

For those who are willing to help, here's the website for the ASUS Mother Board

http://www.asus.com/support/download/item.aspx?ModelName=K8V%20SE%20Deluxe&Type=All

I have tried
  378raid_100137.zip  
  378ata_100104528.zip
  4in1_449.zip
  VIARAID220d.zip

I am just shotgunning now.  :(  Thanks in advance for your assistance.

- Mike
leonard430Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

myderrickCommented:

Leonard..


Try making sure that the HD is set as master, Best if you select auto in the BIOS.

If you can use FDISk try it and see if the is set to ACTIVE partition.

If all of this is done then still have the problem use a bootable winxp cd to boot the system.

Get to the recovery console and use the MAP to see if the HD is displayed. If it is then check your BIOS and FDISK solutions well. If not the I think you got to use FDISK to delete (if no important data is on it) and create partion.

With Windows FAT32 I think it supports some amount of HD Space (32 or something --- Not really sure)

Would you mind partitinioning it into 32GB and ...

With the 32 winxp will be comfortable with that.

Hope this helps.

Good Luck

MD
0
buckeyes33Commented:
Are you using the zip files and putting them on a floppy?   You need to unzip them before you use them.  

first I don't think Fdisk works on SATA drives, so that may be out of the question.


What I would do is get the disk utility from Seagate.  I would then format the drive using seagates software, either a full 0 format or a quick 0 format.  This will insure that the drive is clean.  After that I would go through the setup again and see if it works for you.
0
e_sandrsCommented:
I don't know if this will help (and has been partially addressed by the preceding posts), but here's what I'd do and expect to work:

1) Download 378RAID_100137.ZIP
2) Extract the files
3) Use the MakeDisk option to create a Promise RAID floppy for Win NT/2000/XP/2003
4) Boot the system off an XP install CD
5) Press F6 and insert the Promise floppy from step 3.
6) Install to SATA drive

Have you tried that already and it failed?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
The 7 Worst Nightmares of a Sysadmin

Fear not! To defend your business’ IT systems we’re going to shine a light on the seven most sinister terrors that haunt sysadmins. That way you can be sure there’s nothing in your stack waiting to go bump in the night.

leonard430Author Commented:
Thanks for responses.  I will not be able to try these solutions until tonight 10:30 PST.

I have brought system up with old IDE harddrive and used SATA as Slave.  SATA Hard Drive is currently formatted to NTFS standard (150GB usuable).

The zip files I mentioned above were unzipped and then executed either on old IDE Harddrive or laptop.  

There are 3 different MakeDisk.exe files (2 Raids and 1 VIA...I believe) on the Asus CD and I've tried them all.  I've done the F6 and insert floppy and always end up with the "no hard drive...F3"  

I don't feel too bad now because I have seen multiple post on forums regarding this problem.  

I have found a page in the manual that says I must use Win XP SP 1 for SATA drives.  I have a bootable Win XP disk without SP 1.  I'm placing my bets on this.  I have to get another copy anyway since Microsoft has wisened up and requires activation.


0
e_sandrsCommented:
Ok, I was just reading pg 46 with the "must use WinXP-SP1 for SATA drives" on it.  If you're getting a copy with SP1 integrated, great.  Otherwise, you could read up on slipstreaming the SP into your installation and reburning it to a CD.  Here's one description.

http://www.theeldergeek.com/slipstreamed_xpsp1_cd.htm

I'm sure you or I could find more if you're interested...
0
leonard430Author Commented:
All,
  Thanks for you inputs but I still have the same problems.  I used a slipsteamed WinXP-SP1 with no luck.

When I get the the F6 part of the install, I have a driver that loads WinXP Promise SATA378 Controller which is more appropriate than the RAID drivers.

I'm about to give up and just use my IDE Drive and eat the $135 for the SATA Hard Drive until the drivers/technology become available.

e_sandrs,
  Thanks for the Slipstreamed link.   That is an interesting and useful link.
0
e_sandrsCommented:
Sorry the suggestions haven't helped.  Unfortunately, my only SATA boot drive experience is on Intel 865 chipsets, so I can't comment on whether this should be easier or not on the VIA chipset.

Here's a more thorough walk-through to verify we all think we're doing the same thing and failing.

1) Install HD to Pri_SATA connector.

2) Boot into the BIOS, and on the Advanced menu set, go into the Onboard Devices Configuration screens.  Verify the OnChip SATA Boot ROM is [Enabled].  Also check the status of the Onboard Promise Controller is Enabled and set to RAID Mode.

3)  If you made changes in step 2, you may want to reboot and re-enter the BIOS so the changes have taken effect.  Verify HD is visible and can be selected as a boot source.

4) Whether you can see the HD or not, reboot the system and press <Ctrl+F> to enter the Promise FastBuild menu

5) Choose to AutoBuild (1) a Performance array.  Hopefully, it will show you creating a 1 drive array.  Press <Ctrl+Y> to save the "array".  Press a key to reboot the system.

6) Boot off the WinXP-SP1 disk, install the RAID drivers at the F6 prompt, and go?  The directions recommend using Fdisk before the OS install, but you should have the Fdisk/Format options within the XP install.

Option 2) Try with the Promise Controller "Disabled", and just boot off the CD.  See if you can install to the SATA drive on the SATA1 connector (or less likely, the Pri_SATA) - verifying that the OnChip SATA Boot ROM is Enabled.

Option 3) Try with the HD on SATA1 and following the VIA RAID setup to create a one-drive RAID 0 "array".

Whew!  Hopefully one of those scenarios is something you haven't tried and will work.  We can't let the computer (or in this case hardware) win, can we?
0
buckeyes33Commented:
>>Hopefully one of those scenarios is something you haven't tried and will work
hopefully.
0
leonard430Author Commented:
Thanks,
  I have time tonight to try these.  Found out from another board that the Via SATA Driver version 2.20 is giving people problems.  Version 2.10a is next lower down-rev but is not listed on the Second Edition (SE) download website.  

  I have downloaded that from the original K8V Deluxe download website and will give this a shot also.

  This WILL work tonight....or I'll have to replace my dining room window after chucking the hard drive.  :)
0
leonard430Author Commented:
WOohOo!!  Fixed!

The key was to use the correct version of SATA Driver when F6 is selected.  Correct version is VIA VT6420 SATA 2.20

k...time to document everything I did so others can follow quickly:

1.  Download VIARAID220d.zip (VIA VT6420 SATA 2.20 file) from Asus website (see first post for link).  Unzip and open folder VIARAID/DriverDisk.  Run MakeDisk.exe.
2.  Ensure SATA Cable is connected to SATA1, not PRI_SATA
3.  BIOS Setup
    a.  Onboard Devices Configuration
         i)    OnBoard SATA BOOTROM - Enabled
         ii)   OnBoard Promise Controller - Disabled
    b.  Boot Device Priority   (CD, Floopy, HDD)
4.  Used Slipstreamed Windows XP Disk in order to have Service Pack 1 on install.  See above post.
5.  Push F6 on initial screen and insert disk from step 1.

Easy, if you can find the file.  I must have finally gotten lucky, because I can't even find the download page anymore for K8VSE Deluxe board on ASUS using their search engine.

Thanks to all for their help.
0
buckeyes33Commented:
i wondered about that, but it seemed like you had tried all of them
0
leonard430Author Commented:
The trick on the VIARAID220d.zip file is not to run the setup.exe file in the top level folder.  MakeDisk is hidden.  *shakes fist at ASUS*  

Also learned that all the downloads saying PROMISE are for RAID.  

:)
0
Scott659Commented:
If you looking for another bios solution I found a website that has hard to get bios firmware. You can search by manufacture, year, and type. You can find the link off of this website.


http://www.avidware.net/Co-Location-Los-Angeles.asp

Scroll down to the bottom of the page. That is where the link is

or their home page

http://www.avidware.net/
0
omicronpersei8Commented:
I had a similar problem with an MSI board not recognizing my SATA drive. The solution was to get the right drivers and select to boot from "SCSI" in the bios. Seems SCSI maps to SATA some how.
0
expertmonCommented:
Curious side-topic: to where are the drivers installed?  Can't be the SATA disk since it's not recognized.  Does it update the BIOS somehow?

I hope this works for W2K.  For some reason pressing F6 at the prompt led to: "Cannot determine type of computer ..."  Pressing F6 on subsequent attempts yielded the usual Disk I/O error: status 00001000.

What a disgrace - I can't believe that we still have to rely on the 1.44 floppy.
0
paulmwardCommented:
Just thought I would post the ASUS download link for the K8V SE Deluxe

http://www.asus.com.tw/support/download/item.aspx?ModelName=K8V%20SE%20Deluxe&Type=Latest&SLanguage=en-us


I'm having the same problem as leonard430 and I hoping the fix you posted is going to work for me too. I'll be trying it tonight. Fingers crossed.
0
paulmwardCommented:
Just to let you know that I downloaded VIARAID220d.zip and disabled the promise controller in the BIOS as described by leonard430 and XP loaded first time.

I also used a XP Install CD that didn't include SP1. It was just a standard retail CD.
0
jonelr70115Commented:
Well, I am glad that this worked for you because it didn't for me.  I have tried everything everyone has suggested and I still cannot get xp to see the drive.  Any other suggestions?
0
e_sandrsCommented:
If nothing here is working for you, you're probably better off posting a new question to get more attention than this "stale" one will get.

Referencing this list to avoid some duplication may also be a good idea
0
DestinovaCommented:
This totally worked for me, thanks!
0
hrciCommented:
Hi,

   Just wanted to say thanks to Leonard430 mainly about his post on getting the right driver for the SATA drive ....VIARAID220d.zip (VIA VT6420 SATA 2.20 file). The one that came with my K8VSE Deluxe motherboard would not work and I was about to go crazy!! I tried the driver you suggested and it went fine. I might add I didn't have SP1 slipstreamed either,  and it worked just fine.

As for Bios settings....
a.  Onboard Devices Configuration
         i)    OnBoard SATA BOOTROM - Enabled
         ii)   OnBoard Promise Controller - Enabled


Here is the link to the file for others to use...     http://www.asus.com.cn/support/download/selectftp.aspx?l1_id=1&l2_id=20&l3_id=1&m_id=4&f_name=VIARAID220d.zip~zaqwedc

I hope it works for others too. Thanks again!!!

0
traianosCommented:
probably the sata drive is not being recognized by windows 98 because it's a very new technology.why don't you try to install xp at once,without doing update?
0
gofast505Commented:
So i have an AV8 Delux, and a Seagate sata drive, i am having the same issues as metioned above but I only have this drive, sounds like you all are adding this drive as a secondary, so I can not run makeDisk like in the instructions because it is a windows app, any suggestions?

0
gofast505Commented:
Got it, you have to make a driver disk from another OS to a floppy, run that floppy by f6 when intalling, think that was left out fo the instructions, thanks for all your posts!
0
hw45Commented:
I had the same problems here with a 200GB Maxtor. The Max Blast tool didn't have any problems to find the drive and I could it prepare for the OS and partition. When M$ slipstreams their OS's to SP1 or SP2 then they should also add some drivers!!!

Many thanks for the help here!!!
0
ketan_naikCommented:
I have ASUS P5GD2 915P motherboard, I am not able to install any OS say Win XP, Win XP SP2 or Win 2K. Always at certain level it goes and then error messages gives like. Also it hang at different level like loading setupp.ini, after message please wait... etcs. May please help me how to load OS. I have SATA 80 GB SEAGATE HDD and 64 bit Intel CPU.

K S NAIK
0
e_sandrsCommented:
Ketan_naik - you should probably start your own question, rather than tagging on here, but it sounds like bad memory to me.  Whenever the install hits the bad block(s) it dies.

Swap memory if you can.
0
glenn_1986Commented:
wahooo thanks leonard, ive been tryin to fix this problem for ages and your instructions works perfectly!..:-) :-) :-)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage

From novice to tech pro — start learning today.