• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1634
  • Last Modified:

Windows 98 machine can't access my XP Machine on my network neighborhood...

Hi, I have just setup a home network, well, trying to anyways.  I have it so that both use the same Workgroup name, which is HOME.  On my XP PRO machine, I can go to Network Neighborhood and view both my computer and my fiances (the WIN 98 machine) files that are being shared.  However, when on her Windows 98 machine, if I go to network neighborhood, and then try to access my Windows XP machine, I get a password box that pops up and says,

\\BRYANSCPU\IPC$

no password works.  I am not sure what I am missing or doing wrong.

Her computer does NOT come up on when I am trying to set permissions and I do a find on the network (under Advanced in sharing).  SO I can see her CPU in network Neighborhood, but can't when searching for it.

Can anyone help?

Thanks
Bryan
0
jag5311
Asked:
jag5311
  • 5
  • 5
  • 2
  • +3
1 Solution
 
Christopher McKayMicrosoft Network AdministratorCommented:
Hi jag5311,
You need to have the username used on the Win98 machine listed as an account on the Win XP machine, then give the account permission to use the shared.

Hope this helps!

:o)

Bartender_1
0
 
jag5311Author Commented:
well, I went in and created a limited account with the Windows 98 machine name.

Then I went to the folder I am sharing and went to permissions and then did a search with advanced and found the machine name, which turned out to be  \\BRYANSCPU\Bianca

Well, now when I access BryansCpu from the Windows 98 machine, I get a

"\\Bryanscpu is not accessible.  No permission to access resource"

so that is where I am now :(
0
 
Christopher McKayMicrosoft Network AdministratorCommented:
You need to create an account with the username being used on the Windows 98 machine, not the machine name.

Hope this helps!

:o)

Bartender_1
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
greyknight17Commented:
I have a short tutorial on setting up win98 and winXP on a network.  Although it's using a crossover cable (which you may or may not be using), it should be similar.  My guess is that you need to install Netbeui:

http://www.greyknight17.com/networking.htm

Hope that helps.
0
 
Gareth GudgerCommented:
Bartender is right. The Windows 98 machine needs to be logging in to Windows when it boots up with the same username and password that you created on the XP machine. Alternatively, you can just enable the guest account on the XP box if security is not an issue.
0
 
mercury8001Commented:
i ran i to this prob a cople of days ago. to get by it. i when't in to the sharing propertys of a folder i wanted to share on the hard drive of the XP comp and i change the securaty setings at the bottom of the tab. i can remeber exatly what it sayed, i thing there was a link at the bottem that brat u to the the seting it was just a little check box.

hope this helps
0
 
jag5311Author Commented:
Ok, so I have done what you guys said.  I created a limited account on Windows XP and gave it my fiances Computers username and password.  Then I restarted both machines.  However, the 98 machine still cannot gain access to my windows xp machine.  I just installed Netbeui on both the 98 and my xp machine.

Does Netbui promote a security risk?  For one, I do have a router installed with NAT firewall, so that obviously should help my security.

Anyways, I will give this netbui thing a chance and let you know.
0
 
jag5311Author Commented:
Ok, installed NetBUI on both machines and it still doesn't work.

When trying to access BryansCPU in network neighborhood, I still get a password box that pops up saying,

"\\BRYANSCPU\IPC$
Enter password


argh!!!!!! This is royally pissing me off.

Mercury, I can't even see folders on my XP machine when trying to view them from the 98 machine, thats the problem. I can ping 192.168.0.2 which is the 98 machine.  it comes back flawless
0
 
Christopher McKayMicrosoft Network AdministratorCommented:
I still think you're experiencing diffuculties with the accounts, but just in case, here's a link to common issues with networking between Win9x and Windows 2000/XP
http://www.chicagotech.net/w9xfaqs.htm

Hope this helps!

:o)

Bartender_1
0
 
jag5311Author Commented:
Thanks Bartender, however I couldn't find anything in that article that would have helped me.  I may scan through it again to verify this, but for now, here is an update


UPDATE----------------------------

Here are the current facts of my setup

1.  Trying to setup a home / filesharing network between Windows 98 SE2 and Windows XP

2.  I have file sharing enabled on both

3.  There are no firewalls running other then what my router has built into it (Netgear MR814)

4.  I have NetBios installed on Windows XP, greyed out in Windows 98

5.  I have netbui installed on both

6.  I have a username of Bryan on my Windows XP machine.  I have made the computer name also Bryan

7.  The username is Bianca brooke on the Windows 98 machine.  I have created an account (Limited) on my Windows XP Machine with the username of Bianca brooke.  I have given it the same password that is uses on the Windows 98 machine.

8.  I have added a user to the Windows 98 machine of username Bryan and gave it the same password I use on my Xp Machine

9.  When viewing Network Neighborhood in Windows 98, I see both computers.

10. When viewing Network Neighborhood in Windows XP, I see both computers AND can access both computers

11.  I can access the Windows 98 shares through Network Neighborhood on the Windows 98 machine.

12.  When in Windows XP, I go to a folder to enable File Sharing on it.  I then go to PERMISSIONS and see that EVERYONE has READ rights to it.  I go to ADD and then ADVANCED.  I then hit the FIND button.  I look for Bianca brooke on the list.  The only one I see is Bianca, but there is no brooke to it, so I don't know why that would be different.  Her computer has username of Bianca brooke and a computer name of Bianca brooke.

CURRENT PROBLEM

1.  When I access Network Neighborhood through the Windows 98 Machine, Windows 98 provides to "shortcuts" to the share systems.  If I click on "Bryan", I get a password dialogue box that says

"\\Bryan\ICP$"

I try many different passwords that are familiar to me and none work.

Sometimes if I go up through the ENTIRE NETWORK, and then MICROSOFT WINDOWS NETWORK, and then HOME, and I try to access Bryan (Bryan), I get an error message that says something like, "Don't have permissions to access this resource" or something like that.

So there are the facts.  Thank you,

Bryan
0
 
Christopher McKayMicrosoft Network AdministratorCommented:
A username shouldn't contain spaces.

I would recommend you try this:

Create a username that is 8 characters or less in length.
Create this username on both the XP and the Windows 98 machines.
Allow access to your shares to this username.
attempt to connect while logged in under this new username in Windows 98.

Hopefully this will provide the result you are looking for.

:o)

Bartender_1
0
 
jdsmortCommented:
Simple answer. Set up a user on XP that is exactly the same as that on W98, and with the same password.
Next, make sure that the user has to log onto the W98 machine with the password.
There must be a logon to allow validation in an NT environment.
0
 
jag5311Author Commented:
All Fixed.  Thanks Bartender, your answer worked perfectly.  Her username was 13 characters long including the space (Bianca Brooke)

I shortened it to Bianca and all became well in the world.

Thanks again.

side note, tutorials have said that setting the IP addresses manually on the machines is better for a networking environment, however, when I do it (by setting hers to 192.168.0.2 and mine to 192.168.0.3 and the subnet mask to 255.255.255.0, I lose all connectivity to the internet.  Not sure why this is.

Do I have to change some configs in my router for this to work?

Thanks again,
Bryan
0
 
jdsmortCommented:
Check the address assigned to your router(gateway address), and make sure the other addresses are of the same subset.
Often a router has a gateway address of 192.168.1.1,  so then use 192.168.1.xxx as your base for the assigned addresses, using greater than 1 for the final digit.
0
 
Christopher McKayMicrosoft Network AdministratorCommented:
Thanks for the points, I'm glad you managed to get the difficulty corrected.

If the response from jdsmort doesn't correct the issue, then you need to tell us the settings on your router. (Is is running DHCP, if not, then what is the IP address, and subnet mask for the router?)

:o)

Bartender_1
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

  • 5
  • 5
  • 2
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now