Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

configure windows xp to connect to sybase12 server

Posted on 2004-04-18
13
Medium Priority
?
9,076 Views
Last Modified: 2007-12-19
I installed 'Sybase for Windows NT' on Windows XP.
What do I need to configure on my pc to be able to connect to sybase12 sqlserver?
This is what I have tried:

1) Control panel->Administrative Tools->Data Sources(ODBC)
2) Add User DSN
3) Select SQL Server
4) Information populated:
Name - CAT(database name)
Description - CAT(database name)
Server - syb12(sql server name)
5) Click Next
6) Toggle for selection ' With sql server authentication using a login id and password entered by the user. Click on 'Client Configuration' button -
7) At 'Add Network Library Configuration' window, populate this information:
Server alias - syb12
Server name - 100.4.30.50
Uncheck dynamically determine port (enter port number 4101, previously defaulted to 1422)
Check connect to sql server to obtain default settings for the additional configuration options
login  id - sa
password - password
8)Click next
9)Getting this error message:
Connection failed
SQLState:'01000'
[Microsoft][ODBC SQL Server Driver][TCP/IP Sockets]ConnectionRead(recv())
Connection f ailed:
SQLState:'08501'
SQL Server Error:11
[Microsoft][ODBC SQL Server Driver][TCP/IP Sockets]General network error. Check your network documentation.

Is my configuration above correct:?
0
Comment
Question by:JamilahMS
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
  • 3
  • +1
13 Comments
 
LVL 15

Expert Comment

by:namasi_navaretnam
ID: 10858916
> 3) Select SQL Server

You need odbc driver for Sybase. Also You will need to install Sybase client software on your PC.

Regards-
0
 
LVL 13

Expert Comment

by:alpmoon
ID: 10864690
I suggest to test direct open client connection first. I am not sure whether you have to use ODBC or not. If you don't have to, just use Open Client connection.

Click start, then Sybase, then dsedit. In dsedit, you can add your server by using "server objects" and try your connection by using ping.

Good luck!
0
 

Author Comment

by:JamilahMS
ID: 10865350
Yes, already installed Sybase client.
Ping is ok.
Unable to connect using client isql.
Configure odbc as above but getting connection failure during configuration at step 7.
Is the way I configure odbc correct?
0
Moving data to the cloud? Find out if you’re ready

Before moving to the cloud, it is important to carefully define your db needs, plan for the migration & understand prod. environment. This wp explains how to define what you need from a cloud provider, plan for the migration & what putting a cloud solution into practice entails.

 
LVL 15

Expert Comment

by:namasi_navaretnam
ID: 10865386
>Unable to connect using client isql.

what is the exact error message?

For odbc to work, connection using isql should work first.
0
 

Author Comment

by:JamilahMS
ID: 10865413
Ste4ps used:
1) Control panel->Administrative Tools->Data Sources(ODBC)
2) Add User DSN
3) Select SQL Server
4) Information populated:
Name - CAT(database name)
Description - CAT(database name)
Server - syb12(sql server name)
5) Click Next
6) Toggle for selection ' With sql server authentication using a login id and password entered by the user. Click on 'Client Configuration' button -
7) At 'Add Network Library Configuration' window, populate this information:
Server alias - syb12
Server name - 100.4.30.50
Uncheck dynamically determine port (enter port number 4101, previously defaulted to 1422)
Check connect to sql server to obtain default settings for the additional configuration options
login  id - sa
password - password
8)Click next
9)Getting this error message:
Connection failed
SQLState:'01000'
[Microsoft][ODBC SQL Server Driver][TCP/IP Sockets]ConnectionRead(recv())
Connection f ailed:
SQLState:'08501'
SQL Server Error:11
[Microsoft][ODBC SQL Server Driver][TCP/IP Sockets]General network error. Check your network documentation.
0
 
LVL 13

Expert Comment

by:alpmoon
ID: 10865437
Did you try ping in dsedit?
0
 

Author Comment

by:JamilahMS
ID: 10865489
Sorry,  cant find dsedit function.
Start->Sybase->
I only have these options:
CT-Library Reference
SQLServer Manager
SQLEdit
SSM Help Reference
Sybping
Wisql32

I ping ok via Sybping
0
 
LVL 15

Accepted Solution

by:
namasi_navaretnam earned 500 total points
ID: 10865640
Try sybase odbc drivers.

DataDirect:
http://www.datadirect-technologies.com/download/downloadindex.asp

EasySoft:
http://www.easysoft.com/products/2204/trial.phtml

Looks like you are using odbc driver for MS SQL Server.
0
 
LVL 13

Expert Comment

by:alpmoon
ID: 10865648
I haven't used XP so far. Either Windows XP is different or there is something wrong with your Sybase Client installation. But you can also check and edit Sybase interfaces file,
%SYBASE%\ini\sql.ini

If the entry for your server in sql.ini looks OK, isql should be working. Have you tried wisql?

You can also try isql in Command Prompt:
isql -Usa -S<server_name> -P<password>

(Server name is the name in sql.ini, not ip address)
0
 
LVL 13

Expert Comment

by:alpmoon
ID: 10865804
Btw. have you checked the version of Open Client ('Sybase for Windows NT') you have installed. wisql was part of an old version (maybe system 10), you should have SQLAdvantage instead.
0
 
LVL 1

Expert Comment

by:gottathink2
ID: 10880269
It looks to me like you are using the wrong ODBC drivers to connect to the Sybase database. You appear to be using the "[ODBC SQL Server Driver]" which I think is for Microsoft SQL server not Sybase.

Is the Sybase database on another, separate computer then the one you have installed the ODBC drivers on?

The dsedit utility is normally installed with the Sybase client libraries on the client computer, it should be under "Sybase" on the Start > All Programs menu.

If your Sybase server uses a custom port then you will have to add the port ID in the properties using dsedit. I see you did something similar in step 7 of your list which seems to imply you are using the wrong ODBC drivers.
0

Featured Post

Learn how to optimize MySQL for your business need

With the increasing importance of apps & networks in both business & personal interconnections, perfor. has become one of the key metrics of successful communication. This ebook is a hands-on business-case-driven guide to understanding MySQL query parameter tuning & database perf

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Are you an Exchange administrator employed with an organization? And, have you encountered a corrupt Exchange database due to which you are not able to open its EDB file. This article will explain all the steps to repair corrupt Exchange database.
By default Outlook 2016 displays only one time zone in the Calendar. The following article explains how to display two time zones in one calendar view.
Have you created a query with information for a calendar? ... and then, abra-cadabra, the calendar is done?! I am going to show you how to make that happen. Visualize your data!  ... really see it To use the code to create a calendar from a q…
In this video, Percona Director of Solution Engineering Jon Tobin discusses the function and features of Percona Server for MongoDB. How Percona can help Percona can help you determine if Percona Server for MongoDB is the right solution for …

722 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question