Solved

Windows service

Posted on 2004-04-19
2
568 Views
Last Modified: 2010-04-24
I've made a windows service which I installed but It didn't work, so I uninstalled it and corrected the problem.
But when I tried to reinstalled it it say that there already is a service with that name, how do I remove that faulty service
0
Comment
Question by:RonaldBiemans
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
2 Comments
 
LVL 6

Accepted Solution

by:
zulu_11 earned 500 total points
ID: 10859284
Hi,

Whenever you create a service and install it, the OS makes an entry in the Registry about the service name and the event viewer..now you say that you unistalled the application..then these entries should have been removed automatically by the unistallation process..but that has not happened.
To correct this you'll have to manually remove the entries from the Registry..

1   Open your registry editor..type regedit in run window
2   goto  HKEY_LOCAL_MACHINE\System\CurrentControSet\Services
3. Now look for the folder with the service name that you had created previously..say TestService..
    Delete that folder..
4. Now, look for the EventLog folder under the Services folder..this folder contains all the Event Viewer loggin information.
5. If you did not specify any event viewer loogin information in you code then by default the errors in your code would be put into the Application Log..so open the Application Log and remove the folder with the name of you service...
6. Save the registry and restart..
This should solve your problem,,

Regards

Zulu
0
 

Expert Comment

by:poojasureshkumar
ID: 15033010
Hi Zulu,
I have installed the service through installer.I got display "Installed successfully",but my service is not displayed on Services list.
I followed the same procedure on
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/secmod/html/secmod29.asp

Second issue is,
i created the same application in different system and installed the service.When i uninstall the service,still i am getting the outpur result.Also the Respective service is not listed in Services .

My email id is sureshunique@gmail.com

Pls help me out.

Thanks in Advance,
Suresh
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Creating an analog clock UserControl seems fairly straight forward.  It is, after all, essentially just a circle with several lines in it!  Two common approaches for rendering an analog clock typically involve either manually calculating points with…
It was really hard time for me to get the understanding of Delegates in C#. I went through many websites and articles but I found them very clumsy. After going through those sites, I noted down the points in a easy way so here I am sharing that unde…
Exchange organizations may use the Journaling Agent of the Transport Service to archive messages going through Exchange. However, if the Transport Service is integrated with some email content management application (such as an antispam), the admini…
Finding and deleting duplicate (picture) files can be a time consuming task. My wife and I, our three kids and their families all share one dilemma: Managing our pictures. Between desktops, laptops, phones, tablets, and cameras; over the last decade…

734 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question