PDF995 no longer works since server changed from terminal services remote admin mode to application mode

We have a Windows 2000 server which runs PDF995. Since we changed this server from terminal services remote admin mode to application mode, the PDF995 software has stopped working.

It was outputting empty PDF files and so I uninstalled the software and reinstalled. Now it doesn't work at all. Jobs just queue on the PDF995 printer and no output file is ever created.

Any idea how to get this working again?

Thanks,

rd707
LVL 4
rd707Asked:
Who is Participating?
 
moduloConnect With a Mentor Commented:
Closed, 500 points refunded.

modulo
Community Support Moderator
Experts Exchange
0
 
bda72Commented:
Just a thought...

Did you switch to "install" mode before you installed the app?

open cmd prompt
type change user /install
install app
open cmd prompt
type change user /execute
0
 
turn123Commented:
rd707, Please respond to the comments from the Experts.
See:  http://www.experts-exchange.com/help.jsp#hi49 Thank you, turn123 (s)
0
The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

 
rd707Author Commented:
Have now found a workaround for this issue.

Will request deletion.

Thanks,

rd707
0
 
turn123Commented:
ee_ai_construct,

I object to PAQ-ing the question and refunding points unless rd707 posts the workaround to this question.

Turn123
0
 
rd707Author Commented:
This is the INI file as it now stands:

[Parameters]
Quiet=0
Use GPL Ghostcript=1
Output Folder="f:\pdf995\output"
TS Enabled=0
Document Name=ClubCanvassePerCatProfiles.rep
User File=f:\pdf995\output\ClubCanvassePerCatProfiles.pdf
Output File=SAMEASDOCUMENT
Size=a4       8.3   11.7
Rotate Pages=0
Edit Rotate Pages=0
Level 1.3=1
Conversion Parameters=-sDEVICE=pdfwrite -q -dPDFSETTINGS=/prepress
-dCompatibilityLevel=1.3 -dNOPAUSE -dBATCH
[Debug]
EndDocPort1=1
EndDocPort2=1
EndDocPort3=1

While I was checking out the FAQ for the software
(http://www.pdf995.com/faq.html) I noticed this option:

TS Enabled=0

This sounded like a Terminal Server option to me...

I put this in my INI file and it worked but not as it did before. It started
creating files but with a different extension to before.

What happened before was that if you printed mydoc.doc, you got
mydoc.doc.pdf but now it produced mydoc.pdf.

I emailed pdf995 support to see if they could help. All they said was that
the TS Enabled=0 option would disable support for Terminal Server so I
should turn it off.

A few emails later I was explaining to HIM what the difference was between
the two Terminal Server modes leading me to conclude that perhaps this
setting was for Citrix only and they didn't really understand the
differences (if any) between the software operation under Citrix and
Terminal Services.

In the end I decided to change the bit of software that picked up the PDF to
search for the new file extension (.pdf rather than .doc.pdf) rather than
find out why it had stopped working.

Just to throw something else into the mix, the PDF995 guy asked me to
upgrade the version of PDF995 I was using to the latest version so I'm not
sure if setting this INI file option would have cured the old version of the
software.

Anyway, weeks later it is still working even after a server reboot.

Thanks,

Rob
0
 
bda72Commented:
Rob,
   Thanks for posting your solution. I've had many occassions like yours where I had to give tech support a crash course in TS\Citrix. It doesn't build a lot of confidence considering you're calling THEM for help. I've found most apps can be made to work on TS, but most companies don't test them and almost no company will extend their support to cover TS\Citrix.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.