Solved

Opening a port for Remote Access Software

Posted on 2004-04-19
4
524 Views
Last Modified: 2013-11-21
I'd like to open up a port for some software that I recently installed on my home PC.  I have a Cisco 1700 series and I'm not sure of the command for this.
0
Comment
Question by:avfc88
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 1

Expert Comment

by:badrox
ID: 10862170
It would depend on the config of the 1700...can you post your config?  (please remove all passwords) thanks.

0
 
LVL 51

Expert Comment

by:Netman66
ID: 10862211
You need to create an Access Control List, then add it to the external interface.

0
 

Author Comment

by:avfc88
ID: 10862681
Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime

memory-size iomem 25
clock timezone EST -5
clock summer-time EDT recurring
ip subnet-zero
no ip source-route
ip name-server x.x.x.x
ip name-server y.y.y.y
!
interface Serial0
 description
 ip address z.z.z.z 255.255.255.252
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nat outside
 no fair-queue
 no cdp enable
!
interface Serial1
 no ip address
 shutdown
 no cdp enable
!
interface FastEthernet0
description
 ip address 192.168.1.1 255.255.255.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nat inside
 speed auto
 no cdp enable
!
ip nat pool INTERNET x.x.x.x y.y.y.y  netmask 255.255.255.252
ip nat inside source list OUTSIDE pool INTERNET overload
ip nat inside source static tcp 192.168.1.254 8080 y.y.y.y 8080 extendable
ip nat inside source static tcp 192.168.1.254 80 x.x.x.x 80 extendable
ip classless
ip route 0.0.0.0 0.0.0.0 x.x.x.x
no ip http server
!
!
ip access-list extended OUTSIDE
 permit ip 192.168.1.0 0.0.0.255 any
no cdp run
banner motd ^CC
0
 
LVL 1

Accepted Solution

by:
badrox earned 500 total points
ID: 10862822
Well, depending on what port the software uses (in this example I'm going to use Microsoft Remote Desktop Services which is tcp port 3389)

Assuming you can telnet in and enable and conf term.

ip nat inside source static tcp <ip address of your machine> 3389 <your internet ip> 3389 extendable

Pretty sure that should do the trick for you.
0

Featured Post

Webinar: Aligning, Automating, Winning

Join Dan Russo, Senior Manager of Operations Intelligence, for an in-depth discussion on how Dealertrack, leading provider of integrated digital solutions for the automotive industry, transformed their DevOps processes to increase collaboration and move with greater velocity.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

PRTG Network Monitor lets you monitor your bandwidth usage, so you know who is using up your bandwidth, and what they're using it for.
When it comes to security, there are always trade-offs between security and convenience/ease of administration. This article examines some of the main pros and cons of using key authentication vs password authentication for hosting an SFTP server.
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question