Solved

Save Key in Regedit32.exe

Posted on 2004-04-19
4
147 Views
Last Modified: 2010-04-13
I am trying to save the HKEY_LOCAL_MACHINE in Windows 2000.

However it says the i do not have enough priviledges to save it, yet i am an administrator of the computer.

Any suggestions
0
Comment
Question by:gisvpn
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 86

Expert Comment

by:jkr
ID: 10861988
You need to have the 'Backup' privilege to be able to do that, which is not granted to administrators by default. Go to the 'Local Security Policies' control panel applet and grant them to the account or add the Administrator to the backup operators group.
0
 
LVL 8

Expert Comment

by:RevelationCS
ID: 10861989
might help to know the process you are taking to "save" the tree... also, are you logging in as "Administrator" or using a user id that was created and added to the adminitrators group? I did test it on my end (WIN2K pro) and had no problems saving it with my user id.. If you are logged in with a user id other than "Administrator" then it is a permissions issue or possibly the "Policy" settings for the user id/group that you are using. I would start by looking at that...
0
 

Author Comment

by:gisvpn
ID: 10863137
Hello thank you both for your posts.

jkr

I added my self to the "Backup Operators" group. This did not make a difference, it still says "Access Denid" :(

RevelationCS

I am going into regedit32.exe in%systemroot%\system32 and select HKEY_LOCAL_MACHINE and then clicking "Registry" > "Save Key..."  and im logging in using my local account which has been added to the administrators group and also now the Backup Operators group.

Still no luck :(


0
 
LVL 8

Accepted Solution

by:
RevelationCS earned 125 total points
ID: 10863455
I am assuming you mean that you are clicking on "EXPORT" with W2k

you might try checking your local security policy...

go under the Control Panel > Administrative Tools > Local Security Policy > Local Policies > User Rights Assignment

once here, check the "back up files and directories" to make sure it includes either of the groups your user id is listed under. not sure if this will help or not. You can also reference the following link for further information:
http://support.microsoft.com/default.aspx?scid=kb;en-us;322755&Product=win2000
and make sure you have all of the latest patches applied to your computer for windows 2000

one other option is to create a new user as an administrator and attempt to have him export the registry to see if you can isolate it to something being related to the userid itself...
0

Featured Post

Use Case: Protecting a Hybrid Cloud Infrastructure

Microsoft Azure is rapidly becoming the norm in dynamic IT environments. This document describes the challenges that organizations face when protecting data in a hybrid cloud IT environment and presents a use case to demonstrate how Acronis Backup protects all data.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

NTFS file system has been developed by Microsoft that is widely used by Windows NT operating system and its advanced versions. It is the mostly used over FAT file system as it provides superior features like reliability, security, storage, efficienc…
Changing a few Outlook Options can help keep you organized!
Are you ready to implement Active Directory best practices without reading 300+ pages? You're in luck. In this webinar hosted by Skyport Systems, you gain insight into Microsoft's latest comprehensive guide, with tips on the best and easiest way…

737 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question