Windows Update doesn't recognize I'm an Administrator

I'm logged on as "Administrator".  Computer name is "RMC-5".

When I try to run Windows Update, I get the following message:

"You may not have the necessary permissions to use all the features
of the program you are about to run."

The system then suggests I should run the program as an administrator,
and gives me the option of running it as "Administrator\RMC-5", if only
I can supply the necessary password.

If I enter the password I used when logging on, everything seems to
run fine.  However, I'd like to avoid having to go through this extra
step whenever I run Windows Update.  Can anyone tell me why the
system doesn't recognize that I'm already logged on as an administrator,
and how to fix it?

TIA.

Regards,
Mark Collier
mark_collierAsked:
Who is Participating?
 
NetminderConnect With a Mentor Commented:
User resolved; closed, 125 points refunded.

Netminder
Site Admin
0
 
matalyn1016Commented:
This sounds like a user profile issue. If you have followed Msft’s recommendations and renamed the Administrator accounts through Gpo’s your workstations will reflect the new policy and permissions may not have been set correctly. If you are logging into a 2000 domain ensure that the user account and profile have been created on the local computer for the domain.

I would check RMC-5’s users and ensure there is a valid Admin account and profile on the local computer. Additionally I would assign a known admin (usually the IT guys logon) admin rights and perform all updates logged on as that user. If you are working in a 2000 domain environment you can reduce your workload by distributing updates through Gpo’s to your clients.

Hope this helps.
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

 
wtrmk74Commented:
matalyn1016,
Thats what the link is !!!

wtrmk74
0
 
wtrmk74Commented:
hows it going
0
 
mark_collierAuthor Commented:
Thanks for trying to help me.  I fixed the problem on my own.  It did not have anything to do with a corrupt profile.  It turns out that the "Windows Update" shortcut, which is available to all users, had been changed.  The "Run As Another User" checkbox had been checked.  (It's cleared by default when Windows 2000 is installed.)  I cleared it, and the problem disappeared.
0
 
wtrmk74Commented:
glad it worked out for you

post a comment in the Community Support Section with a title of " delete Q's with points refunded"
with the URL to this post

and a moderator will be glad to give you your points back

take care
wtrmk74
0
All Courses

From novice to tech pro — start learning today.