Solved

IE 6 - links won't open

Posted on 2004-04-19
18
16,948 Views
Last Modified: 2012-06-27
Problem with Internet Explorer 6 on Windows XP Pro

Basic problem:  IE will open any website just fine.  Clicking on most (90%) hyperlinks results in no page opening.  Right clicking on the link and choosing "Open in New Window" doesn't work either.  Printing the web page won't work.  This is consistent with both Cable Modem and DialUp access (tried both).

Strange observations:  Clicking on a hyperlink gives a brief (split second) refresh of screen as if it's opening the window but doesn't complete the job.  Also, using AOL web browser gives the same results EXCEPT that clicking on a hyperlink opens a BLANK window (as does rightg clicking).

Work performed:  I've done a complete SpyBot scan (zero problems).  I unchecked IE6 from the Add/Remove Programs (to uninstall).  Rechecked to reinstall (no change).  Microsoft has a Knowledge Base article I found which had me regsvr32 about 6 DLL files as well as verify 3 Registry settings (all 3 Registry settings were fine, and all 6 DLL files registered OK).  Not running any popup blocking software and no firewall software was running at time of tests.

This one has me completely baffled.  Any ideas?

This one is for a VIP, so the first person who can give me the right answer will get an additional 500 points via another posted question... I need to fix this THAT MUCH.  If someone gets me on the right track I'll award the points to them as well.  Thanks, All.

Jim
0
Comment
Question by:TXShaman
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
  • 2
  • +5
18 Comments
 
LVL 29

Expert Comment

by:blue_zee
ID: 10864225

Try repairing your IE:

How to Reinstall or Repair Internet Explorer and Outlook Express in Windows XP
http://support.microsoft.com/default.aspx?scid=kb;en-us;318378

Zee
0
 
LVL 29

Accepted Solution

by:
fibo earned 500 total points
ID: 10864235
Hi Jim,
I once had a similar problem and found no esay way out of this.
Workarounds if your VIP conems within the next hour:
- Install Opera -in my case this did work and was fine [except it does not work with Outlook Web Access, even when masquerading Opera as IE]
- "navigate" by link copy (from the page) and paste (into the adress line) [but does not work with javascript menu handling]

Now, if you have more time, have a look at IE settings, specifically the "advanced" and try to find which magical setting might solve your problem, or at least minimize it. Problem #1 is presumably this obscure parmeter that allows (or not) "multi-domain pages". Do some experimentation there...

Good hunt!

0
 
LVL 29

Expert Comment

by:blue_zee
ID: 10864351
0
Windows running painfully slow? Try these tips..

Stay away from Speed Up Computer Programs that do more harm than good.
Try these tips instead.
Step by step instructions in trouble shooting Windows Performance issues.

 
LVL 1

Expert Comment

by:Staceman03
ID: 10864355
Run Hijackthis and post the results....avail though Google...

Disable 3rd Party Browser Extentions in Internet Options/Tools/advanced
0
 
LVL 10

Expert Comment

by:eeBlueShadow
ID: 10868526
Not that this will be much consolation at all but this person ( http://www.webdevforums.com/showthread.php?t=3497 ) found the error fixed itself. If could be something as simple as emptying the Temporary Internet Files folder (Tools->Internet Options->Delete Files).
0
 
LVL 10

Expert Comment

by:eeBlueShadow
ID: 10868537
Also, this person ( http://www.daniweb.com/techtalkforums/showthread.php?t=880 ) found that the Disable 3rd Party Extensions option fixed but you need to restart IE
0
 
LVL 22

Expert Comment

by:_TAD_
ID: 10870659

I had this same problem once.  I don't know exactly what fixed it, but basically I ran the gambit.

repaired IE
Cleared all contents of HOSTS file (search pc for HOSTS)
ran SpyBot Search and Destroy
Turned off Execute ActiveX scripts (in advanced settings)
cleared cache
ran Trend Micro House call virus scanner.


The computer I was fixing actually had a lot of problems.  each one of those steps above resolved something (it was pretty ugly).

I hope you get your problem fixed!
0
 
LVL 22

Expert Comment

by:_TAD_
ID: 10870677


Oh... and also, don't forget to enable scripting and java.

(under security and advanced settings)
0
 
LVL 1

Author Comment

by:TXShaman
ID: 10872304
I'll be working on the VIP laptop all day tomorrow.  Tried a few of these (no luck, but the newer posts I'll try tomorrow and will try to resolve this soon so I can award points).  Thanks for posting so many possible options... really appreciate the help.

Jim
0
 
LVL 27

Expert Comment

by:Asta Cu
ID: 10874076
You're not alone with this problem; some have reported this after an IE 6 service pack.

Are both XP and IE 6 updated with all service packs from WindowsUpdate?

Can you access WindowsUpdate without problem?

Have you tried resetting all IE settings (after jotting down preferences to reinstate, if needed) to the default settings?

Have you checked the privacy options to try using the edit and paste URL of a problem link and choosing allow to test?

All changes to settings in IE require your closing it for changes to take.  Also clear cache, including offline content and history files (again) and any cookies that may be related to the problem sites you're trying to link to.

What is the source of the "links" you're trying to access and can't?  Do Favorites still work?  Just Email links the problem?

Have you cleared autocomplete items and renamed HOSTS oldhosts and rebooted to test?  No change at all?

So to recap, you've already (or should) try ....
1) IE -> Tools -> Internet Options
2) General tab delete related cookies (or save to disk first)  and temporary internet files, including all offline content
3) Advanced tab--> restore defaults and click Apply
4) Programs tab -> reset web setting and back on General, type in your desired home page after the reset.  Also check default Email program here for accuracy.
5) Privacy tab Default levels
6) Security tab and for each zone set levels to Default Levels then click OK...  
7) Close IE for settings changes to take, reboot and try again

Check restricted zones, if problem links listed there.

Also, as you'll probably see or have already seen, these files may need to be verified.  For Windows XP - check system files as follows
->  Start-run-  sfc /scannow (space after sfc) and have Windows XP disk handy.

May need to check and verify these were correct versions and properly registered.  The msjava.dll may or may not apply; I've upgraded to Sun Java, version 2 1.42.04 (if memory serves), link also follows.  Microsoft VM (Java) is phasing out, will no longer be supported in 09/2004 or so.

Start-->Run-->regsvr32 urlmon.dll
Start-->Run-->regsvr32 Shdocvw.dll
Start-->Run-->regsvr32 Msjava.dll
Start-->Run-->regsvr32 Actxprxy.dll
Start-->Run-->regsvr32 Oleaut32.dll
Start-->Run-->regsvr32 Mshtml.dll
Start-->Run-->regsvr32 Browseui.dll
Start-->Run-->regsvr32 Shell32.dll

Others have already given great recommendations, and sure hope you've been helped.  If more is needed, please check the LOGS and verify user accounts, etc. to ensure login information is correct and no restrictions in place or errors overlooked but logged.

I'm not getting Email notifications from this site today, and advised Engineering; but will check back when I can.

There is a maximum of 500 points, by the way, per question according to our Guidelines.

Asta









0
 
LVL 27

Expert Comment

by:Asta Cu
ID: 10874138
Forgot to ask if this is Engilish or another language....  Here's why (cut/paste and source follows).


Internet Explorer May Not Connect to Web Sites with Multibyte Character Set Link or URL
View products that this article applies to.
This article was previously published under Q328824
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows Registry

SYMPTOMS
If you use Internet Explorer to connect to a Web site whose link or URL contains multibyte character sets (such as Japanese), Internet Explore may not connect to the site.
CAUSE
This behavior is caused by a parsing error when Internet Explorer reads the characters in the URL or hyperlink.
WORKAROUND
WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To work around this behavior, you must add a registry value. Add a DWORD registry value named MBCSServername with a data value of 0 to the following registry key:
HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\CurrentVersion\Internet Settings

This new value resolves the behavior in most cases. However, if the default language for Microsoft Windows is set to anything other than United States (for example, Korean), connectivity problems may still occur.
The information in this article applies to:
Microsoft Internet Explorer 5.5 for Windows 2000 SP 2
Microsoft Internet Explorer version 6 for Windows XP
Microsoft Internet Explorer version 6 for Windows 2000
Source link:  http://support.microsoft.com/default.aspx?scid=kb;en-us;328824

Please also make sure that the "links" are valid hyperlinks.  Example, if links are added to some word processors, but not activated and/or followed by a line return, may not be a valid hyperlink and therefore not work properly.  OR it could be truncated or contain an invalid character at the end.  Try cut/pasting a sample link here for us and/or into the address bar and verify that it doesn't contain an end character and/or is truncated.  Here's another possible link:

http://support.microsoft.com/default.aspx?scid=kb;en-us;327010&Product=ie600




0
 
LVL 1

Author Comment

by:TXShaman
ID: 10891229
Installed Opera as a temporary solution, and lo and behold the hyperlinks work and right-clicking to open in new window works... so this tells me its definitely something with IE6.

I'm going to do the complete uninstall/reinstall of IE6 and see if it works.  Will post results soon.

Jim
0
 
LVL 29

Expert Comment

by:fibo
ID: 10978710
Jim,

Could you tell us where you stand and what did faill / succeed?
0
 
LVL 1

Author Comment

by:TXShaman
ID: 10979364
I've accepted fibo's answer since Opera seems to be the only way for the client to successfully access specific hyperlinks as well as "Open in New Window"...

Thanks, all... if I ever do figure this one out I'll resubmit the solution here.

0
 

Expert Comment

by:jweigold
ID: 11422593
Hi guys -

I've got the same problem and I have just spent two hours on with Microsoft - no luck yet.  The intersting thing is I can get it to work if I start in safe mode with networking.  That leads me to believe it's some kind of 3rd party application that loads at startup which is preventing the navigation.  I am trying to go through them 1 by 1, but no luck yet.

Another website said it could be solved by removing Yahoo! Campanion, which I don't have installed.  However, your VIP may have it so check it out!

Any ideas?
0
 
LVL 1

Expert Comment

by:Staceman03
ID: 11422633
Hae your tried Fix WinsockXP?  It/s mostly for cennectivity problems, but I have found it helpful to reset other settings...

http://www.spychecker.com/program/winsockxpfix.html
0
 

Expert Comment

by:jweigold
ID: 11443275
I tried the winsock and got nothing.  Tonight I went through and started uninstalling all non essentials - somehow it worked!  Of course now it's hard to pin the source of the difficulty because I got rid of about ten things.  Good luck to anyone else who has this problem....it's incredibly frustrating!
0
 
LVL 1

Expert Comment

by:Staceman03
ID: 11446288
Sometimes cleaning house helps!  Glad you got it fixed, good luck!
0

Featured Post

On Demand Webinar - Networking for the Cloud Era

This webinar discusses:
-Common barriers companies experience when moving to the cloud
-How SD-WAN changes the way we look at networks
-Best practices customers should employ moving forward with cloud migration
-What happens behind the scenes of SteelConnect’s one-click button

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Enterprise Mode 4 71
Adware on Android hooked into Chrome 6 66
IE11 cannot send an email using a gmail account 2 41
CSS Style on Chrome 1 57
Problem I downloaded the Microsoft Internet Explorer 9 Beta, today, to give it a test drive and maybe write a review for the site, and it failed miserably and got stuck in a crash restart loop. The error message given is as illustrated below i…
Today, still in the boom of Apple, PC's and products, nearly 50% of the computer users use Windows as graphical operating systems. If you are among those users who love windows, but are grappling to keep the system's hard drive optimized, then you s…
This Micro Tutorial will demonstrate how to add subdomains to your content reports. This can be very importing in having a site with multiple subdomains.
Shows how to create a shortcut to site-search Experts Exchange using Google in the Chrome browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch the Search Engine Menu: In chrome, via you…

739 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question