Solved

routing problem with aliases interfaces

Posted on 2004-04-19
4
433 Views
Last Modified: 2010-03-18
Running RedHat 9.0 I added 5 virutal eth interfaces as follows: The problem
is that I can only access ifcfg-eth0 AND ifcfg-eth0:0 outside the local
network. The remaining  virtual IP are only available from the local
network.

 I checked any problems with the firewalls. I also added route -n output. I
have done this with sucess on other RH boxes and an stumped as to why this
is working. Any help would be greatly appreciated.

ifcfg-eth0, ifcfg-eth0:0, ifcfg-eth0:1, ifcfg-eth0:2, ifcfg-eth0:3,
ifcfg-eth0:4

DEVICE=eth0 **WORKS**
ONBOOT=yes
BOOTPROTO=static
IPADDR=209.113.151.18
NETMASK=255.255.255.128
GATEWAY=209.113.151.1

Contents of eth:0   **WORKS**
DEVICE=eth0:0
ONBOOT=yes
BOOTPROTO=static
IPADDR=209.113.151.30
NETMASK=255.255.255.128
GATEWAY=209.113.151.1


Contents of eth0:1  **DOESN'T WORK**
DEVICE=eth0:1
ONBOOT=yes
BOOTPROTO=static
IPADDR=209.113.151.31
NETMASK=255.255.255.128
GATEWAY=209.113.151.1


[root@cp sbin]# ./route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use
Iface
209.113.151.0   0.0.0.0         255.255.255.128 U     0      0        0 eth0
169.254.0.0     0.0.0.0         255.255.0.0     U     0      0        0 eth0
127.0.0.0       0.0.0.0         255.0.0.0       U     0      0        0 lo
0.0.0.0         209.113.151.1   0.0.0.0         UG    0      0        0 eth0
0.0.0.0         209.113.151.1   0.0.0.0         UG    0      0        0 eth0
0.0.0.0         209.113.151.1   0.0.0.0         UG    0      0        0 eth0
0.0.0.0         209.113.151.1   0.0.0.0         UG    0      0        0 eth0
0.0.0.0         209.113.151.1   0.0.0.0         UG    0      0        0 eth0
0.0.0.0         209.113.151.1   0.0.0.0         UG    0      0        0 eth0
0.0.0.0         209.113.151.1   0.0.0.0         UG    0      0        0 eth0
0.0.0.0         209.113.151.1   0.0.0.0         UG    1      0        0 eth0
0.0.0.0         209.113.151.1   0.0.0.0         UG    1      0        0 eth0
0.0.0.0         209.113.151.1   0.0.0.0         UG    1      0        0 eth0
0.0.0.0         209.113.151.1   0.0.0.0         UG    1      0        0 eth0
0.0.0.0         209.113.151.1   0.0.0.0         UG    1      0        0 eth0
0.0.0.0         209.113.151.1   0.0.0.0         UG    1      0        0 eth0


Snippet from ifconfig
eth0      Link encap:Ethernet  HWaddr 00:04:75:E3:35:8C
          inet addr:209.113.151.18  Bcast:209.113.151.127
Mask:255.255.255.128
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:82905120 errors:0 dropped:0 overruns:1 frame:0
          TX packets:43780708 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:629400957 (600.2 Mb)  TX bytes:571159821 (544.7 Mb)
          Interrupt:10 Base address:0xa400

eth0:0    Link encap:Ethernet  HWaddr 00:04:75:E3:35:8C
          inet addr:209.113.151.30  Bcast:209.113.151.127
Mask:255.255.255.128
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:82905120 errors:0 dropped:0 overruns:1 frame:0
          TX packets:43780708 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:629400957 (600.2 Mb)  TX bytes:571159821 (544.7 Mb)
          Interrupt:10 Base address:0xa400

eth0:1    Link encap:Ethernet  HWaddr 00:04:75:E3:35:8C
          inet addr:209.113.151.31  Bcast:209.113.151.127
Mask:255.255.255.128
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:82905120 errors:0 dropped:0 overruns:1 frame:0
          TX packets:43780708 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:629400957 (600.2 Mb)  TX bytes:571159821 (544.7 Mb)
          Interrupt:10 Base address:0xa400






0
Comment
Question by:duficy
  • 2
4 Comments
 
LVL 40

Accepted Solution

by:
jlevie earned 125 total points
ID: 10865867
I'd recommend that you remove the GATEWAY line from ifcfg-eth0:*. It isn't necessary and just messes up the routing table.

Your interfaces are up and running, as proved by the fact that you can access them from the local LAN. So it looks like your router or upstream provider has something not right that is preventing access.
0
 
LVL 9

Expert Comment

by:Alf666
ID: 10871373
Jlevie's right about the GATEWAY lines.

I'm just wondering : Are these your real IP addrs ? If yes, I can apparently ping all of them from where I am.

What does not actually work ?
0
 

Author Comment

by:duficy
ID: 10871467
I was hoping jlevie would respond ;-)

I am my own worse enemy. My firewall was blocking the 209.113.151.31 - 209.113.151.49 range. I thought I had checked but obviously not. I opened up ping just to make troubleshooting easier. I till turn off ping.

Thanks for all the help.

Andrew
0
 
LVL 40

Expert Comment

by:jlevie
ID: 10871667
That's pretty much what i figured it had to be... I'm glad you were able to find the problem quickly and fix it.
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
This tutorial demonstrates a quick way of adding group price to multiple Magento products.
I designed this idea while studying technology in the classroom.  This is a semester long project.  Students are asked to take photographs on a specific topic which they find meaningful, it can be a place or situation such as travel or homelessness.…

943 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now