Solved

Public Folders Issue

Posted on 2004-04-19
11
497 Views
Last Modified: 2009-07-29
Greetings to all the Experts,

I am administering SQL 2000 and exchange 2000 environment.
The past weekend I had a system crash, and I had to restore all data from the back, which all went ok (Thank God).

The exchange data had corruption and that includes the public folders even though we are not using them. As a result I didn’t have a backup for it, and there for I didn’t restore it.
So I had to leave dismounted until now, but now users are seeing message when they open their mailboxes, and click on folders. The message is saying that “the service is no longer available” then they can click ok and the message goes away.
This message is about the public folders, so now I have to do something to get them to mount.
I tried every command line from Microsoft Web Site, which was saying “Successfully” at the end of each one of them but it still won’t mount, and then I went a head and deleted the pub1.stm and pub1.edb, and when I tried to mount the public store it created new once, then I went to public folders in the exchange system manager, right clicked on public folders, then connect to, then I selected my server.
Now when I right click on public folders and click view system folders it gives the following message from Exchange System Manager:
The http service user by public folders is not available, possible causes are that public store are not mounted and the information store is not running.

ID no: c1030af3
Exchange System Manager

The problem is that the users are still seeing the same message “Server No Longer Available” of course because the public is still does not exist in the mailbox, in the folders area.

Any ideas any suggestions are highly appreciated.

MJ
0
Comment
Question by:mjalmassud
  • 4
  • 2
  • 2
  • +2
11 Comments
 
LVL 3

Expert Comment

by:ans-ansdenver
ID: 10865636
Your error code recommends that you use "IISRESET/restart": http://support.microsoft.com/default.aspx?scid=kb;en-us;202013
Which makes sense since you are seing the HTTP Service Error

ans
0
 
LVL 1

Author Comment

by:mjalmassud
ID: 10865733
I am running a cluster and I had to go to the cluster administrator, then took the http virtual server offline, then back online.
I am still having the same problem.

thank you for the nice comment ans-ansdenver.
0
 
LVL 8

Expert Comment

by:ErikKvK
ID: 10866647
If you have a public store, then you need to recreate a MAPI public hierarchy. Right click the public store and select create public folder hierarchy. Chances are that this will not succeed, then on the referenced articles there are some directions on where in the configuration partition of AD you can find settings for this.

Outlook Problem is probably with the System public folders not being present (OAB, Outlook 10 security settings and Schedule free/busy).

Check out these articles on public folders, not sure if they will help.
http://support.microsoft.com/?kbid=313865
http://support.microsoft.com/?kbid=258509
http://support.microsoft.com/?kbid=257666

PS. I would try to get the 'empty' store recovered from tape if possible.
0
 
LVL 20

Expert Comment

by:ikm7176
ID: 10866700
0
 
LVL 1

Author Comment

by:mjalmassud
ID: 10868844
ikm7176, thank you for the nice comment.
 it has the same question that I had, but they didn't post an answer yet.

I'll check on it again some other time.

thanks again
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 
LVL 1

Author Comment

by:mjalmassud
ID: 10875197
Hi all,

first of all I wanna thank you all for trying to help me in the public folder issue.
I've got it to work, and I would like post the fix here so if somebody else goes through the same problem the will find the answer here.

after I had the public folder to mount but not apear in the OWA, where is shows the service is no longer avaiable, I went a head and dimount the data base, and I ran the eseutil on it once with the /g switch, and then with the /r switch.
after that I mounted the data base then it apeared in the OWA.

how can I close this question?

thanks

0
 
LVL 8

Expert Comment

by:ErikKvK
ID: 10875783
Post a zero point question in the moderator topic area and ask for a refund.

Look in the Help for Experts Exchange for more info on  this.
0
 
LVL 1

Author Comment

by:mjalmassud
ID: 10877687
CORRE CTION!!!

THE SWITCHES I USED ARE /g and /d.

sorry guys
0
 
LVL 20

Expert Comment

by:ikm7176
ID: 10877724
please post the solution on the above listed link. it always good to share your knowledge... :)

0
 
LVL 1

Accepted Solution

by:
Computer101 earned 0 total points
ID: 11137103
PAQed, with points refunded (500)

Computer101
E-E Admin
0

Featured Post

Wish Marketing would stop bothering you?

Is your marketing department constantly asking for new email signature updates? Are they requesting a different design for every department? Do they need yet another banner added? Don’t let it get you down! There is an easy way to manage all of these requests...

Join & Write a Comment

Suggested Solutions

"Migrate" an SMTP relay receive connector to a new server using info from an old server.
Marketers need statistics and metrics like everybody else needs oxygen. In this article we explain how to enable marketing campaign statistics for Microsoft Exchange mail.
In this video we show how to create a Distribution Group in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >>…
In this video we show how to create an Accepted Domain in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Ac…

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now