Solved

Can't ping remote router interface over a bridged Multilink PPP connection.

Posted on 2004-04-19
4
1,436 Views
Last Modified: 2012-06-27
I know this must be something simple - but I can't find any relevant information.

I have two 2620s setup to use a multilink
interface to combine two T1s into a single
fat pipe. IP routing is off and I'm simply
bridging the two nets.

          ----------
          |         | gateway to internet
          ----------
               |
               |         LAN-A 10.10.x.x
     ---------------------------------------
               |
               |
          ----------
          |         |  2620-A
          ----------
             |   |
             |   |
   T1-A   |   |   T1-B
             |   |
             |   |
          ----------
          |         |  2620-B
          ----------
               |
               |    LAN-B 10.10.x.x
 ------------------------------------------------

All the hosts on LAN-A can ping hosts on
LAN-B and vice verse. Everything seems to
work fine....

EXCEPT...

If I try to telnet to or ping the Fastethernet
interface on the remote segment I can't?
The symptoms are the same for hosts on LAN-A
trying to reach 2620-B or the hosts on LAN-B
trying to reach the hosts on LAN-A.

Also - from either routers CLI I can't ping
anything on the remote end.

Any help is greatly appreciated.

Router configs below:

2620-A
Using 1402 out of 29688 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname blah
!
enable secret blah
!
ip subnet-zero
no ip routing
!
!
ip name-server blah
!
!
!
!
interface Multilink1
 no ip address
 no ip route-cache
 no ip mroute-cache
 load-interval 30
 arp arpa
 arp timeout 0
 no cdp enable
 ppp multilink
 multilink load-threshold 1 either
 no ppp multilink fragmentation
 multilink-group 1
 bridge-group 1
!
interface FastEthernet0/0
 ip address 10.10.10.254 255.255.0.0
 no ip route-cache
 no ip mroute-cache
 no keepalive
 speed auto
 full-duplex
 bridge-group 1
!
interface Serial0/0
 bandwidth 1536
 ip unnumbered Multilink1
 encapsulation ppp
 no ip route-cache
 no ip mroute-cache
 no fair-queue
 ppp multilink
 multilink-group 1
!
interface Serial0/1
 bandwidth 1536
 ip unnumbered Multilink1
 encapsulation ppp
 no ip route-cache
 no ip mroute-cache
 no fair-queue
 ppp multilink
 multilink-group 1
!
ip classless
no ip http server
!
snmp-server community public RO
no snmp-server enable traps tty
bridge 1 protocol ieee
!
line con 0
 exec-timeout 0 0
 password 7 blah
 login
line aux 0
line vty 0 4
 password 7 blah
 login
!
end


2620-B
Using 1354 out of 29688 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname blah
!
enable secret 5 blah
!
ip subnet-zero
no ip routing
!
!
ip name-server 10.10.20.11
!
!
!
!
interface Multilink1
 no ip address
 encapsulation ppp
 no ip route-cache
 no ip mroute-cache
 load-interval 30
 ppp multilink
 multilink load-threshold 1 either
 no ppp multilink fragmentation
 bridge-group 1
!
interface FastEthernet0/0
 ip address 10.10.20.254 255.255.0.0
 no ip route-cache
 no ip mroute-cache
 no keepalive
 speed auto
 full-duplex
 bridge-group 1
!
interface Serial0/0
 bandwidth 1536
 ip unnumbered Multilink1
 encapsulation ppp
 no ip route-cache
 no ip mroute-cache
 no fair-queue
 ppp multilink
 multilink-group 1
 !
interface Serial0/1
 bandwidth 1536
 ip unnumbered Multilink1
 encapsulation ppp
 no ip route-cache
 no ip mroute-cache
 no fair-queue
 ppp multilink
 multilink-group 1
!
ip classless
no ip http server
!
snmp-server community public RO
no snmp-server enable traps tty
bridge 1 protocol ieee
!
line con 0
 exec-timeout 0 0
 password 7 blah
 login
line aux 0
line vty 0 4
 password 7 blah
 login
!
end

0
Comment
Question by:tradermacher
  • 2
4 Comments
 
LVL 79

Expert Comment

by:lrmoore
ID: 10868114
Because you are bridging.
Try creating a loopback interface that is not part of the bridge group with a totally different IP address range, and ping it

i.e.

Side A
interface loopback 1
 ip address 192.168.123.4 255.255.255.252

Side B
interface loopback 2
 ip addres 192.168.123.14 255.255.255.252

0
 
LVL 50

Accepted Solution

by:
Don Johnston earned 125 total points
ID: 10868122
If you have IP routing disabled, then there will be no processing of IP packets.

You can use Integrated Routing and Bridging (IRB) if you need to process IP packets and bridge at the same time.

Remove the ip address from the fastethernet interface and add these lines.

ip routing
bridge irb
interface bvi 1
ip address 10.10.10.254 255.255.0.0

This should give you an ip address you can talk to.

-Don
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 10868608
Don,
Nice one.
Do you need to add "route ip" to the bridge definition?

0
 

Author Comment

by:tradermacher
ID: 10870372
Don,

It looks like you're the man!  I won't be able to test the solution until later
today (or perhaps later this week).  But I will let you know as soon as I
get it done.  Many thanks!  (Many thanks to lrmoore as well - I appreciate
the help!).


--tr
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
How to setup VPN onCisco RV016 8 51
Let me pick your brain -Router for 100 users plus 80 wireless devices 6 56
VirtualBOX on GNS3 11 94
Wireless network monitoring 8 53
While it is possible to put two routes in place with the secondary having a higher metric, this may not always work. In the event of a failure that does not bring down the physical interface on the router the primary route is not removed. There is a…
Tired of waiting for your show or movie to load?  Are buffering issues a constant problem with your internet connection?  Check this article out to see if these simple adjustments are the solution for you.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

910 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now