Cisco PIX 501 and MS Exchange 5.5

Hello, i have i client that im experiencing the following thing.

I have now set up a adsl solution with a fixed ip adress 213.145.234.21 and since that has been
implementet they cannot recive email anymore, they are able to send via the exchange server.

Before the adsl they had a dialup isdn connection.

The company that host their domain has set up their routers to forward all emails to the 213.145.234.21 ip adress.

What do i do on the exchange server and/or on the pix so that they are able to recive email again?

 

 
LVL 1
daxa78Asked:
Who is Participating?
 
Tim HolmanConnect With a Mentor Commented:
Assuming outbound internet and mail is all working OK, you should just be able to add these lines, where 192.168.2.57 is your internal Exchange server:

access-list smtp permit tcp any host 213.145.234.21 eq smtp
 static (inside,outside) tcp interface 25 192.168.2.57 25 netmask 255.255.255.255
access-group smtp in interface outside

Look here for some more information if you need it:

http://www.cisco.com/en/US/products/hw/vpndevc/ps2030/products_configuration_example09186a0080094466.shtml


0
 
Tim HolmanCommented:
If you run into problems, post up your config.. ;)
0
 
lrmooreCommented:
There are several things that are necessary.
1. Proper MX Records for mail server redirect in primary DNS server. Go to http://www.dnsreport.com and put in the domain to check
2. Proper static nat map on the PIX as tim has demonstrated. Use either 1-1 static NAT or static Port map as tim demonstrates
3. Proper inbound access-list (or conduit) to permit the inbound traffic
4. Disable fixup for smtp:
  no fixup protocol smtp 25

0
 
hawgpigCommented:
assuming that you posted the correct ip address....for your mail server.....i took a look at your port 25 and it shows open.....So the server looks like it is listening.....However I checked with www.dslreport.com and it sayes that the address is not a mail server which means that your ISP hasen't changed over your e-mail address to reflect the current ip address yet. Try this yourself.
Also doing an NSlookup on your ip address does not show your domain.....Your ISP is probably your issue...
Good Luck
0
 
daxa78Author Commented:
Thanks so much for the help. Made my day. Have a good one
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.