• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 408807
  • Last Modified:

Connecting 2 computers using a crossover cable

Hey All,
I have two computers, one running windows 2000 and one running SuSe linux.
There is a crossover cable between the two machines.
Could someone please post up a detailed explanation of how to connect the two machines that includes setting ip addresses, routing commands etc,.  (I am offering maxium points so please give exact instructions.)
All I have done so far is link the machines with the crossover cable but they can only ping themselves not each other, however I can't seem to configure the routing etc.
3 Solutions
First and foremost, they must be on the same subnet.
If you're giving them private ip addresses, and - they both should have a subnet mask of  You can set the gateway to be the ip address of the other machine or leave it as blank.

On the W2k machine, enable NetBIOS over TCP/IP:

Right-click your network connection/local area network and choose properties
Find your TCP/IP protocol, click it and click properties
  Click the Advanced button on the General tab.
  Click the WINS tab.
  Under NetBIOS setting heading
   Click Enable NetBIOS over TCP/IP
  Click OK to apply and close out the dialogue box...
stefargAuthor Commented:
I tried the above, still no change.
The cards can ping them selves but not eachother
are u sure your corss cable is good in condition?
WEBINAR: GDPR Implemented - Tips & Lessons Learned

Join the WatchGuard team on Thursday, March 29th as we recount some valuable lessons learned in weighing the needs of a business against the new regulatory environment, look ahead at the two months left before implementation, and help you understand the steps you can take today!

Please post the following output

Windows machine :

In command prompt
ipconfig /all

In suse : ifconfig -a

Also check whether u see the link led on the lan cards on both machines.
wats your intention for this network?
do you want to share the internet from the windows machine?
if so then go here:


install an utility AnaligX in the machine thats gonna serve the Services.
 read its manual.

A+ MCP Cisco CCNA Acad Sem-1
Trygve ThayerIT DirectorCommented:
This is a pinout to make sure your crossover is correct.  This uses the EAIA standard

                                                1----------------      -----------------      -----------------      WHITE / GREEN      
                                                2----------------      -----------------      -----------------      GREEN / WHITE      
                                                3----------------      -----------------      -----------------      WHITE / ORANGE      
                                                4----------------      -----------------      -----------------      BLUE / WHITE      
CABLE                                                5----------------      -----------------      -----------------      WHITE / BLUE      
                                                6----------------      -----------------      -----------------      ORANGE / WHITE      
                                                7----------------      -----------------      -----------------      WHITE / BROWN      
                                                8----------------      -----------------      -----------------      BROWN / WHITE      
            NOTE: CLIP IS ON BOTTOM                                          WHITE / ORANGE      
                                                                  ORANGE / WHITE      
                                                                  WHITE / GREEN      
                                                                  BLUE / WHITE      
                                                                  WHITE / BLUE      
                                                                  GREEN / WHITE      
                                                                  WHITE / BROWN      
                                                                  BROWN / WHITE      
stefargAuthor Commented:
Hey All,
thanks for the comments, here's my responses:

yes, I have tried two crossover cables both of which have been used by others with no problems, but just to be sure, I tried connecting the computers usig a switch and two standard cables, but still no luck.

See details at end of comment for ip details.  Also yes the led lights are on on both machines.  the two cards have 2 lights eachs. one is on constant and the other flickers now and again (same on both machines)

I need to set up a nistnet emulation box, i.e. a linux application that resides on a machine with two network cards and emulaties various network conditions for communications between the two computers connected to the cards.

The cables seem fine, I'm reasonably confident they are not the problem,

Thanks everyone for your comments so far

---------------------------Linux Machine:---------------------------------------------
eth0      Link encap:Ethernet  HWaddr 00:40:F4:89:70:E7
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::240:f4ff:fe89:70e7/10 Scope:Link
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:70 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:0 (0.0 b)  TX bytes:6464 (6.3 Kb)
          Interrupt:11 Base address:0x3c00

lo        Link encap:Local Loopback
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:300 errors:0 dropped:0 overruns:0 frame:0
          TX packets:300 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:21446 (20.9 Kb)  TX bytes:21446 (20.9 Kb)

sit0      Link encap:IPv6-in-IPv4
          NOARP  MTU:1480  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

----------------------------------Windows Machine:-----------------------------------------------

Windows 2000 IP Configuration
        Host Name . . . . . . . . . . . . : delboy
        Primary DNS Suffix  . . . . . . . :
        Node Type . . . . . . . . . . . . : Broadcast
        IP Routing Enabled. . . . . . . . : No
        WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

        Connection-specific DNS Suffix  . :
        Description . . . . . . . . . . . : 3Com 3C920 Integrated Fast Ethernet
Controller (3C905C-TX Compatible)
        Physical Address. . . . . . . . . : 00-08-74-41-34-AB
        DHCP Enabled. . . . . . . . . . . : Yes
        Autoconfiguration Enabled . . . . : Yes
        Autoconfiguration IP Address. . . :
        Subnet Mask . . . . . . . . . . . :
        Default Gateway . . . . . . . . . :
        DNS Servers . . . . . . . . . . . :

I see your problem.  Turn off DHCP on the Windows machind and statically assign an IP address of and subnet mask of and you should be good.  The windows machine is automatically configuring itself in the absence of a DHCP server.
Trygve ThayerIT DirectorCommented:
Yep I would agree.  They are not on the same network ip structure.  Neet seeing the Linux config.  Been meaning to set one of those up and play around with it.
...or set the Linux box up with a address/subnet mask of
stefargAuthor Commented:
Ok problem solved,
CountRugen noticed something that I hadn't that was that the windows machine required a reboot (typical) after I set the address to static.  I had set it in the network settings but as you can see above the ipconfig did not notice the changes, but it did after rebooting.
There was still a slight problem though when I rebooted, the same problem as above but I figured out that linux box was mixing up the network cards.
There were 2 cards in the system, one ┬úcom and one Realtek and in Yast2 it told me that I had applied ip changes to the 3com card but those changes actually occurred on the Realtek card and vice versa.  So all was well and good when I swapped the cables.
As for the points allocation, I hope you think it was fair, but I awarded most to CountRugen because that comment pointed an oversight that needed to be resolved before I could get the system working.
I awarded the remaining points to tthayer and sirbounty because I found their posts to be extremely helpful in tracking down the solution and helped my understanding of the network details etc.
Thanks for all your help,
come, this is easy.

go to frys and buy a $80 wireless router and your done.

Scott Wiseman
please give example code in VB.net for networking including chatting
Here is a great tool I use for cross over cables


Best of Luck

try this,

go to My Computer and right click on it, select Manage
go to Service and Application and choose services
there is a service COMPUTER BROWSER check it is not stopped and if so just start it

Sorry, I dont work with Linux as yet.

TRY THIS....!!!!!
CrossOver Cable:
END1: WhiteOrange/Orange/WhiteGreen/Blue/WhiteBlue/Green/WBrown/Brown

Network Configuration.
PC1: (TCP/IP Properties)
GATEWAY: -none-


Ping first its IP Address. Then the oterPC.
If you've not recieve a reply. Maybe, their is a problem with your CABLE, or LAN card.
Another would be the DRIVER. Re-install the driver.
No need to restart windows when using Windows 2000 and Upper version.
In 98 you're required to restart, in order to apply the new settings.
I think the cable connection is wrong.
Try this Cabling method.

1) Brown White-Blue White
2) Brown - Blue
3) Blue White - Brown White
4) Green - Green
5) Green White - Green white
6) Blue - Brown
7) Orange White - Orange White
8) Orange - Orange

Add Static TCP/IP on both computers : &
Subnet mask : on both computer.
Restart and Ping to each other not with computer name but by IP Addresss..
I think this will work.....
Feroz AhmedSenior Network EngineerCommented:
Cross over cabling is only to bring 2 systems into one network for routing to take place you require a router where you can configure routing protocols on router and then you can make use of these 2 systems as you like with your Router one and 2 way.
Feroz AhmedSenior Network EngineerCommented:
Check whether your LanCards are working properly in both the computers if they are working properly then check your cable colour sequence for Cross Cabling and whether they are climpped properly or not and moreover you can check your lanCard connection is blinking or not once cable is plugged into LanCard and make sure you remove all the ip settings and just enter ip address followed by Subnetmask on both the systems (for example :; and 192.168.02; and see you should be able to communicate between 2 systems.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

We Need Your Input!

WatchGuard is currently running a beta program for our new macOS Host Sensor for our Threat Detection and Response service. We're looking for more macOS users to help provide insight and feedback to help us make the product even better. Please sign up for our beta program today!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now