Solved

Missing Network Adapter in control panel

Posted on 2004-04-20
11
469 Views
Last Modified: 2010-04-25
When I open the Network Connections control panel I only see create new connection... I do not see my adapter, which is a 3com 3c905c.  The operating system is Windows 200 Pro.  I can see the adapter in device manager, and there is no conflicts, and everything looks ok.  If I run ipconfig I can see the adapter and it looks ok there too, it grabs a DHCP address and everything.  Does anyone know if this is a registry problem or anything?

0
Comment
Question by:icfire
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 3
11 Comments
 
LVL 69

Expert Comment

by:Callandor
ID: 10871422
I would suggest trying a different NIC to see if that makes a difference - you may have a faulty card.  NICs are pretty cheap.
0
 
LVL 9

Expert Comment

by:jonoakley
ID: 10943841
First what is network IP address
Try The following:
Stop at first non reply
Open a command prompt type PING 127.0.0.0 check your IP stack
    IPCONFIG/all returns network IP information
type PING xxx.xxx.xxx.xxx ( IP address from IPCONFIG)
type PING Default Gateway (from IPCONFIG)
Type PING DNS Server (from IPCONFIG)

If all this returns replies you do indeed have an IP network connection.

Log on to
http://www.3com.com
Download the latest driver for you card there are a couple of flavors to chose from but it should be silk screened on the card.    
The file will most likely be an .exe or .zip and contain the driver files. Place the files somewhere accessable

Right-click the My Computer icon on your desktop and select Properties.
Select the Hardware tab and click the Driver Signing... button.
Make sure that File signature verification is not set to Block - Prevent installation of unsigned files.
Change the setting if required and click OK to put the change into effect.
Click Device Manager double click your 3Com NIC under Network Adapters
Click the Drivers tab then click the Update button and point to the driver files.
 
0
 
LVL 2

Author Comment

by:icfire
ID: 10948957
First off new network card did not work.

yes I could ping things and everything worked just fine but as I was playing with the connection it somehow got reconfigured to static over dhcp and then after that I could not access anything because the dhcp was gone.  I did have the latest drivers and everything in the device manager was looking good.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 9

Expert Comment

by:jonoakley
ID: 10949486
Even though Device Manager thinks the device is working that is not always the truth. Once in a while removing or updating the drivers will replace a corrupt bit that causes a device the report that it is working properly but is actually not fully functional.

When you say "the new network card did not work" , did the system have the same symptoms or was the card not fuctional?

"playing with the connection" can we assume this was moving the various RJ-45 connectors at the card, wall, switch/hub...  Is this with the new card or the old?

Which card is in the system currently? Do you have a link light? Can you ping the gateway?

I know all of these questions seem tedious but the answers affect the path for troubleshooting.

0
 
LVL 9

Expert Comment

by:jonoakley
ID: 10949686
If you have can ping the gateway we have a good connection.

The next step is to open add/remove windows components
Start--> Setting-->Control Panel-->Add/ Remove Programs-->Add/Remove Windows Components( a box on the the left of the pop up window)

Scroll down and highlight  Network Services then click the Details button. In the new pop up window click the box next to Simple TCP/IP Services. If there is a check in the box this will uninstall some TCP/IP services the reverse is true if there is no check. The effect is to refresh the TCP/IP stack. Check network connection. The component status can be restored by repeating the above procedure.
0
 
LVL 2

Author Comment

by:icfire
ID: 10949754
removing the card and replacing it back in the system did not make any difference.

The new card did have the same symptoms, shows a connection shows that everything is ok, but does not show in the network properties.  

"playing with the connection"  refers to ipconfig /release /renew /all /showclassid.  Also removing TCP/IP services through add/remove components.  I have done all of that and somewhere in that I lost the DHCP settings and the card got reconfigured to static with no address.

0
 
LVL 9

Expert Comment

by:jonoakley
ID: 10950141
0
 
LVL 9

Accepted Solution

by:
jonoakley earned 250 total points
ID: 10950183
0
 
LVL 9

Expert Comment

by:jonoakley
ID: 10950210
Is have got to teach my fingers how to edit   :8)
0
 
LVL 2

Author Comment

by:icfire
ID: 10950333
I just went back there to check on these things and the machine is running Windows XP now.  I guess the other support guy couldn't wait for me to find a fix for the problem and bought XP to upgrade the machine.  

I tell you what I searched through the Microsoft support and never found those articles.  I think their new search is not as good as their old search used to be.  damn Microsoft.  I am going to award you with the points just because I think that one of those would have worked.
0
 
LVL 9

Expert Comment

by:jonoakley
ID: 10950617
I hate when that happens your working on a system then next thing you know its upgraded
0

Featured Post

Space-Age Communications Transitions to DevOps

ViaSat, a global provider of satellite and wireless communications, securely connects businesses, governments, and organizations to the Internet. Learn how ViaSat’s Network Solutions Engineer, drove the transition from a traditional network support to a DevOps-centric model.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

No matter the version of Windows you are using, you may have some problems with Windows Search running too slow or possibly not running at all. Before jumping into how you can solve this issue, just know there are many other viable alternative deskt…
Skype is a P2P (Peer to Peer) instant messaging and VOIP (Voice over IP) service – as well as a whole lot more.
In a recent question (https://www.experts-exchange.com/questions/29004105/Run-AutoHotkey-script-directly-from-Notepad.html) here at Experts Exchange, a member asked how to run an AutoHotkey script (.AHK) directly from Notepad++ (aka NPP). This video…
Finding and deleting duplicate (picture) files can be a time consuming task. My wife and I, our three kids and their families all share one dilemma: Managing our pictures. Between desktops, laptops, phones, tablets, and cameras; over the last decade…

734 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question