Solved

IIS SMTP problems with queue and mail sent by CDO.Message

Posted on 2004-04-20
24
44,506 Views
Last Modified: 2011-08-18
Hello there,

The first I heard about the problems we're experiencing, was when somebody contacted me about emails that were not getting through.  People were receiving a "Delivery Failure Report" that said "Delivery to the following recipients has been delayed".

The first thing I did was have a look at the SMTP queue on our server and to my suprise there was five days worth of email in the queue that hadn't been sent.

I also checked the event viewer and found 1000's of SMTPSVC warnings that read:

Message delivery to the host '<ip address>' failed while delivering to the remote domain '<domain name>' for the following reason: The remote server did not respond to a connection attempt.

Any idea what the problem could be?

Many thanks,
Dave.
0
Comment
Question by:tidydave
  • 6
  • 5
  • 3
  • +8
24 Comments
 
LVL 11

Assisted Solution

by:SweatCoder
SweatCoder earned 250 total points
Comment Utility
make sure you have the correct, fully-qualified mail server name in SmartHost under Advanced in SMTP properties, and uncheck "attempt direct delivery first".

and as a test, run this from command prompt:

telnet yourprefix.yourmailserver.com 110  (and see if it connects)
0
 
LVL 2

Expert Comment

by:sbennetts
Comment Utility
I've seen something similar when the permissions are changed on the mail directory in the wwwroot folder.  Not sure if it'll help here, but worth a look.
Simon
0
 
LVL 37

Accepted Solution

by:
meverest earned 250 total points
Comment Utility
you've probably been blocked by a firewall or isp.

check that you have smtp connectivity to the server/s listed in the event log.

for example, where it says "Message delivery to the host '<ip address>' failed " enter:

telnet <ip address> 25

at a command shell.  you should see the banner of the remote server if all is ok.  if not, you will see a connection failed message.

if you see the latter (i suspect that you will) then you need to find out what firewall is blosking you out.  maybe you corporate lan, or maybe your isp (if they think that you are spamming)  also, many dsl isps trace the number of smtp connections going out of each connection.  if it reaches some limit (maybe 100 in an hour) they automatically block that port.  now 100 an hour might be reasonably indicative of spam activity for an average domestic service, but for a business operation, 100 is not many at all.... maybe there something like that going on?

cheers,  Mike.
0
 

Author Comment

by:tidydave
Comment Utility
Thanks Guys, it is was a problem with the firewall and not having a smarthost mail server setup.

Now I'm forwarding my mail (using smarthost) to a mail server that is allowed through the firewall.  

And a queue of 1890 items is now 0 :-)
0
 

Expert Comment

by:jevindme
Comment Utility
The remote server did not respond to a connection attempt....

 http://support.microsoft.com/support/misc/kblookup.asp?ID=827363
0
 

Expert Comment

by:jevindme
Comment Utility
0
 

Expert Comment

by:benc007
Comment Utility
Tidydave,

How did you get around the firewall problem and forward your mail (using smarthost)?  




---------------

Thanks Guys, it is was a problem with the firewall and not having a smarthost mail server setup.

Now I'm forwarding my mail (using smarthost) to a mail server that is allowed through the firewall.  

And a queue of 1890 items is now 0 :-)
0
 

Expert Comment

by:jevindme
Comment Utility
What did you with the Firewall ??

Open ports 25, 110 or something else...
0
 

Expert Comment

by:epaschal
Comment Utility
I had this same issue. Almost all of our mail was in queue to popular domains like aol.com, hotmail.com, etc.

The eliminate the immedeate problem, I used a smarthost to relay our mail for us. That got the mail out of queue, but didn't solve why WE couldn't send our own mail out (instead of going through a third party).

When I tried to connect to AOL manually, I received this message:
220-rly-ye01.mx.aol.com ESMTP mail_relay_in-ye1.7; Sun, 06 Jun 2004 20:38:23 -04
00
220-America Online (AOL) and its affiliated companies do not
220-     authorize the use of its proprietary computers and computer
220-     networks to accept, transmit, or distribute unsolicited bulk
220-     e-mail sent from the internet.  Effective immediately:  AOL
220-     may no longer accept connections from IP addresses which
220      have no reverse-DNS (PTR record) assigned.

I'm guessing that our failure to connect was possibly a result of this "no reverse-DNS PTR Record" item. I have no idea how to get a PTR record established for the IP we sent mail from though...
0
 

Expert Comment

by:sattlesey
Comment Utility
I had the same problem and the resolution was to make sure my PTR and MX records were published properly.  epaschal, contact your ISP and they should be able to get the PTR published properly.

Scott
0
 

Expert Comment

by:FrankTaylor617
Comment Utility
After upgrading from Exchange 2000 to 2003, I also had the problem with AOL, Yahoo, etc sticking in the Queue.  I resolved the problem by making sure that under Default SMTP Virtual Server Properties - Delivery Tab - Advanced - Configure External DNS servers, I  Added our ISP's DNS server addresses in here. Once I did that all of the emails went through after that.  
-- Frank
0
Find Ransomware Secrets With All-Source Analysis

Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

 

Expert Comment

by:benc007
Comment Utility
I am using IIS 2000.  I am under Default SMTP Virtual Server Properties - Delivery Tab - Advanced.

But I do NOT have a "Configure External DNS servers" tab!!

Please help.
0
 

Expert Comment

by:benc007
Comment Utility
FrankTaylor617,

Can you help?  I am having the same problem and need to figure out a solution asap.  You can also contact me directly at {{email address removed for member's protection - 3-Aug-05 --alimu/Page Editor IIS}}

I appreciate your help.  Thank you in advance.

0
 

Expert Comment

by:rholton
Comment Utility
You might trying calling your ISP. If it is SBC you will want to ask for 2nd teir support and unblock port 25 on your system. You will need to reboot your router or reset

Thanks,

Rich
0
 

Expert Comment

by:benc007
Comment Utility
Rich,

What is port 25 used for?  Will SBC unblock this port?

I am currently not using SBC to send emails ...

I believe my problem is similar to FrankTaylor617 but I am using IIS 2000.  The problem is that under Default SMTP Virtual Server Properties - Delivery Tab - Advanced, there isn't a Configure External DNS servers button.
0
 

Expert Comment

by:rholton
Comment Utility
Port 25 is for smtp (Simple Mail Transfer Protocal)

Call them or log into help.sbcglobal.net .

There is a form to fill out and they will unblock it. Everything will just go back to working. Very Bizare.

Thanks,

Rich
0
 

Expert Comment

by:benc007
Comment Utility
Were you using CDONTS and SMTP Virutal Server?  What platform?
0
 

Expert Comment

by:rholton
Comment Utility
SMTP Virtual Server
0
 

Expert Comment

by:mfu2305
Comment Utility
I just dealt with this problem and it was a result of not having our PTR record setup properly. Our ISP didnt have our reverse DNS setup in the PTR record. and as I found out, some mail servers dont accept connections from servers if they cant lookup their DNS name, such as some AOL servers, gmail, and others.

newbie

{{email address removed for member's protection - 3-Aug-05 --alimu/Page Editor IIS}}
0
 

Expert Comment

by:rholton
Comment Utility
I think my problem is only with SBC. Sbc started blocking port 25 accross thier network.
0
 

Expert Comment

by:benc007
Comment Utility
Do you know what RBLs are?
0
 

Expert Comment

by:rholton
Comment Utility
NO, sorry.
0
 
LVL 37

Expert Comment

by:meverest
Comment Utility
guys - this question is closed.  you may want to open a new thread to start a new discussion.

Cheers.
0

Featured Post

Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

Join & Write a Comment

What is an ISAPI filter?   •      It's an assembly (.dll file) that can add or change the way IIS works.   •      They can be enabled globally for your web server or on a site-by-site basis.   When the IIS server receives a request, enabling the ISAPI fi…
Running classic asp applications under Windows Server 2008 R2 (x64) and IIS 7 is not as easy as one may think. It took me a while to figure it out while getting error 8002801d a few times. After you install the OS you will need to install the fol…
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

7 Experts available now in Live!

Get 1:1 Help Now