Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Routing problem

Posted on 2004-04-20
15
Medium Priority
?
229 Views
Last Modified: 2010-04-17
I am in the process of configuring the router for the first time. The router is 2651 with two fastethernet interfaces. I have configured the following ip addresses for the interfaces. Fastethernet0/0 ipaddress 192.168.0.254, Fastethernet0/1 ipaddress 192.168.1.254. The routing RIP is enabled for both networks. Now I sit on a PC 192.168.1.1 and try to ping 192.168.0.1 computer, I cannot. I have set the default gateway for the PC as IP address of the router interface. I can ping both IP addresses of the interfaces but not any other address on other network.
0
Comment
Question by:shifka_75
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
  • 3
  • +2
15 Comments
 
LVL 27

Expert Comment

by:pseudocyber
ID: 10870401
Can the 192.168.0.1 computer ping 192.168.1.254?

I assume you haven't turned of IP routing with "no ip routing".  You might want to type "ip routing" just for the halibut.

You might want to type "show ip route" from global exec mode to examine the routing table.  All interfaces up?  You could type "show ip int" and examine them.

0
 
LVL 13

Expert Comment

by:td_miles
ID: 10874904
funny thing is that ip routing is usually DISABLED by default when you first configure a router. It's one of the gotchas, you do need to explicitly enable it as pseudocyber has described.
0
 

Author Comment

by:shifka_75
ID: 10875442
Thanks a lot for your comments.... I typed ip routing command. As you mentioned. I can only ping 192.168.0.2 computer on the other network from PC 192.168.1.1 and vice versa. But I cannot ping any other computer on this network 192.168.0.0 from 192.168.1.0 network and vice versa.

For testing purposes I have attached one router interface to the computer directly 192.168.1.1, and other interface to the switch 192.168.0.0 network with around 40 computers. Only 192.168.0.2 can access other network and vice versa

Any suggestions!!! Thanks

0
Turn your laptop into a mobile console!

The CV211 Laptop USB Console Adapter provides a direct Laptop-to-Computer connection for fast and easy remote desktop access with no software to install.

 
LVL 13

Expert Comment

by:td_miles
ID: 10875491
OK, let me get this correct, you have:

PC1 - 192.168.0.1
PC2 - 192.168.1.1
Fa0/0 - 192.168.0.254
Fa0/1 - 192.168.1.254

To debug this, you need to work out where the problem is.

1. From PC1, ping Fa0/0
2. From PC1, ping Fa0/1
3. From PC1, ping PC2

4. From router, ping PC1
5. From router, ping PC2

6. From PC2, ping Fa0/1
7. From PC2, ping Fa0/0
8. From PC2, ping PC1

and the results are ?

As requested by pseudo, can you post the output from the router command "show ip route". Can you also post the output from the router command "sho ip int brief". It would also be helpful if you can post the config of the router (use "show run").
0
 
LVL 13

Expert Comment

by:td_miles
ID: 10875508
oops, I just reread your comment, are you saying that from PC 192.168.1.1 you CAN ping 192.168.0.2 ? If so, then it looks like your router may be working as expected.

If so, then I would check that the rest of the PC's on the 192.168.0.0 network have the default gateway set correctly to 192.168.0.254.
0
 
LVL 27

Expert Comment

by:pseudocyber
ID: 10876927
Also, make sure all subnet masks are set correctly.
0
 
LVL 1

Expert Comment

by:ekahan
ID: 10882162
2 things you can try that will point you to where the promlem is.

1. Do a tracert from a pc on one side of the router to a pc on the other? where does it start timing out.

2. From the router itself  and do an extended ping to a pc using the opposite side router interface.

If you need help with extended ping let me know.
0
 
LVL 28

Accepted Solution

by:
mikebernhardt earned 200 total points
ID: 10903456
If one PC on 192.168.0.0 can ping 192.168.1.1 but none of the others can, it's not a router problem- unless the subnet mask on one of the router interfaces is not configured as you think it is. Otherwise either one PC is also configured as 192.168.0.254 (duplicate IP), or they mostly have incorrect subnet masks or default gateways. You mentioned 192.168.0.1 earlier, but then it was 192.168.0.2. Same PC or different one?

So, check your router config to make sure the masks are right; Check your PCs to make sure the masks and default gateways are right. Make sure that none of the other PCs are configured with the router interface address as their own address.

You can type "show arp" on the router and look to see that every IP that should be there is there.

Not sure why you're running RIP unless you're connecting the 2 LANS to some other site via serial interface. Otherwise remove RIP with "no router rip" but leave IP routing on. The router will always forward packets between directly connected networks. Turning on RIP on a single router justs broadcasts RIP onto the LANS. With one way out of the LAN this is useless.

By the way, "ip routing" is ON by default. You couldn't have typed "router rip" without it- the router wouldn't have accepted the command.
0
 

Author Comment

by:shifka_75
ID: 10928505
Thanks a lot for such informative comments. Now my problem is solved, I am able to ping the other network and vice versa.

Now another problem, I can ping 192.168.0.2 machine from 192.168.1.1 machine across router and vice versa. My 192.168.0.2 machine in the domain controller with DNS and DHCP running on this machine.

I want that my computer 192.168.1.1 should now get the ip address from this DHCP server, and also use this as DNS. When I write the command ipconfig/renew (after selecting the option "obtain ip address automatically"), it says cannot connect to DHCP, similarly NSLOOKUP doesnot work from other network 192.168.1   .

Although I tried to add this computer 192.168.1.1 to domain (192.168.0.2 domain controller), it worked and I can login using my domain account.

PLease help me out of it.  
0
 
LVL 27

Expert Comment

by:pseudocyber
ID: 10929671
Use the IP Helper command on the Cisco router to point one subnet to the other for DHCP.
0
 
LVL 28

Expert Comment

by:mikebernhardt
ID: 10930294
Yes, on the 192.168.1.0 interface, type
ip helper-address 192.168.0.2

and you should be good to go
0
 

Author Comment

by:shifka_75
ID: 10967193
Thanks a lot for your suggestions. Now everything is setup and next step is applying the access lists. What I want is that

1) Any user on the network 192.168.1.0 can login to the server 192.168.0.2 with his domain account in active directory,

2) Same server to be used as DNS and DHCP for 192.168.1.0 Network.

3) The users should not have any access to computers or or files etc on 192.168.0.0 Network

4) The users on 192.168.1.0 Network can access the Web services (IIS) from 192.168.0.3 computer

5) The users on 192.168.1.0 Network can access the Microsoft exchange server with Ip address 192.168.0.5

6) The users on 192.168.1.0 Network should be able to access the file server 192.168.0.6 only for saving their data.

7) The users in 192.168.1.0 Network should be able tyo access the Database server with Ip address 192.168.0.4

8) The users in 192.168.1.0 Network should be able to access the ISA proxy server with Ip address 192.168.0.1 for Internet access.

Any other access is restricted

Waiting for your suggestions

Thanks a lot!!
0
 
LVL 27

Expert Comment

by:pseudocyber
ID: 10969712
Well, this question has really gotten involved for only 50 points - but you did get it answered.

If you want help configuring your access lists, I'd suggest opening a new question for more points.
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Problem Description:   Couple of months ago we upgraded the ADSL line at our branch office from Home to Business line. The purpose of transforming the service to have static public IP’s. We were in need for public IP’s to publish our web resour…
In the hope of saving someone else's sanity... About a year ago we bought a Cisco 1921 router with two ADSL/VDSL EHWIC cards to load balance local network traffic over the two broadband lines we have, but we couldn't get the routing to work consi…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

661 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question