• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 443
  • Last Modified:

Change the colors from millions to thousands

I am very new to Linux.  I've just installed Linux 9 and when I changed the colors from thousands to millions, I can no longer see the screen properly.  How do I change it back from the command prompt?
0
slaroche
Asked:
slaroche
  • 11
  • 6
  • 3
  • +1
1 Solution
 
Pete LongTechnical ConsultantCommented:
You can change the resolution of your Linux desktop using the following command:
sudo /pkg/pkg/tool/kiesres.sh.

You will get a menu that will allow you to change your resolution.
Your new resolution will be automaticly used the next time you login.
http://www.win.tue.nl/bcf/linux/resolutie.php?PHPSESSID=b2528187a72a00ba245f1236dd3f7b3b
0
 
slarocheAuthor Commented:
at the Grub> command prompt, I've typed in the command and I get the error "error 27: unrecognized command"
0
 
Karl Heinz KremerCommented:
This is not a grub parameter, you first need to boot your system. You can avoid booting into the graphical environment by adding either a "single" to the grub command line, or a "3".

But, you can also boot into the graphical UI and then use <Ctrl><Alt>F1  to switch to a virtual text console.
Log in as root user and then run /pkg/pkg/tool/kiesres.sh
0
Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

 
Karl Heinz KremerCommented:
However, I don't think that this will work, I don't think that this program is part of a RedHat installation.
0
 
Karl Heinz KremerCommented:
Edit the file /etc/X11/XF86Config and search for the string "DefaultDepth" Change this to 16, also make sure that you have a "Display" SubSection for a Depth of 16 (you may need to change this as well).
Do this instead of running the kiesres.sh command.
0
 
Karl Heinz KremerCommented:
Another alternative is to run the command redhat-config-xfree86
Just select "thousands of colors" and save your changes.
0
 
slarocheAuthor Commented:
<ctrl><alt><F1> brought me to a screen, but typing stuff in didn't change anything.  It didn't behave like a command prompt, but rather a black notepad.  How do I edit files?  From the Grub> command line, I can't type edit without getting an unrecognized command error.  Do I need to boot to a dos command prompt?
0
 
Karl Heinz KremerCommented:
You need to log in after you switch to the virtual terminal. Type "root" (without the quotes) as the user name and the root password that you specified.

What distribution are you using. I just noticed that you were only talking "linux 9", and I somehow assumed that it's RedHat, is this the case?

If that's the case, when you see the boot selection type "a". This will bring up the grub append dialog. Type " 3" (a space followed by the number 3 and hit return. This will bring up a login prompt, type the "root" user name and the root password.
0
 
Karl Heinz KremerCommented:
And, once you are logged in as root, use the "redhat-config-xfree86" command. This will get you around editing config files.
0
 
slarocheAuthor Commented:
the redhat config command takes me to a gui that I can't make out.  It's better, but I have no idea what I'm clicking on.  I typed help at the same command prompt to try and figure out how to edit a file, but didn't see the edit command.  Would you mind explaining how to edit the file you've specified.  If it's too much of a pain, I can just reload the OS and keep it at thousands of colors.  I am using the Redhat distribution.  
0
 
gtkfreakCommented:
Login: root
Password: xxxxxxxx (whatever your root password)
You will see a #. At the # type:
# startx -- -depth 16

This will give you thousands of colors. Then you can make this setting permanent by clicking on the RedHat startup menu, system settings->display and make your settings permanent.
0
 
Karl Heinz KremerCommented:
I thought about this as well, but this will fail if you don't have settings for 16bit mode in your XF86Config file.
0
 
Karl Heinz KremerCommented:
Are you familiar with any Linux editor? I don't know what's installed on a RedHat system by default. I'm only using vi and that's always there :-) Try to edit with joe and pico:
joe /etc/X11/XF86Config
or
pico /etc/X11/XF86Config

0
 
slarocheAuthor Commented:
the 16bit color was not available.  joe and pico are not recognized commands.  reload?  thanks for all your help, by the way.
0
 
Karl Heinz KremerCommented:
Have you ever used vi? It's not the best editor for a novice, but I can walk you through it.
0
 
slarocheAuthor Commented:
I'm not going to be back on the server until Tuesday...It would be great if you could walk me through vi becuase I've never used it.  I'll repost Tuesday.
0
 
Karl Heinz KremerCommented:
Here a tutorial for vi: http://www.eng.hawaii.edu/Tutor/vi.html
You can download the complete document as PDF file and e.g. print it and keep it next to your terminal when you start to edit the XF86Config file. This tutorial is much better than anything I could come up with. Take a look and let me know if you need more information about a certain area.
0
 
gtkfreakCommented:
Editing the XF86Config file using vi.

Take a backup of the present XF86Config file.
# cp /etc/X11/XF86Config /etc/X11/XF86Config.backup

Open the XF86Config file using vi.
# vi /etc/X11/XF86Config
Press <:> (colon key)
Enter /DefaultDepth at the : (colon) prompt.
You should see the cursor at the DefaultDepth. The / searches for DefaultDepth.

Press <R> (capital R) to do a replace. Move with arrow keys and change the number to 16 after DefaultDepth.

Press <escape>
Move with arrow keys to the line that says Depth.

Press <R> (capital R) to do a replace again. Change the number value to 16.
Press <escape>
Press <:> (colon)
Press wq at the <:> prompt.

This saves the XF86Config file and you are done.
0
 
gtkfreakCommented:
If the above gives error, then you can restore your backed up XF86Config file by:
# cp /etc/X11/XF86Config.backup /etc/X11/XF86Config
0
 
Karl Heinz KremerCommented:
Before you do this, check the /etc/X11 directory to see if you already have a backup of XF86Config in this directory. It's possible that the config tool created a backup copy when you changed to "millions of colors". If that's the case, move your current version out of the way and copy the backup back:

cd /etc/X11
mv XF86Config XF86Config.millions_of_colors
cp XF86Config.backup XF86Config

(Replace XF86Config.backup with the name that's actually used for the backup copy on your system).
0
 
slarocheAuthor Commented:
That worked!  Thanks for all your help.  Love this place!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

  • 11
  • 6
  • 3
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now