Solved

PIX and DNS Zone Xfer

Posted on 2004-04-21
6
264 Views
Last Modified: 2009-12-16
I am having trouble getting DNS Zone Xfer to pass through the Pix.  I have a primary DNS on the inside and a secondary DNS on the outside.  I want the secondary DNS to pull a new zone file (when necessary) through the pix.  Not working for me.  I have provided the relevant PIX configs:

access-list 101 remark --ALLOW DNS AND ZONE XFER--
access-list 101 permit tcp host 32.A.B.C host 32.A.B.D eq domain
access-list 101 permit udp host 32.A.B.C host 32.A.B.D eq domain

global (outside) 1 32.A.B.E
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) 32.A.B.D <INTERNAL IP> netmask 255.255.255.255 0 0

The DNS is the first entry in the access-list.  There are other entries, but not pertaining to DNS.  If this is a little confusing, I need to allow an outside (untrusted) IP to request DNS from an inside (trusted) IP.  Secondly, the only communication allowed betwen the two DNS servers is DNS.  
The PIX version is 6.3(1).

Any help?

Jeffrey
0
Comment
Question by:jwi71
6 Comments
 
LVL 6

Expert Comment

by:bloemkool1980
ID: 10879677
I had the same problem long time ago and as I recall I copied the zonefile the first time manually to the seconday. Don't ask me why but after that it worked with the same configuration as you have mentioned here
0
 
LVL 23

Accepted Solution

by:
Tim Holman earned 63 total points
ID: 10883472
If you want to PULL from the secondary, you need an ACL applied to the outside interface:

source secondary DNS server, destination primary DNS server, TCP port 53.

Don't worry about UDP 53, this isn't used for zone transfers...

From what I can see you've allowed DNS out, but not back in again to the static translation ?
0
 
LVL 15

Assisted Solution

by:DonConsolio
DonConsolio earned 62 total points
ID: 10969140
If you use bind you can use the query-source directive to force bind to send queries through a specified source port.
This would allow your firewall rules to work as you expect.

e.g. server 123.123.123.123, port 53

options {
[...other options..]
    query-source address 123.123.123.123 port 53;
};
0
 
LVL 15

Expert Comment

by:DonConsolio
ID: 14136015
still does not work ?

you might also need to add:

[...]
transfer-source * port 53;
notify-source * port 53;
[...]
0
 
LVL 27

Expert Comment

by:Tolomir
ID: 15738751
No comment has been added to this question in more than 21 days, so it is now classified as abandoned..
I will leave the following recommendation for this question in the Cleanup topic area:
Split: tim_holman{http:#10883472} & DonConsolio{http:#10969140}

Any objections should be posted here in the next 4 days. After that time, the question will be closed.

Tolomir
EE Cleanup Volunteer
0

Featured Post

Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Stuck in INIT/DROTHER 2 27
Cisco Policy based routing 2 40
Windows Security warnings have started to pop up excessively 4 58
Switch ports not working 8 34
Ensuring effective and secure communication in the age of healthcare BYOD.
The 21st century solution to antiquated pagers.
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, just open a new email message. In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
Email security requires an ever evolving service that stays up to date with counter-evolving threats. The Email Laundry perform Research and Development to ensure their email security service evolves faster than cyber criminals. We apply our Threat…

810 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question