Solved

Nistnet error> util_binaddnistnet: No such device

Posted on 2004-04-21
13
1,598 Views
Last Modified: 2012-05-04
Hey All,
I have set up a computer to act as an emulator using nistnet but I am having difficulty getting the nistnet tool to work.
Everytime I try to add a configuration like:

cnistnet -a 193.1.132.110 192.168.0.1

it gives the error:

util_binaddnistnet: No such device

after echoing back the configuration I specified.
Can someone please tell me what this means and how to solve it.
Thanks,
Stef
0
Comment
Question by:stefarg
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 6
13 Comments
 
LVL 9

Accepted Solution

by:
Alf666 earned 500 total points
ID: 10884341
Did you compile and load the nistnet module ?
(insmod nistnet).

0
 
LVL 1

Author Comment

by:stefarg
ID: 10884422
I followed the instructions at http://snad.ncsl.nist.gov/nistnet/install.html
although now come to think of it the Load.Nistnet command complained about the rtc module not being loaded even though I loaded it in make menuconfig and make dep.
Could you explain a bit more about the insmod nistnet process.
I am not very well up on linux.
Thanks,
Stef
0
 
LVL 1

Author Comment

by:stefarg
ID: 10884442
where do I call insmod nistnet from i.e. from the directory where I installed nistnet or from /usr/local/bin/ where the executable is?
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 9

Expert Comment

by:Alf666
ID: 10884478
just type insmod nistnet from anywhere.
Or use the Load.Nistnet command.

If you get any error message, please send it here.
Obviously, the kernel module is not loaded. Hence the error messages.
0
 
LVL 1

Author Comment

by:stefarg
ID: 10884488
yeah, I got an error:

/lib/modules/2.4.10-4GB/misc/nistnet.o was compiled for kernel version 2.4.9 while this kernel is version 2.4.10-4GB

What can I do about this? is there some way I can install the correct kernel?
Thanks again,
Stef
0
 
LVL 9

Expert Comment

by:Alf666
ID: 10888808
The kernel you have is correct. What is wrong is the kernel sources you have in /usr/src. The kernel sources you have on your box is 2.4.9. The kernel installed (and in use) is 2.4.10.

Where did you get your 2.4.10 kernel ? Upgrade ? If yes, upgrade the kernel sources. Which distrib is that ?

Once you have the 2.4.10 kernel sources (please, don't get one from www.kernel.org. Get the package for your distrib), you have to get the actual config. On RedHat, there is a config directory under /usr/src/linux. Copy it to /usr/src/linux/.config. Then, cd to that directory, make a "make oldconfig", and a "make dep". This will prepare your kernel for your module compilation.

You will just have to recompile and re-install the nistnet module. It should load ok then.

0
 
LVL 1

Author Comment

by:stefarg
ID: 10888855
hey Alf666,
Well sorta, the kernel that was in use was 2.4.10, so I found 2.4.9 sources on the suse cds and compiled and installed that.  Then I reinstalled nistnet and hey presto, A Network Emulator ready to go!
Thanks for your help,
Stef
0
 
LVL 9

Expert Comment

by:Alf666
ID: 10888929
You're welcome. But I honestly think this deserves an "A" grade :-)
(if you wish, you can ask an admin to review the grade. You can post a request in the Support area - see the link at the top of the page - and have them re-open this question - happens all the time- ).
0
 
LVL 1

Author Comment

by:stefarg
ID: 10889133
Hey Alf666,
I had awarded the grade before you explained about how to resolve the kernel problem and I was offering maximum points because this was urgent.
Till 4am last night I was scouring the internet to find out how to resolve the issue by compiling and installing the correct kernel, which was part of the solution I needed.  I had resolved the problem before you posted up the comments about the kernel.  Therefore while you pointed me in the right direction I did not feel that the answer you gave was complete (especially considering the points offered).
However, I think that this page will be useful to others who have problems with nistnet in the future.  This problem is on many other forums with no solution.  Therefore, I am willing to change the grade as it is probably an A grade solution for others in the future.  For my needs (urgency and incomplete answer by the time I resolved the issue) it was not an A grade, as I had to find out a large portion of the solution myself.
Just wanted to explain my reasoning for giving a B grade originally.
Thanks Stef
0
 
LVL 9

Expert Comment

by:Alf666
ID: 10889270
No problem. Totally understanding :-)
But you're right. It should show as an A grade for future reference (honestly. Not looking for points here).
0
 
LVL 9

Expert Comment

by:Alf666
ID: 10889284
Oh. And, for future references, on SuSE, you will find the current kernel config in /proc/config.gz. So :

cd /usr/src/linux
zcat /proc/config.gz > .config
make oldconfig
make dep

I love this SuSE trick. Very usefull. Even if it takes a few K of kernel mem.
0
 
LVL 1

Author Comment

by:stefarg
ID: 10889323
That's cool :)
Thanks for all your help,
I posted a change of grade request in the support area,
Stef
0

Featured Post

Flexible connectivity for any environment

The KE6900 series can extend and deploy computers with high definition displays across multiple stations in a variety of applications that suit any environment. Expand computer use to stations across multiple rooms with dynamic access.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
How to add a new SAN disk to a linux vmware box 8 40
How to enable SSH in Ubuntu. 7 110
Help instaling linux on vmware 36 97
Install XRDP on Ubuntu Server 16.10 x64 3 116
I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…

732 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question