Solved

Page cannot be displayed - Can't get Internet connection

Posted on 2004-04-21
13
958 Views
Last Modified: 2013-12-14
I have an IBM T30 laptop that I just upgraded on a new drive from Win 2000 to XP Pro. Everything seemed to go well except for one thing, I can't get an Internet connection. I have a cable modem and I have checked the connections multiple times, changed cables but everytime I click on IE I get "the Page cannot be displayed". Ihen I checked my Network Connection I had a red X saying disabled and I had that lovely X down in my taskbar saying "network cable unplugged", but it wasn't. I changed my link speed to half duplex and that went away, but I still can't connect. I tried to right click the connection and chose "repair", but then I get the message "The following steps of the repair operation failed: Renewing the IP address. "  I have compared my settings to my desktop running xp (which connects no problem) and thy are identical. Any suggestions?
0
Comment
Question by:HRJ77
  • 6
  • 6
13 Comments
 
LVL 40

Expert Comment

by:Fatal_Exception
ID: 10888009
The first thing I would do is to upgrade your NIC drivers..  It looks like your IBM is using an Intel Pro 100..  You can dnload the latest IBM drivers for this here:

http://www-3.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-44954

The file is quite large (25 Mb's) so you will need to dnload and burn it to a disk so you can install it...

0
 
LVL 40

Expert Comment

by:Fatal_Exception
ID: 10888048
Another thing you may try is replacing the cable, or moving it to another port on your router...  

There is a Winsock fix you can run on XP also..  Essentially it rebuilds the stack..  Here is the link:

Winsock Fix

http://members.shaw.ca/techcd/WinsockXPFix.exe

And, just curious, you do have your system set to get the IP information dynamically (from DHCP)..???  You might try setting it with static addresses (follow the example of your other system when you run the ipconfig command)
0
 

Author Comment

by:HRJ77
ID: 10888498
Ok, I have downloaded and installed the NIC drivers (They looked to be the same from the date on them), and previously I tried to run the Winsock fix utility and it said it repaired it, but didn't change the fact that I can't get a Internet connection.

I tried to run "ipconfig" from Run, but a black window popped open and then closed.

Yes my system is getting its IP assigned by DHCP.

I greatly appreciate the suggestions Fatal! Hopefully you have a few more cards up your sleeve ; )
0
 

Author Comment

by:HRJ77
ID: 10888587
Ok I ran a network diagnostics check and my network adapter (Inel (R) PRO/100 VE) failed. Here is some more info:

Default IP Gateway = 192.168.0.1 (Same Subnet) (FAILED)
DHCPServer = 192.168.0.1 (FAILED)
DNSServerSearchOrder = 192.168.0.1 (FAILED)
IPAddress = 192.168.0.4 (PASSED)
0
 
LVL 40

Expert Comment

by:Fatal_Exception
ID: 10891211
The reason that ipconfig from the Run line does not work is that you must use it at the Command Shell..  (dos prompt)

Start > Run > cmd (ok)  ........opens the Dos Prompt..  

Type in ipconfig /all > ip.txt

This will put your ipconfig in a text file on your desktop (as long as your dos prompt is pointing there, which is the default..)
Go ahead and copy into this thread so we can take a look..

BTW:  your settings look right above..  Do you have a working computer next to you on the same subnet (network) that you can compare the IP settings with..  In fact, post them here too...

FE
0
 

Author Comment

by:HRJ77
ID: 10891363
Thanks for the clarification!

Ok this is what I got when I ran that on my laptop :

Primary Dns Suffix     :
Node Type                : Unknown
Ip Routing Enabled     : No
Wins Proxy Enabled    : No

Media State          :  Media disconnected
Description           : Intel (R) PRO/100 VE Network Conn.
Physical Address   : 00-09-6B-7A-59-99


Here are the readings from my desktop running off the same router:


Windows IP Configuration

        Host Name . . . . . . . . . . . . : Office
        Primary Dns Suffix  . . . . . . . :
        Node Type . . . . . . . . . . . . : Unknown
        IP Routing Enabled. . . . . . . . : No
        WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

        Connection-specific DNS Suffix  . : charter.net
        Description . . . . . . . . . . . : Realtek RTL8139 Family PCI Fast Ethe
rnet NIC
        Physical Address. . . . . . . . . : 00-50-BA-B2-D1-FA
        Dhcp Enabled. . . . . . . . . . . : Yes
        Autoconfiguration Enabled . . . . : Yes
        IP Address. . . . . . . . . . . . : 192.168.0.2
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . : 192.168.0.1
        DHCP Server . . . . . . . . . . . : 192.168.0.1
        DNS Servers . . . . . . . . . . . : 192.168.0.1
        NetBIOS over Tcpip. . . . . . . . : Disabled
        Lease Obtained. . . . . . . . . . : Thursday, April 22, 2004 8:27:30 AM
        Lease Expires . . . . . . . . . . : Sunday, April 25, 2004 8:27:30 AM



0
Why You Should Analyze Threat Actor TTPs

After years of analyzing threat actor behavior, it’s become clear that at any given time there are specific tactics, techniques, and procedures (TTPs) that are particularly prevalent. By analyzing and understanding these TTPs, you can dramatically enhance your security program.

 
LVL 40

Expert Comment

by:Fatal_Exception
ID: 10891878
Media State  :  Media disconnected       This means that the connection between your Nic and the router is definitely not showing up...     Question..  When you plug the cable into the router are you getting a green link light on the panel of the router..??

1.  I assume we have tried a new cable (make sure that it is a Straight Thru and NOT a Crossover cable..)  (To make sure, you might want to use the cable from your other system..)
2.  Assume we tried a different port on the router.
3.  We might try Uninstalling the NIC..  Use the Device Manager to do this.  (My Computer > Manager > Device Manager)  Open up your Network Adapter >  right click the Intel Pro/100 Nic and Uninstall > Reboot the computer..  It will recognise the NIC and install the Network Stack..  

Let me know if any of these make sense...

FE
0
 

Author Comment

by:HRJ77
ID: 10893456
Yes there is a green light on the router. Yes, I have tried a new cable , different ports, and even connecting directly to my cable modem.

I have tried numerous times to install new drivers and have uninstalled the NIC and reinstalled till I am blue in the face. The only thing I can think to do now is to buy a NIC and try that, because it seems like the problem is coming from the Intel PRO 100 adapter. If that doesn't work I guess I will have to reformat and re-install Win 2000.

Thanks for hanging with me on this Fatal !!
0
 

Author Comment

by:HRJ77
ID: 10893814
**Update**

Well I would still like to resolve my adapter problems, but am happy to say that the Linskys card I purchased and installed got me online in seconds.
0
 
LVL 40

Accepted Solution

by:
Fatal_Exception earned 400 total points
ID: 10894509
Boy that was quick...  I was going to suggest this as a last resort, but you got there first..  And..   I have about 40 PCMCIA 3Com Nics sitting in a drawer..  Too bad you don't live close or I would have just given you one..

But glad you got it fixed..!!  

FE
0
 
LVL 40

Expert Comment

by:Fatal_Exception
ID: 10895145
ThankQ...   Sorry we could not get that Intel to work though..  :(
0
 

Author Comment

by:HRJ77
ID: 10895178
N.P. I greatly appreciate you seeing me through. You gave me many good suggestions and helped me eliminate the possible causes. Maybe someday we'll come across the answer.  THANKS AGAIN!! ; )
0
 
LVL 4

Expert Comment

by:Len Aberts
ID: 11037024
Just to throw this in as it might help. I have seen this problem before and for some reason XP will kill some connections on laptops. Unfortunately the the "cure" may be worse than the disease, usually a clean install of XP will cure the problem. A complete format and reinstall, but since you are working with another card you may not want to go this route. People that dual boot with Linux on laptops have it much worse as XP somehow alters the BIOS string and leaves Linux unable to use the NIC after an XP install. Very curious. Just my two cents...if it helps.
0

Featured Post

What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

This solves the problem of diagnosing why an internet connection is no longer working. It also helps identify the likely cause of the lost connection if the procedure fails to re-establish your internet connection. It helps to pinpoint the likely co…
Sometimes you have to pull out old tricks to get a new firewall to work… While we were installing a new Sonicwall at a customers site we found that sites they were able to visit before were not working.  It seemed random and we could not understa…
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …
This video demonstrates how to create an example email signature rule for a department in a company using CodeTwo Exchange Rules. The signature will be inserted beneath users' latest emails in conversations and will be displayed in users' Sent Items…

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now