?
Solved

Error Installing .Net Framework 1.1

Posted on 2004-04-22
5
Medium Priority
?
1,041 Views
Last Modified: 2008-02-07
We have a Windows XP machine that had the .Net Framework 1.1 loaded and applications ran fine.  Last week a VB.Net application began getting an error "Application Has Generated An Exception That Could Be Handled:  process id=0xf84 (3972), Thread id=0xf88 (3976)"

This application is run on 30+ other machines with no problems at all.

We uninstalled the .Net framework and reinstalled.  We get through the install, but when we hits the configuration screen we get an error: "Snap-in failed to initialize.  Name: .Net Framework 1.1 Configuration CLSID{1270E004-F895-42BE-8070-DF90D60CBB75"

We cannot go any further as when we click Ok it dies.  We've tried redownloading the .Net 1.1 installation file with the same results.

We've run scans on the hard drive and found no errors.

Short of reformatting the machine has anyone had this happen to them?  Any thoughts or ideas?

Thanks

RichW
0
Comment
Question by:RichW
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
5 Comments
 
LVL 25

Assisted Solution

by:RonaldBiemans
RonaldBiemans earned 500 total points
ID: 10888865
0
 
LVL 4

Author Comment

by:RichW
ID: 10891483
We tried that already, and it is does not fix the problem.

RichW
0
 
LVL 1

Accepted Solution

by:
Trancedified earned 500 total points
ID: 10896321
RichW,

Was your application developed with .NET Framework 1.0 or 1.1? You  could try to install the older Framework at the link below:

http://msdn.microsoft.com/netframework/downloads/updates/sp2/download/default.aspx

IF you developed w/ 1.0 it's not forward compatible w/ 1.1, but if you developed w/ 1.1 it's backwards compatible w/ 1.0.

-or-

I had a simliar problem before, did you try to install Framework 1.1 and then restarting the machine?

Good luck!

Chris
0
 
LVL 4

Author Comment

by:RichW
ID: 10898493
We developed the application on 1.0, and the user had 1.1 installed.  30+ other machines have 1.1 installed and they are running the 1.0 application without any problems at all.

It is 1.1 we are trying to reinstall on the machine that is giving us trouble.

I'm sure reformatting the machine will fix it, but we'll do that as a last resort.  I'd prefer to keep looking for a solution.

RichW
0
 
LVL 4

Author Comment

by:RichW
ID: 11009093
Thanks for trying guys.  I still don't have a solution, but I wanted to get this thread closed.
0

Featured Post

Get your Conversational Ransomware Defense e‑book

This e-book gives you an insight into the ransomware threat and reviews the fundamentals of top-notch ransomware preparedness and recovery. To help you protect yourself and your organization. The initial infection may be inevitable, so the best protection is to be fully prepared.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

It seems a simple enough task, yet I see repeated questions asking how to do it: how to pass data between two forms. In this article, I will show you the different mechanisms available for you to do just that. This article is directed towards the .N…
Wouldn’t it be nice if you could test whether an element is contained in an array by using a Contains method just like the one available on List objects? Wouldn’t it be good if you could write code like this? (CODE) In .NET 3.5, this is possible…
If you’ve ever visited a web page and noticed a cool font that you really liked the look of, but couldn’t figure out which font it was so that you could use it for your own work, then this video is for you! In this Micro Tutorial, you'll learn yo…
In this video, Percona Solution Engineer Rick Golba discuss how (and why) you implement high availability in a database environment. To discuss how Percona Consulting can help with your design and architecture needs for your database and infrastr…
Suggested Courses

777 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question