Solved

server on home network can't see workstation

Posted on 2004-04-22
13
1,097 Views
Last Modified: 2013-12-23
I have a server running windows adv server 2000 connected to the web through a d-link wireless router. I have a workstation connected to the router wireless, the server is connected through cat5. Server is running with a domain. I have the save domain name on the workstation. I have put the workstation name as a user and as a computer on the server. Each individual machine works fine, although neither can see each other. I have shared folders on each. What is this novice missing? Any advice?
0
Comment
Question by:stevehiwy
  • 5
  • 4
  • 3
  • +1
13 Comments
 
LVL 16

Expert Comment

by:JammyPak
ID: 10888968
I think this is just a browser issue...the fact that you're behind a WAP is preventing browser broadcasts from passing.

from the wireless machine, try this:

ping <ip of server>

if that works, try this:

ping <name of server>

if that doesn't work, then you need to setup name resolution - you could add the server to your HOSTS or LMHOSTS file (assuming that you don't have a local WINS or DNS server running)

once that works, try this:
net use \\servername\sharename

to see if you can map the drive (oh yeah, if you populate both machines LMHOSTS files, you may find that they show up while browsing now, too)
0
 
LVL 16

Expert Comment

by:JammyPak
ID: 10888984
sorry:
net use j: \\servername\sharename

to actually have a mapped drive...

you could also just do
Start - Run - \\servername
and hit enter
0
 

Author Comment

by:stevehiwy
ID: 10890300
JammyPak

Thanks for your reply. From the wireless machine, I pinged server using both internal ip and web address. Both successful. Ping with name of server also successful. I have the DNS service running on the server. I looked at LMHOSTS file on both server and workstation. Neither had been touched before. At the workstation, I placed a record with the server IP and server name. At the server I placed the  same record. I rebooted both. Still, I cannot see one from the other. I did try the start>run>net use \\servername, and also \\servername\sharename but receive an error message  "network path not found".  

0
 
LVL 1

Expert Comment

by:gbarberjr
ID: 10895922
Steve,
Is your workstation machine logging on to the domain, or onto the local computer?
If i am not mistaken, if you log onto a local computer only (not entering the username and password for the account on the domain), you are logging into a workgroup.
Well... that's my theory anyway.  Just double check to see if you workstation is logging into the domain.
There is an options button at the bottom of the log in screen. (btw.. what OS is your workstation running?)
Hope this helps.
:)
0
 
LVL 16

Expert Comment

by:JammyPak
ID: 10899086
yes, but whether he's logging into a domain account or a local computer account, he should still be able to map a drive - as long as the username and password are correct

maybe try this:

net use g: \\<servername>\<sharename> /USER: <username>

also, is your workstation actually a member of the domain? it almost sounds like you just set your workgroup name to be the same as the domain name. This is ok, but you might have more luck if you join the domain for real.
0
 

Author Comment

by:stevehiwy
ID: 10904936
Thanks gbarberjr and JammyPak,

My workstation is windows nt service pack 4 as the server is windows 2000 adv server service pack 4.

I don't think the workstation is logging on to the domain, as you suspect maybe just the local computer. I turned off the auto logon at the workstation and looked at that screen again when I rebooted. I am using the same login name and pswd as the server that has the domain. I see there is only a check box to 'log on using dial up connections' on the log on screen. I did check the box for a trail but it unchecked itself stating there were no dial up connections for all users. I re-loged on as usual.

I try the net use net use g: \\<servername>\<sharename> /USER: <username> but again I receive the message that 'no network path is found'.

In the active directory on the server, I have placed my workstation name in the 'computers' folder and the signon id in the 'users' folder. The server is the domain controller. I have this darn assumption that this allows my server to recognise my workstation and server sees it when workstation boots? I guess that is not accurate! Maybe I need to know how to get workstation to log into server? I appreciate both of your comments and assistance.
0
Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

 
LVL 1

Expert Comment

by:gbarberjr
ID: 10905353
Steve...
Right click MY COMPUTER, and verify that it is in fact a member of a domain, as JammyPak said.  If not, (i'm running Linux now, so Windows is a little fuzzy), there should be a Network Identification tab.  If you click on that (if your workstation is not a member of a domain), you can have it join... just supply the administrators username and password.  
JammyPak is correct in that you should be able to see a mapped drive, regardless of workgroup or domain member, but if you ensure to us that it IS in fact a domain member, that will give us a little bit more info to where the problem may lie.  

Later man
Glen
0
 
LVL 1

Expert Comment

by:gbarberjr
ID: 10905410
Also.. just thought of this.
On your LOGIN screen on your workstation... There (should) be an OPTIONS button.  If you click that, it will bring up a drop down box.
If your computer is a member of the domain, you will be given two options.
<yourdomain.stevescomputer> <---- domain
<steveslocalcomputer> (Local Computer)   <---- obviously... the local computer
Another thing.
When you set up your server, did you allow enough Client Access Licences to support your workstation?  Did you choose Per Seat or Per Client licencing?
These are more major issues.  Per Seat allows up to a certain amount of clients to access that computer's resources. (on the setup screen, the default is 5)
Per Client licensing requires you to purchase CALs for that machine to access that computer.
(I ran into this problem a while ago... I thought I had enough CALs to support my domain and servers, until I ran out of licenses.  I forget exact numbers, but say I originally purchased 250 CALs, that 251st machine was unable to access my domain's resources until I purchased that license.)
Another good thing to know when you are setting up servers, is you can ALWAYS revert from Per Client to Per Seat, but you cannot do the opposite.
Just some random info that may help.
0
 
LVL 16

Expert Comment

by:JammyPak
ID: 10917964
but running out of licenses doesn't actually prevent you from working....
0
 

Author Comment

by:stevehiwy
ID: 10919978
JammyPak and gbarberjr! appreciate comment and info.

I think I am per seat default 5 licensing. I was (still am) trying to keep costs to bare minimum. I don't think I have problems here but I am not sure about anything at this point. Over the weekend I unpromoted the domain from the server and re-promoted (DCPROMO) it back following the microsoft documentation that I originally followed to be sure I had done it correctly. Advanced directory, domain, DHCP services all installed and enguaged, active, forwarders, server are as per that document. Still though, when at the 'MY COMPUTER', properties, tcp/ip, properties, network identification... my full_computer_ name is stevecomputer.the_sever_domain_name. Now... I put the server domain name in there by clicking on the properties button labled 'rename this computer or join a domain', then MORE. I typed the domain name in there. BELOW the MORE button there is a radio button where you can click to join a domain or workgroup. When clicking the domain radio and typing the server domain name here.... THEN I get a message:

'The following error occurred validating the name <steve_domain_name> The error could be caused by a DNS lookup problem.  Please see the following web site HTTP://go.microsoft.com/fwlink/?linkid=5171.  The specificed domain either does not exit or could not be contracted. I went through the microsoft document "Error during domain join" but I must say I think I get to screwing things up and end up putting things back when I get bright Ideas in there.

OK ok... I have looked again for a way to 'sign on' to the domain in the sign in at the workstation. Geepers, I just don't see it. I only have a signon for the workstation. Dang, the only way I see to join a domain, gives me an error message.

What should be in the LMHOSTS file on the server, workstation? Am supposed to be signing up my workstation on the active directory 'server' and 'users' folders? Nothing I have done here in these two areas have made any difference.

Steve
0
 
LVL 16

Accepted Solution

by:
JammyPak earned 250 total points
ID: 10920685
sounds like you aren't in the domain, and I'm guessing it's a DNS problem. when you installed Active Directory, it would have populated a DNS server with the info for your domain. you need to make sure that that same DNS server is set as  your primary DNS server on your client PC.

you don't really need anything in LMHOSTS if you have DNS setup, but you could also add a line like this:

<server's IP address>    <name of server>   #PRE #DOM:<NetBIOS name of Domain>

(when I say NetBIOS name of Domain, I mean don't use the DNS-style name. It should be an 8-character text name (with no dots!)

HTH
0
 

Expert Comment

by:peemickuk
ID: 11175377
I agree with JammyPak.  It does sound like that your computer is not on the domain.  I had the same problem a few weeks back.
 I had to delete the workstation account in AD, connect the workstation to the domain.  Take it back off the domain, delete the account (again) and put it back on.

I would also check the TCP/IP settings on the workstation.  To make sure that it is configured correctly.  If using DHCP to config tcp/ip, try a static IP address.

HTH
0
 

Author Comment

by:stevehiwy
ID: 11175721
thanks peemickuk

appreciate your info!
0

Featured Post

What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

A brief overview to explain gateways, default gateways and static routes OR NO - you CANNOT have two default gateways on the same server, PC or other Windows-based network device. In simple terms a gateway is formed when a computer such as a serv…
Enterprise networks where VoIP phones have been deployed frequently use port configurations that allow both a computer and an IP phone to be plugged into the same switch port but use different VLANs. On Cisco equipment I'm referring to the "native V…
This video discusses moving either the default database or any database to a new volume.
Excel styles will make formatting consistent and let you apply and change formatting faster. In this tutorial, you'll learn how to use Excel's built-in styles, how to modify styles, and how to create your own. You'll also learn how to use your custo…

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now