Solved

Calcomp TechJET 5336 Color Setup Issues Under Win98SE for AutoCAD R 13-c4, PhotoShop and Windows Applications

Posted on 2004-04-22
8
2,018 Views
Last Modified: 2009-07-29
I recently purchased two Calcomp TechJET 5336 Color Plotters (not the GT or GT/PS versions).  I have the original owner's user manual.  The setup information therein only covers Win 95 installations and AutoCAD through Release 12.  I have also been to the http://www.calgraphinc.com/Support/tjcolor.html website and downloaded the latest dirvers and installation information.  

I have downloaded and installed all of the updated drivers from the website.  I have precisely followed all of the (README.TXT) instructions provided for set-up and installation, but neither plotter will work with either the Windows raster driver or the AutoCAD ADI driver.  I have even swapped the cables that I am using to eliminate them as a factor.  I have also tried two different PC’s to eliminate the machine itself as a factor.

I have been trying to utilize the Centronics connections on the plotters.  I have inspected the connectors and they are not corroded.  They are very clean.

My computer BIOS set-up allows for several choices on configuration for the parallel port (LPT1).  NORMAL (automatic detect), ECP, EPP and ECP+EPP.  I have tried both the NORMAL (automatic detect) and ECP settings.   I have also tried the Serial RS232C method of connection without success.

I used CCLEAN95 to remove the original Windows drivers from the OS prior to installing the updated drivers.  Before installing the new drivers, I checked the “add new printer” list to make sure that they were gone.  I installed the drivers exactly as specified in the instructions and set the plotter parameters as specified for Windows.  Still nothing.  I even tried all of the drivers listed that could possibly pertain to my plotters.

Attempts to do a test plot (print test page) from Windows gives
“There was an error writing to LPT1……….”
It also shows a little window saying “Print Failure!   %%%%CALCOMP DEVICE CONTROL”

AutoCAD yields a similar error message.
“AutoCAD Message   Error Writing Output”  

Please help me…….here is what I have.

Windows 98SE Operating System (on 1.2 GHz PC’s with 768 Meg RAM)
AutoCAD Release 13-c4
PhotoShop 6.0

The only thing that I have not tried is setting up the plot spooling in a Windows NT/2000 manner (Supposedly, you do not have to do that in Win98, but at this point, I'm willing to try anything.)  Both plotters test out OK and both generate excellent ,test, pallet and stitch plots.

Please let me know what my exact plotter settings, computer settings and drivers should be for using these plotters with my OS and software.

Thank you for your kind assistance.

Sincerely

Lynn A Thornton
0
Comment
Question by:Sleeping_Dog
  • 2
  • 2
  • 2
  • +2
8 Comments
 
LVL 38

Expert Comment

by:Herman D'Hondt
Comment Utility
It seems unlikely that both printers (or PCs) would have faulty parallel ports. It is possible that the driver for some other device (printer, scanner, etc) has installed a parallel port handler that stops normal communication.

Check in Device Manager. If the driver for LPT1 is anything but the Microsoft driver, Uninstall it and load the default driver.

To test the connection, bring up a DOS prompt and type

DIR > LPT1:

That should send a listing of the current directory to the printer.
0
 
LVL 21

Expert Comment

by:briancassin
Comment Utility
Do as hdhondt suggested with the test from DOS. If you cannot get connectivity in DOS then you are having a physical connection problem.

One thing you did not mention was how long the cable you are using....

Even though you mentioned you swapped the cables Your parallel printer cable(s) needs to say IEEE1284 on it this should be printed somewhere on the cable either on the cable itself or on the connectors, it also cannot be any longer then 10ft at maximum. Also do make sure the cable is connected directly from the back of the computer to the printer no switch boxes etc... If IEEE1284 is not imprinted on the cable you will need to get one that does have this printed on the cable. This cable standard is required by your plotter.

Also your Bios should be set to normal and in windows in device manager the port should be listed as a standard parallel port or bi-directional if it is listed as ECP or EPP you will need to remove it from device manager hit refresh then let the plug and play come up and then select "Let me choose from a list" or something similiar to that affect then select ports, parallel port, standard then standard port type or bi directional then continue through the wizard till the end.

In addition check for this file go to start find files or folders make sure where it says look in you have the C: drive selected and include sub folders... where it says named type in "DRVWPPQT.VXD"      (without quotes) then hit find / find now...

If it does display this file in the results window below then right click on the file select rename put your cursor at the end of the D in VXD left click once so you have a blinking cursor and backspace 3 times to the dot  then type in OLD hit enter it should now read DRVWPPQT.OLD close the find window go to start select shutdown, shutdown the pc and the printer for a minimum of 2 minutes then turn on the printer and then the pc and try printing again.

0
 
LVL 21

Expert Comment

by:briancassin
Comment Utility
If you have had any other previous printers, scanners, tape backup drives, installed on these systems please list them as hdhondt mentioned other previous devices may have loaded drivers which are now preventing other devices from communicating through the ports.


If it is still not working after the above....

Go to start settings printers then right click on the plotter driver select properties go to details make sure under print to the following port it is set to print to lpt1. You can also change the spool settings by clicking on that and try selecting print directly to printer and have RAW for the data format instead of EMF.

Let us know if any of this helps or not or what the results are.
0
 
LVL 23

Expert Comment

by:sciwriter
Comment Utility
Lynn --

You need to set the BIOS for the LPT1 as either SPP (single PP) or EPP -- do not use ECP as it has lots of problems with older driver protocols.

Once you've done that, you MUST go into the Calcomp setup on the printer and change its port settings to match what you are sending from the computer.  If you don't do this it will never work.

Once you get used to the printer setup, you can also experiment with the serial port, protocol, etc, and match it to the PC settings.  There must be synchroneity at the printer and computer setup for this to work.
0
Find Ransomware Secrets With All-Source Analysis

Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

 

Author Comment

by:Sleeping_Dog
Comment Utility
Thanks again, all.  I really do appreciate the input.  An update:

I had already cleared all existing drivers.  I had also removed and re-estalished the parallel port.  Fortunately, the "Normal" setting in the BIOS on the computer is actually an "automatic" or "auto-detect" parallel port setting.

I then called CalGraphics (who now officially supports Calcomp) and asked them for the correct plotter settings for using AutoCAD 2000 under Windows 98 SE.  (I have an educational copy of ACAD 2K).  I had to call and ask because they did not list these settings on their website for this combination of OS and software.

Other than the default settings, the plotter panel settings are:

Protocol - AUTO
Input Resolution - 360 DPI
Port Type - CENTRONICS
EOP Timer - DISABLED
Input Buffer - 100K
Stitch - 0

I downloaded the updated driver package from the AutoDesk website for AutoCAD 2000 and installed it.  It included the updated ADI drivers for Calcomp plotters.  (I had already done the same thing for AutoCAD 13-c4).

I set the ACAD configuration to the following parameters in Autocad 2K and 13.  This was my "Starting Point":

Calcomp TechJET Inkjet Plotters    ADI 4.2  V 6.55 by Calcomp
TechJET Color 5336  E/AO
<P>  (Parallel Port)
Parallel Port Name - LPT1

Plot Optimization Level - 1
Plot WILL be written to a selected file
(Plot file name was set to "LPT1" in a different setup area of AutoCAD)
Sizes are in Inches and the style is Landscape
Plot origin is at (0.00, 0.00)
Plotting area is 43.00 wide by 33.00 high (E size)
Plot is not rotated.
Area fill will not be adjusted for pen width.
Hidden lines will not be removed.
Plot will be scaled to fit available area.
(Some of the preceeding Items I might change as I become more familiar with this plotter and I fine tune its working with AutoCAD)

Description - Calcomp TechJET 5336 Color Plotter

LO and BEHOLD!  IT WORKED under AutoCAD 2000.  Then, just for giggles, I tried it with AutoCAD 13-c4.  EUREKA!  It worked again.  I then looked back at the documentation from both the CalGraphics site and the original User Manual.  Both sets of documentation differed from what CalGraphics had told me over the phone for setup on the plotter panel.

I guess that the moral of this story is "Don't believe everything that you read."

Once again, I want to thank everyone for their input and assistance.  I can only hope that in the future, this thread will help some other poor schmuck like me get their Calcomp TechJET plotter up and running.

With Kindest Regards.

Sleeping Dog  
0
 

Author Comment

by:Sleeping_Dog
Comment Utility
PS

I will probably have more questions to add to this thread as I try to:

A.  Get the Windows drivers to work with this plotter for applications like PhotoShop and PowerPoint.
B.  Set the plotter up to function as a "Network Printing Device".
C.  Get the plotter to work from LINUX applications.

Fortunately, the plotter's panel settings allow one to set up four different sets of parameters and save each under user numbers 1 through 4.
 
Have a Great Day, All.

Sleeping Dog
0
 
LVL 38

Expert Comment

by:Herman D'Hondt
Comment Utility
No comment has been added to this question in more than 21 days, so it is now classified as abandoned..
I will leave a recommendation in the Cleanup topic area that this question is:
PAQ/Refund
Any objections should be posted here in the next 4 days. After that time, the question will be closed.

PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!

hdhondt
EE Cleanup Volunteer
0
 

Accepted Solution

by:
modulo earned 0 total points
Comment Utility
PAQed, with points refunded (300)

modulo
Community Support Moderator
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Suggested Solutions

If you use a Brother DCP 130C or similar Brother printer, at some point you might encounter the following problem: after you change the ink cartridge, the printer displays an "ink empty" message. Sometimes you just need to follow the instructions…
When I recently replaced my image transfer kit on my office HP color laserjet 5550dn printer, I had a slight problem.  The left bracket that holds the transfer kit got stuck in the upright locked position instead of being at a 45 degree angle facing…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now