E10000 annoying message on solaris 9

Hi everyone,

I have a ULTRA30 with Solaris 9. I just reinstalled it.

Everything's fine with it except everytime if I reboot the server (good thing it doesn't happen often) I get a message (sorry I don't have the exact message) which states :

"You server can be configured as an SSP for E10000. Do you want to enable it ? (Y/N)"

Problem is, it just doesn't boot until I've answered yes/no, so I can't login to it remotely and have to ask the admin at that particular site to answer NO everytime...

Question 1 : WHY ??? I mean Solaris shouldn't assume everyone has E10000's lying around.

Question 2 : How can I disable it for good ? And if the answer is : "reboot again" and it shouldn't appear anymore, please tell me where it stores the flag to not appear in the future.

Question 3 : Did I make a mistake when I reinstalled the box ?


I've seen this on solaris 8 too if I'm not mistaken and it's quite annoying.
Thanks for any help in advance !

Martin
LVL 1
cyberpassionAsked:
Who is Participating?
 
rkotaraCommented:
Probably the better way to do this is to properly remove the SSP packages you may have inadvertently installed and then reboot.  Here are packages you may have:

SUNWsspdf      System Service Processor Data Files
SUNWsspdo      System Service Processor Domain Utilities
SUWsspdr      System Service Processor Dynamic
SUNWsspfp      System Service Processor Flash Prom Image
SUNWsspid      System Service Processor Inter-Domain
SUNWsspmn      System Service Processor On-Line Manual Pages
SUNWsspob      System Service Processor Open Boot Prom
SUNWsspop      System Service Processor Core Utilities
SUNWssppo      System Service Processor POST Utilities
SUNWsspr       System Service Processor, (Root)
SUNWsspst      System Service Processor Scan Tests
SUNWsspue      System Service Processor User Environment
SUNWuessp      Sun Enterprise 10000 SSP 3.4 Collection

Just do a pkgrm on them (as root):
pkgrm SUNWsspdf SUNWsspdo SUWsspdr SUNWsspfp SUNWsspid SUNWsspmn SUNWsspob SUNWsspop SUNWssppo SUNWsspr SUNWsspst SUNWsspue SUNWuessp
0
 
liddlerCommented:
I don't know this particular problem, but it is almost certainly a script in /etc/rc2.d or /etc/rc3.d

Try:
cd /etc/rc2.d
grep SSP *
and / or
cd /etc/rc3.d
grep SSP *
If this gives a script, rename it by change the S to s and it will not run at next reboot
0
 
cyberpassionAuthor Commented:
THIS SOLUTION WORKED PERFECTLY !
Man, I didn't want to browse into admintool finding which packages caused this !

Just out of curiosity, Is it in the tree when I install it that this function gets enabled ?
If so, where !!!

Thanks again to all who answered !
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.