Solved

How do I write to an NTFS partition ???

Posted on 2004-04-22
21
286 Views
Last Modified: 2010-08-05
I have installed Mandrake 10. in 2 computers.
Both of these computers have windows and linux installed.

In computer "A" when ever I am using Linux, then I am able to write to other partitions in my disk, even though these other partitions are format as NTFS, which is the formatting method used by windows.

In computer "B" when ever I am using Linux I can only read from the other partitions ( NTFS ) but I can not write to them.

Some how I probably installed a package or something in computer "A" and therefore I can write to the partitions, but I can not do the same thing with computer "B".

WHY ???
How do I solve this problem ???
What package should I installed ???
0
Comment
Question by:digi_mind
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
21 Comments
 
LVL 44

Accepted Solution

by:
Karl Heinz Kremer earned 50 total points
ID: 10895344
Did you by any chance install Captive (http://www.jankratochvil.net/project/captive/) ? If not, this may be the package you want.
0
 

Expert Comment

by:MotiAd
ID: 10896876
do not!!!!!! do that.
there is a very simple reason for that.
through unix/linux reading from NTFS parts is very easy and good.
when you write to this part you take a very big risk that some of the data on your system will be deleted!!!!
this is a problem.
any way, if you still want to, mount the part with read/write access and it is the same as working with other parts.
0
 
LVL 44

Expert Comment

by:Karl Heinz Kremer
ID: 10897627
Captive uses the original Windows NTFS driver, therefore the risk is (still there but) less than with the native Linux NTFS file system driver.
0
Stack Overflow Podcast - Frustrating Miracles

In this podcast, Stack Overflow interviewed Linux Academy CEO/Founder, Anthony James, and got his developer story!

"Follow your passion, be prepared to work hard and sacrifice, and, above all, don't let anyone limit your dreams."  - Donovan Bailey

 

Author Comment

by:digi_mind
ID: 10897774
Actually I can just right click and add a new hard disk with mandrake, but when I want to create a folder into this new partition, I get a message saying:

Error write/access denied.

Then, I log in as root and I change the rights for that partition with:

chmod 777 x

"x" is the name of the partition.

then i am supposed to be able to read, write and execute the files contained in this partition, but I keep on getting the same message.

Suggestions ???
0
 
LVL 44

Expert Comment

by:Karl Heinz Kremer
ID: 10897948
The NTFS driver that comes with Mandrake is the read-only driver. So just changing the permissions on a directory will not change the underlying permissions of the file system.
0
 

Author Comment

by:digi_mind
ID: 10898010
But I can do it with my laptop.... why then ???
0
 

Author Comment

by:digi_mind
ID: 10898020
How about this then... I created another partition. This partition is called dev/hda9 and I formatted with the linux format system I believe it is ext3.

And I can not write to it !!!
0
 
LVL 44

Expert Comment

by:Karl Heinz Kremer
ID: 10898210
How did you mount /dev/hda9? You can write to the partition that hold your home directory, so there is nothing wrong with the system, it's probably just a matter of passing the right options to the mount command.
Run this command:
mount
and post the output here. I'm pretty sure that there will be a difference how / is mounted vs. how /dev/hda9 is mounted. Also, run the mount command without any parameters on both your systems after the NTFS partition is available. Do you see a difference in how the partitions are mounted on your two systems?
0
 
LVL 14

Expert Comment

by:cjl7
ID: 10898243
Hi,

My guess is that you are running two different distro's and one has NTFS write compiled into the kernel and the other hasn't...

What you need to do is to re-compile your kernel and add NTFS write support...


//jonas
0
 
LVL 44

Expert Comment

by:Karl Heinz Kremer
ID: 10898276
Did you check the link to the Captive project, and are you sure that you did not install this package on one of your machines?
0
 

Author Comment

by:digi_mind
ID: 10898777
Ok... then I will say forget about the NTFS... now:

How do I write to an ext3 partition.

1. The partition "x" is mountet.
2. I can read from the partition.
3. I can NOT wrtite to it.

How do I cahnge the rights for it ????
0
 

Author Comment

by:digi_mind
ID: 10898835
I say forget about it, because when I am "root" then I can write to an NTFS partition or to an ext3....

I can not do this as a normal user. I believe it has to do something with the rights.
0
 
LVL 12

Expert Comment

by:j2
ID: 10898855
You can not set rights on a NTFS/FAT/Other Non *NIX-native partiton, it has to be _mounted_ with the correct options. Look at the gid and uid options of mount.
0
 

Author Comment

by:digi_mind
ID: 10902195
Listen .... ext3 is my partition now...

So how can I write to it ???
0
 

Author Comment

by:digi_mind
ID: 10902213
and j2 I siad:

"I can write and read as root from an to an NTFS partition" but not as a normal user.

0
 

Author Comment

by:digi_mind
ID: 10902221
khkremer no the driver is not read only, because I can write to the partition as root, but not as a normal user.

0
 
LVL 5

Expert Comment

by:pbhj
ID: 10905301
I think what you're after is changing the permissions of the mount to rw ... either in the /etc/fstab file ("defaults" only allows ro for users afaik) or from the shell:

mount -o remount -rw /dev/hdaX

Check out the man-page  ("man mount") for more info.
0
 
LVL 44

Expert Comment

by:Karl Heinz Kremer
ID: 10905522
If digi_mind can write as root user the partition is already mounted in rw mode.

Try to run chmod 777 on a directory on this partition (as root) and try again to write as normal user to this directory. Does this work?
0
 

Expert Comment

by:sallauddins
ID: 11002991
khkremer suggestion to use captive drivers works for me. digi_mind u also try the same it really works.

Thanks khkremer.
0

Featured Post

Secure Your WordPress Site: 5 Essential Approaches

WordPress is the web's most popular CMS, but its dominance also makes it a target for attackers. Our eBook will show you how to:

Prevent costly exploits of core and plugin vulnerabilities
Repel automated attacks
Lock down your dashboard, secure your code, and protect your users

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

1. Introduction As many people are interested in Linux but not as many are interested or knowledgeable (enough) to install Linux on their system, here is a safe way to try out Linux on your existing (Windows) system. The idea is that you insta…
Fine Tune your automatic Updates for Ubuntu / Debian
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
Suggested Courses

621 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question