• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 173
  • Last Modified:

Microsoft DNS Question

I have my domain controller running as my internal DNS.  This works just fine.  I also have a Routing and Remote Access service running on the same machine which my company uses in order to VPN into the network.  Here is my problem:

Inside my network, this works:

ping server1.my_domain.my_company.com
It Replies:  192.168.1.6, which is correct

While VPN'd into my network, it doesn't work:

ping server1.my_domain.my_company.com
It Replies:  A real IP address from my service provider

I tried doing a tracert on it, and it seems that it goes to my Routing and Remote access server, which is also my DNS server, but then it gets forwarded to the network's default gateway of 192.168.1.1.  After that it tries to resolve that domain on the internet, which of course will not work.

I guess my question is how do I tell my DNS server that this is an internal server?  I have an entry in the forward lookup zone for this server:

server1           192.168.1.6

I just can't figure out how to tell my internal DNS server how to resolve server1.my_domain.my_company.com

Any help would be appreciated.  Thanks!
0
barthalamu
Asked:
barthalamu
1 Solution
 
Christopher McKayMicrosoft Network AdministratorCommented:
Hi barthalamu,
You need to enter a pointer in your DNS that says:

server1.my_domain.my_company.com         192.168.1.6

Hope this helps!

:o)

Bartender_1
0
 
barthalamuAuthor Commented:
I tried creating a PTR record, but it does not seem to help.  It will not allow me to enter an IP address.  I created a record that looks like:

Name:                    Data:
--------                   -------
server1                   server1.my_domain.my_company.com


Is this correct?  I also tried clearing the cache.

Thanks.
0
 
MSGeekCommented:
What IP address are the VPN clients getting?  In the VPN client what IP do you have configured for DNS?
0
Cloud Class® Course: Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

 
PaulADavisCommented:
try enabling ip routing on the ip tab of the rras server properties....
0
 
barthalamuAuthor Commented:
MSGeek:

The RRAS service is giving out the range of:
192.168.1.201 - 192.168.1.215

Here is a sample of what the RRAS is giving out to a client when connected:  ( ipconfig /all )
IP Address. . . . . . . . . . . . : 192.168.1.202
Subnet Mask . . . . . . . . . . . : 255.255.255.255
Default Gateway . . . . . . . . . : 192.168.1.202
DNS Servers . . . . . . . . . . . : 192.168.1.5
                                            64.81.45.2
Primary WINS Server . . . . . . . : 192.168.1.8

The 192.168.1.5 is my internal DNS server.

PaulADavis:
I do have this enabled.  Thanks.

Thank to both for the help.
0
 
barthalamuAuthor Commented:
MSGeek:

The RRAS service is giving out the range of:
192.168.1.201 - 192.168.1.215

Here is a sample of what the RRAS is giving out to a client when connected:  ( ipconfig /all )
IP Address. . . . . . . . . . . . : 192.168.1.202
Subnet Mask . . . . . . . . . . . : 255.255.255.255
Default Gateway . . . . . . . . . : 192.168.1.202
DNS Servers . . . . . . . . . . . : 192.168.1.5
                                            64.81.45.2
Primary WINS Server . . . . . . . : 192.168.1.8

The 192.168.1.5 is my internal DNS server.

PaulADavis:
I do have this enabled.  Thanks.

Thank to both for the help.
0
 
barthalamuAuthor Commented:
sorry about the double post.
0
 
MSGeekCommented:
bathalamu.. change RRAS so the client does not receive a default gateway when connected.  They will not be able to surf the web, but do you want them doing so from an unsecured location?

The other solution would be to go with something a little more secure.  Depending on the number of users you have a Cisco PIX 501 or 506E with the Cisco VPN client will give you 3DES encryption and a sure tunnel  MSGeek
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Introducing Cloud Class® training courses

Tech changes fast. You can learn faster. That’s why we’re bringing professional training courses to Experts Exchange. With a subscription, you can access all the Cloud Class® courses to expand your education, prep for certifications, and get top-notch instructions.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now