Remote desktop behind the router failed.

So, there's Win XP pro,
Zyxel Prestige 643 router
ADSL from Covad, 1 Static IP with NAT
It's only one comp. Everithing is working fine. I have internet, I can use HTTP, FTP, SMTP, POP3, etc. But no remote desktop.
I checked the port 3389 a hundred times. It's open. But every time I'm getting this error:
"The client could not establish a connection to the remote computer..."
Any ideas?
LVL 10
vadim63Asked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
Fatal_ExceptionConnect With a Mentor Commented:
If it were me, I would get a laptop (maybe from a friend..?) and try to establish a connection within the LAN..  To troubleshoot this properly, we need to take some of the hardware out of the mix, so to speak, to try to narrow the problem down...  Just a thought..
0
 
Fatal_ExceptionCommented:
Have to start somewhere, so the first question is have you ticked the Allow Users to Connect Remotely in the System Properties > Remote tab...??

And, if you have a second XP box in your internal LAN, can you RDP to the subject computer internally..??
0
 
vadim63Author Commented:
There's one XP box only. "Allow Users to Connect Remotely" is checked
0
[Webinar] Kill tickets & tabs using PowerShell

Are you tired of cycling through the same browser tabs everyday to close the same repetitive tickets? In this webinar JumpCloud will show how you can leverage RESTful APIs to build your own PowerShell modules to kill tickets & tabs using the PowerShell command Invoke-RestMethod.

 
Fatal_ExceptionCommented:
Ok, next be sure that you XP firewall is either turned off, or that it is allowing Port 3389 to  come through..  The firewall is located on the TCP/IP properties window.. Advanced tab...  The setting is Remote Desktop..

Not sure about the Zyxel Prestige 643 router..  never been into its interface, but many of these are including firewalls along with their NAT devices, so check that also..  And usually, you must configure the Port (3389) to be forwarded to a specific IP address, which identifies the host computer..  This should be a static address, so it can find it everytime you try to logon with RDP...  (in other words, do not use DHCP for your internal addressing of this system..  Set your IP config statically, including DNS, Default Gateway, etc...)

FE
0
 
vadim63Author Commented:
Thank you. Everything is done. But no result.
0
 
vadim63Author Commented:
Thank you, I'll try it today. Good idea.
0
 
vadim63Author Commented:
The problem is resolved. Thank you. It's a good idea about laptop.
0
 
Fatal_ExceptionCommented:
That was too easy..  and am sure that just plugging the laptop in did not fix it, but will not look a gift horse in the mouth..  (where did that saying come from anyway.. :)

Thanks..

FE
0
 
vadim63Author Commented:
Sure, that points just for good idea. I found the problem, when I hooked up laptop.
0
 
Fatal_ExceptionCommented:
Great...   thanks again..

FE
0
All Courses

From novice to tech pro — start learning today.