• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 340
  • Last Modified:

windowmaker

Hello,
I have a pc running rhl 9.0.  I am trying to install windowmaker for my gui.  I have successfully installed the rpm and compiled the tar version.  However it does not update my login screen to allow its use.  Can anyone help please.

Gavin
0
mbpssgms
Asked:
mbpssgms
  • 2
  • 2
1 Solution
 
cjl7Commented:
Hi,

The easiest way to get it to work is to create a .xinitrc file in your home dir, it only needs one line to work...

exec wmaker

Then start your X-server by running startx (don't try to login with gdm/xdm...)

In order to get to runlevel 3 do init 3, after that do startx.

//jonas
0
 
mbpssgmsAuthor Commented:
Great!!!
This worked, but how do I login to a wmaker shell from gdm, entering runlevel 3 each time is a bit messy?

Gavin.
0
 
cjl7Commented:
Short answer: I don't know...

One solution is to change the /etc/inittab file and find the line

id:5:initdefault:

And change the "5" to "3". Then you will be in "console" mode (runlevel 3) and then you just need to login and do a startx....

//jonas
0
 
mbpssgmsAuthor Commented:
Yes, I have already done this, but other users of this machine are not comfortable wit a command line.  No matter.  Do you know how to change the font sixe and terminal colour in a xterm.  On irix it is xterm -f <options>?

Thanks Gavin.
0

Featured Post

Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now