• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 342
  • Last Modified:

DC registers its A record with old IP address after reboot

Hi,
 
I have recently changed the IP address of an SBS Windows 2000 AD controller. This server is also running Exchange 2000, DNS, DHCP and WINS and is the only server in the network. Here's what I done:
 
1/ changed IP address of server
2/ Stopped then restarted DNS
3/ Restarted Netlogon service
3/ ipconfig /registerdns
4/ restarted all clients
 
The server keeps registering it's old IP address so I have to manually edit the record to reflect the new IP address so that clients can connect to the server. This also happens every time the server is rebooted. I have checked the hosts and LMhosts files and there isn't any entry of the old IP address, I have also checked WINS entries. I can't find out why the server is registering it's old IP address. The server very intermittently changes the entry without rebooting, which brings the network down. I have also tried unchecking the 'register this connections address in DNS' but still the problem occurs. Something is telling the server to register its old IP address, which is really causing problems.
 
Any help would be greatly appreciated. Thanks
0
proit
Asked:
proit
1 Solution
 
mohsynCommented:
Do a search in Regedit for old IP
0
 
aflockhartCommented:
ipconfig / flushdns  ??

0
 
corneliupCommented:
Check your SOA record, the Name Servers tab, and change the new IP address.
then reload the zone.
0
Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

 
proitAuthor Commented:
Thanks for the replies so far. I have already updated the SOA record and tried ipconfig /flushdns. I will try to search the registry in the morning as I can't TS to the server at the moment.
0
 
aflockhartCommented:
Clearing the DNS server's cache might be worth a try too, if you haven't done so already.
0
 
proitAuthor Commented:
Thanks for for all your idea's. I resolved it by scanning the registry. There was an entry under DNS that related to the old IP address, I amended this and all is fine.
0

Featured Post

Prep for the ITIL® Foundation Certification Exam

December’s Course of the Month is now available! Enroll to learn ITIL® Foundation best practices for delivering IT services effectively and efficiently.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now