• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 137
  • Last Modified:

Local printers will not install on Windows 2000 Terminal Server

Hello,

Now that we have clients beginning to upgrade from 2000 to XP, for whatever reason their local printers are no longer being pulled into the terminal server.  In this case, its an officejet D145.

I'm assuming this is driver related.  However, I have tried having the user log in as administrator, and still it does not install the driver (I'm kind of thinking it should).  I've tried putting the XP drivers on the 2000 term srvr, and tried putting the 2000 drivers on the local client.  Neither seems to make a difference.

Is there any way to map back to the client for this (manually install the printer)?  Citrix makes it really easy, but terminal server seems to lack some of the more important controls for those sort of things.  This is a remote client connecting through a Cisco PIX VPN, so mapping the printer through traditional means is not an option.

Thanks in advance for the help!
0
caw01
Asked:
caw01
1 Solution
 
sr75Commented:
Try this suggestion from http://www.jsiinc.com/SUBJ/tip4700/rh4738.htm

1. Start / All Programs / Accessories / Communications / Remote Desktop Connection.

2. In the Remote Desktop Connection dialog, press Options.

3. Select the Local Resources tab.

4. Press Printers in the Local Devices area.

5. Press Connect.
0
 
salvagbfCommented:
When you say you "put" the XP drivers on your server, did you just copy the files or did you install the printer as if it was connected to the server through the add printer wizard? At my last job for a user's local printer to work (via term srvcs), we had to install printers in the add printer wizard as if they were locally installed on our server.
0
 
caw01Author Commented:
This option is already checked.  This user has been using a deskjet 830C and the term server has been pulling it in just fine.  It just wont pull in the new printer (officejet d145).

- Chris
0
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
caw01Author Commented:
Does 2003 server have any better way of doing this?  I know you can now see your local drives with 2003.  I know they have borrowed some of the Citrix technology, just not the good parts...  :)
0
 
caw01Author Commented:
I hvae both the XP and the 2000 driver installed on the TS for this printer.  The XP driver is "hp officejet d series" and the 2000 driver is "hp officejet d series printer".

I installed the drivers to lpt1 and just labeled the printers DO NOT USE.  I figured I'd delete them after I knew it was working.

- Chris
0
 
sr75Commented:
I know I have had issues with an HP Officejet printer and the Drivers not working in TS (similar to your set up) in the past.  I just had them return the printer for a different one.  It may have been the same model as yours.  I tried everything I could think of as well.
0
 
caw01Author Commented:
Unfortunately, thats not a good option for my client...  They don't care what problems I'm having, they just want it to work...  Ahhhh customers..  aren't they great!
0
 
caw01Author Commented:
Here is the $99 answer from Microsoft.  I hope it helps someone else.  How do I close the question without accepting one of the responses above?

Based on the problem description, I understand that a multi-function printer installed on your system is not redirected in a terminal session as expected. You have tried to install the driver on both the server side and the client side, but that did not work. If I have misunderstood your concern, please let me know.  

Based on my experience, this issue occurs because the printer port does not begin with COM, LPT, or USB. By default. Printer port names that do not begin with COM, LPT, or USB are only redirected in Windows Server 2003 (act as client). By default, multifunction print devices may not be redirected unless you are running Windows Server 2003 on your local computer because they use DOT4 ports.

For a solution, please proceed with the steps below.

Solution
=================
To resolve this problem on a on the XP Client, force all ports (including DOT4) on the client computer to be filtered for redirection. To do this, add a DWORD value named FilterQueueType to HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client\Default\AddIns\RDPDR and set its value data to FFFFFFFF.

Follow these steps, and then quit Registry Editor:

1. Click Start, click Run, type regedit, and then click OK.
2. Locate and then click the following key in the registry:
       
        HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client\Default\AddIns\RDPDR

3. On the Edit menu, point to New, and then click DWORD Value.
4. Type FilterQueueType, and then press ENTER.
5. On the Edit menu, click Modify.
6. Type FFFFFFFF, and then click OK.

This enables all ports on the client to be redirected.

To work around this problem on a client computer that has a multifunction print device, change the port that the multifunction print device uses from DOT4 to an LPT port.

For example, to configure a multifunction print device to use an LPT port on a Windows XP-based computer, follow these steps:

1. In Control Panel, open Printers and Faxes.
2. Right-click the local printer that is not redirected, and then click Properties.
3. Click the Ports tab, click an LPT port, and then click Apply.

        The printer should now appear next to that port.
4. Close the Printer Properties window, and then reconnect by using Remote Desktop.

Important When a multifunction printer is using a standard LPT port instead of the DOT4 port, it loses its multifunction capabilities, such as scanning, faxing, or copying. To regain the multifunction capabilities, the print device must use the DOT4 port.
0
 
caw01Author Commented:
How do I close this question after I have gotten my own answer?
0
 
caw01Author Commented:
I wouldn't delete this post as the answer to the original question is included in it.  If I could accept my own answer I would.  Someone will find this information helpful.
0
 
Computer101Commented:
PAQed, with points refunded (500)

Computer101
E-E Admin
0

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now