Solved

1751 routing across a clear channel t1

Posted on 2004-04-23
17
780 Views
Last Modified: 2010-04-17
Hi all,

Here is my question, I hope someone can help me. I have 2 cisco 1751 routers on a point to point clear channel t1. I have the t1 setup, and I can ping the opposite router, but I cannot ping past the opposite router ethernet port. I need to be able to get an ip via dhcp and browse the opposite network, as well as get internet access accross the t1. Below are the configuration settings.

router a (the one conected to the internet)

Building configuration...

Current configuration : 956 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname routera
!
logging queue-limit 100
enable secret 5 $1$CMIj$zbYtyK9sU9P9YM61raHXd.
enable password
!
memory-size iomem 20
ip subnet-zero
!
!
!
!
!
!
controller T1 0/0
 framing esf
 clock source internal
 linecode b8zs
 channel-group 0 timeslots 9-23
 tdm-group 1 timeslots 1-8,24
!
controller T1 0/1
 framing esf
 clock source internal
 linecode b8zs
 tdm-group 1 timeslots 1-8,24
!
!
interface FastEthernet0/0
 ip address 10.90.30.75 255.255.255.0
 speed auto
 full-duplex
 no cdp enable
!
interface Serial0/0:0
 ip address 10.0.0.1 255.255.255.0
!
router eigrp 100
 network 10.0.0.0
 auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.90.30.1
no ip http server
!
!
access-list 1 permit any
connect 1 T1 0/0 1 T1 0/1 1
 !
!
!
line con 0
line aux 0
line vty 0 4

!
no scheduler allocate
end

router b (the one that needs to browse the opposite subnet and internet via the t1 connection)

routerb#s run
Building configuration...

Current configuration : 956 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname routerb
!
logging queue-limit 100
!
memory-size iomem 20
ip subnet-zero
!
!
!
!
!
!
controller T1 0/0
 framing esf
 clock source internal
 linecode b8zs
 channel-group 0 timeslots 9-23
 tdm-group 1 timeslots 1-8,24
!
controller T1 0/1
 framing esf
 clock source internal
 linecode b8zs
 tdm-group 1 timeslots 1-8,24
!
!
interface FastEthernet0/0
 ip address 10.90.29.75 255.255.255.0
 speed auto
 full-duplex
 no cdp enable
!
interface Serial0/0:0
 ip address 10.0.0.1 255.255.255.0
!
router eigrp 100
 network 10.0.0.0
 auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.90.30.75
no ip http server
!
!
access-list 1 permit any
connect 1 T1 0/0 1 T1 0/1 1
 !
!
!
line con 0
line aux 0
line vty 0 4
 !
no scheduler allocate
end


If you need more info ( I am far from an expert on this) please let me know.

thanks!
0
Comment
Question by:raspis21
  • 6
  • 4
  • 4
  • +2
17 Comments
 
LVL 28

Expert Comment

by:mikebernhardt
Comment Utility
First of all, both serial interfaces have the same IP address.

The remote router has a static default route pointing at the other side's fast ethernet. That won't work, as it's not the next hop (you could do this with default-network). But EIGRP automatically advertises a static default route to all other routers. So both routers are sending default routes, but both are ignoring that info and listening to their own static routes.

On the router which is the last hop to the internet which is in the same EIGRP domain, configure the static route (maybe it's the "local" router you've shown). Remove it from all other routers and you'll see that it works fine.

0
 

Author Comment

by:raspis21
Comment Utility
oops, you know what, the config was wrong. router a and b do have different serial addresses. 10.0.0.1 on router a and 10.0.0.2 on router b. oops!
0
 

Author Comment

by:raspis21
Comment Utility
I can't check it until Monday (maybe a slim chance tomorrow), but I will let you know if that is it as soon as I can!
0
 
LVL 7

Expert Comment

by:pedrow
Comment Utility
Give these things a try:

Router A:

interface FastEthernet0/0
 ip address 10.90.30.75 255.255.255.0
 
!! turns dhcpdiscover broadcast packets (which don't forward off the LAN) into unicast addresses which route.
 ip helper-address <address of your dhcp server>    <<<<<<<<<<========================
  !
!
router eigrp 100
 network 10.0.0.0
!!auto summary makes the advertisements 'classful', so each router was thinking that the
!! whole 10.x.x.x network (class A, /8) was local to that router. No auto-summary will allow automatic subnetted advertisements.
no auto-summary  <<<<<<<<<<========================

Router B:
interface FastEthernet0/0
 ip address 10.90.29.75 255.255.255.0
 
 ip helper-address <address of your dhcp server>     <<<<<<<<<<========================
 
!
router eigrp 100
 network 10.0.0.0
 no auto-summary  <<<<<<<<<<========================
0
 
LVL 7

Expert Comment

by:pedrow
Comment Utility
eigrp won't automatically advertise a default route. Use a static default route on the router that's connected to the internet access and redistribute the static route into eigrp:

ip route 0.0.0.0 0.0.0.0 123.45.67.89

router eigrp 100
 network 10.0.0.0
 no auto-summary
 redistribute static


Hope this helps.
0
 

Author Comment

by:raspis21
Comment Utility
Thanks for your comments Mike and Pedrow, but I have tried both of your solutions and neither work. I am still able to ping out to the internet from the locally connected router, but I cannot from the remote router. From the remote router I can still ping as far as the fast ethernet interface on the local router, but I cannot ping past it at all. I have tried romoving all the static routes from the remote router, and I have tried what Pedrow suggested as well. Any other suggestions? I am increasing the points value of this question since it doesnt seem to be something quick and easy.
0
 
LVL 28

Accepted Solution

by:
mikebernhardt earned 500 total points
Comment Utility
Well, we were both wrong, and both right. "No auto-summary" is only needed if you have discontiguous networks. For example, if you had the 10 network at each site, but 192.168 on the serial link. Since you are using 10 everywhere it's not necessary.

On Friday I found a note at Cisco that said the static route wasn't needed on Router A. Now I found others that said it is. But pedrow left out a line:
ip route 0.0.0.0 0.0.0.0 10.90.30.1
!
router eigrp 100
 redistribute static
 default-metric 10000 1 255 1 1500

You MUST configure a default metric when you redistribute a static route into EIGRP, or it won't propagate. In EIGRP, the metric consists of 5 parameters, the above are the usual defaults. So try that on router A, again making sure that you remove the static default route from router B. Once that's done, if you type show IP route on router B you should see a default route at the end of your routing table, advertised from EIGRP. I assume that you see some routes in EIGRP now...

If you see the default route but still can't ping out, here's my question. You're pointing your default route on Router A to 10.90.30.1. Is that another router of yours or your ISP? If it's yours, please provide the configuration on that one as well so we can see if the problem is there. Is it running EIGRP also?

If adding the default metric doesn't work, please provide the actual configurations of both routers (since there was a typo in one of them originally, maybe there are more?). You might also provide output from both routers of show ip route.
0
 
LVL 7

Expert Comment

by:pedrow
Comment Utility
Just for kicks, please post output from sh ip route from both routers, both w/ and w/out 'no auto-summary'  :)

For clarification: Using auto-summary will cause the router to advertise classful networks. So, each router, if both using the 10.x.x.x/8 range, will both advertise that classA network. i.e. 10.x.x.x addresses on other routers won't be seen, since the same /8 is being sourced locally(much like RIP v1). no auto-summary will allow CIDR advertisements. Believe me...no auto-summary will be required. On both routers.

http://www.cisco.com/en/US/products/sw/iosswrel/ps1828/products_command_reference_chapter09186a00800ca5a9.html#wp1017389

And redist static doesn't require a default metric to work w/eigrp. If you're gonna redistribute other dynamic routing protocols into eigrp, yes, but not redist static (or redist connected for that matter).

0
Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

 
LVL 28

Expert Comment

by:mikebernhardt
Comment Utility
Pedrow, from the URL you supplied: To disable this function and transmit subprefix routing information ***across classful network boundaries,*** use the no form of this command.  (My asterisks). EIGRP summarizes at network boundaries unless you use "no auto-summary." But the network he's shown is all 10.0.0.0/8 so there is no boundary. With or without it won't affect him.

raspis21, the reason I'd like to see the config of the router at 10.90.30.1 is because maybe IT doesn't know how to get back to the remote side. The remote router itself may be working as it should.
0
 
LVL 7

Expert Comment

by:pedrow
Comment Utility
mike...i'll have to chew on that one for a bit :) I'd still say no auto-summary will keep you out of trouble :)

Besides the routing tables from both routers, does 'show ip eigrp neighbors' show that the two routers are talking?
0
 
LVL 28

Expert Comment

by:mikebernhardt
Comment Utility
Good idea. I was wondering about that too, but he said that he could ping the fast ethernet on each side so I didn't worry about it. But that could have just been working because of the static routes...

So raspis21, if adding the default metric and redistribute static didn't help, please supply:
current RUNNING configs from all 3 routers
show ip eigrp neighbor from all 3 routers (if EIGRP is running on all three)
show ip route from all 3 routers

We WILL get to the bottom of this, with your assistance.
0
 
LVL 5

Expert Comment

by:epylko
Comment Utility
With EIGRP you could always use the "default-information originate" command.

IGRP used to require that you have "ip default-network w.x.y.z" set for a default route to work. I don't think EIGRP requires that.

-Eric
0
 

Author Comment

by:raspis21
Comment Utility
Sorry I took so long to get back to this, but I have been ultra busy. Mike and Pedrow, thanks a lot, I got it working just fine, I accepted the answer but I messed up on the assist. I will see if I can get it changed to give the assist to pedrow.


Thanks all!
0
 
LVL 28

Expert Comment

by:mikebernhardt
Comment Utility
What fixed it?
0
 
LVL 17

Expert Comment

by:mikecr
Comment Utility
You guys went through all of the motions with EIGRP, but I think you overlooked one thing, there was no NAT set up for the remote router from what I could tell so they would have never been able to ping out onto the itnernet. He would have also needed a defaul route on his internet router per Pedrow's suggestion.
0
 
LVL 28

Expert Comment

by:mikebernhardt
Comment Utility
He never said that was an issue. There is a 3rd router in the mix and we never saw its configuration...
0
 
LVL 17

Expert Comment

by:mikecr
Comment Utility
I didn't see in the conversation where there was a third router but I may have overlooked it. Sometimes these things can go on for days like an IRS audit.
0

Featured Post

Do You Know the 4 Main Threat Actor Types?

Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

Join & Write a Comment

While it is possible to put two routes in place with the secondary having a higher metric, this may not always work. In the event of a failure that does not bring down the physical interface on the router the primary route is not removed. There is a…
Tired of waiting for your show or movie to load?  Are buffering issues a constant problem with your internet connection?  Check this article out to see if these simple adjustments are the solution for you.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

728 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

9 Experts available now in Live!

Get 1:1 Help Now