Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1321
  • Last Modified:

401.2 error with IIS using Integrated Security

Hey,

I'm trying to get to the bottom of a problem that is driving me crazy. I recently deployed an app for my company that uses IIS 6 and Tomcat. Everything seemed to be going fine until 2 users reported an error they got when they typed the url into a browser window. Everywhere i look for a solution it tells me i need to switch from Anonymous Authentication to something else, but since the start I've been using Integrated Security and these users have sufficient entitlements to access the site, but still they can't. Is there some other setting in IIS that i need to check? Or is it something specific with the browser version these two are using - quite a few people have logged on at this stage without encountering this problem

Hope you can HELP.

0
peterwnorman
Asked:
peterwnorman
1 Solution
 
meverestCommented:
check that the problem users are logged on to the domain and not to their local computer.

cheers.
0
 
peterwnormanAuthor Commented:
the problem users are outside the domain, as is most everyone. everyone else is challenged by the server to enter their domain username and password. these 2 aren't. the server simply throws a 401.2 error
0
 
peterwnormanAuthor Commented:
i just found an article on microsoft.com that says the error can occur if you use NTLM on the server (which i am) and try and access the server through another proxy server. but surely there is some other method of allowing a user to access a site that is outside their current domain when they are accessing it through a proxy server...
0
Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

 
rama_krishna580Commented:
see here..

 Netscape doesn't support Integrated Windows authentication. If you want
 Netscape users to be able to log in to the site, you'll need to select
 Basic authentication. You can select both Integrated and Basic if you'd
 like -- IE clients will use Integrated, and everyone else will use
Basic.
 
 Please note that passwords go over the wire in almost-cleartext with
Basic
 authentication. To prevent password sniffing, you'll want to install and
 use an SSL certificate on your site.

And finally check here www.iisfaq.com for answers....

best of luck..

R.K
0
 
peterwnormanAuthor Commented:
these users are using IE...
0
 
shahrialCommented:
Error Message
HTTP Error 401 - 401.2 Unauthorized: Logon Failed Due To Server Configuration

Cause
The User Authentication settings are incorrect under the Security Tab in Internet Options

Solution
Make sure "Automatic logon only in Intranet Zone" is selected under "User Authentication"

How to select "Automatic logon only in Intranet Zone" is selected
1.) From the Start menu, click Settings, and choose Control Panel.
2.) Double-click the Internet Options icon.
3.) Click on the Security tab.
4.) Click the Custom Level button.
5.) Scroll down until Automatic logon only in Intranet zone is visible.
6.) Select Automatic logon only in Intranet zone.
7.) Click the OK button.
8.) Click the OK button.
9.) Click the OK button.
10.) Close all windows.

Hope this helps...



0
 
sandipkhardeCommented:
Hi Team...I had same issue

i switched NTLM to Keberos authentication .now it working fine....

http://support.microsoft.com/kb/832769
0

Featured Post

Receive 1:1 tech help

Solve your biggest tech problems alongside global tech experts with 1:1 help.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now