Solved

HP Laserjet IIIP will print test print but won't print from PC

Posted on 2004-04-23
7
2,017 Views
Last Modified: 2013-12-15
HP LJ IIIP was turning itself off after a couple of minutes. I suspected and replaced the power supply. Printer now stays on. When powered on, it completes a self test sucessfully and displays no error messages. I can print a test print using the buttons on the front panel. The print looks fine. It says it is 'ready' and is 'online'. I cannot get it to print from my PC. I changed the cable and tried printing from another PC but still no print. Doing a 'print test page' from within the printer settings page in Windows doesn't work and it doesn't work with a wordpad file. I queues up but then errors. I was told that there is a 'reset' button under the back cover on the left. I pressed it and the printer does an 'engine test' and prints a page with a lot of vertical lines on it. Still won't print from the PC.
0
Comment
Question by:newberntech
  • 4
  • 2
7 Comments
 
LVL 20

Assisted Solution

by:trailblazzyr55
trailblazzyr55 earned 25 total points
Comment Utility
No problem,

Got a couple questions though..
How do you have your printer connection to your computer? Is it a network printer or connected directly to your PC?
How is it connected? USB or Parallel or LAN?
Did your Printer come with a drivers Disk?
And what operating system are you running?

Lemme know and we'll get ya up in no time!
Regards,
~trail
0
 
LVL 21

Expert Comment

by:briancassin
Comment Utility
Sounds like the driver may be possibly corrupt ....

do this

I am assuming you are using windows but you never mentioned which version these instructions will cover win98,98se,xp,2000....
Reinstall the driver but prior to reinstalling it go to start run type msconfig and hit enter then go to the startup tab and on a piece of paper write down everything that is either checked or unchecked whichever is easier then uncheck everything. or select disable all (if available) then hit apply then ok then reboot. Once you are back in windows it will say you are in a diagnostic mode of windows ignore this message and continue on next uninstall the driver... reboot then install the correct driver then try to print again if you are still having problems please post the error messages you are getting and also if you could please tell us how the printer is connected as mentioned above by trailblazzyr55.

Also please let us know what your O.S. is

0
 

Author Comment

by:newberntech
Comment Utility
The printer is connected via parallel cable. I am running windows xp-pro. I tried the printer on another pc that was running w98se also via parallel cable. That would seem to rule out the driver. The driver is the one supplied with the version of windows that I am running so changing pc's also would have changed the driver. As mentioned, I tried another cable.

As far as using msconfig, I went to a command prompt and did a dir>lpt1. No error reported and no print so I don't think it is a windows thing. Besides, I tried another PC.
0
Find Ransomware Secrets With All-Source Analysis

Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

 
LVL 21

Accepted Solution

by:
briancassin earned 100 total points
Comment Utility
Does the cable you are using say IEEE1284 compliant on it and is it 10ft or less in length ?  If not then you need to replace the cable with one that says IEEE1284 compliant on it and that is no longer then 10ft.

This cable being incorrect would affect it on two different machines. Your printer requires an IEEE1284 compliant cable without it the printer will not work properly.

If you did the dir >lpt1 in dos and got nothing no error message or anything then it is a cable problem, port problem or you have had other printer software in the past loaded on the computers that you are testing this printer on and the drivers for those other printers are interfering.

Since it can do a self test print from the machine itself it is not the formatter board. However we have not ruled out yet that the port on the printer is bad or that the main board in the printer has gone bad....
0
 

Author Comment

by:newberntech
Comment Utility
Thanks for the quick response.
Correct me if I'm wrong, but isn't the IEEE1284 a bidirectional cable. This printer has been around since before IEEE1284 was in place I believe. Anyway, the cable that I have been using (for years) isn't IEEE1284 so I don't think it is required for this printer since it is not bidirectional. I even tried a third cable but no print. I tried using the serial port but I'm not sure that that cable is good so it is really inconclusive. The job queued and then went away as if it printed (no error like when I print with the parallel) but no print. I also deleted the printer and readded it using a new driver. I also deleted the LPT1 and readded it. ALthough there is another printer attached to the machine, it is a usb printer and both have coexisted since last August so I con't see a conflict there. The second PC has only has the HP LJ IIIp printer driver installed and never any other (it is a laptop).

As I originally said, I replaced the power supply so the machine has been disassembled. The port board is firmly seated and screwed down as is everything else. I'm thinking that the port board is gone but don't know enough about it to test it or if it can be tested while in the printer.
0
 

Author Comment

by:newberntech
Comment Utility
I guess I didn't say this but I've had the printer for years and it has worked fine until it started shutting itself off. I could print from both PCs using it. Then I changed the power supply and now it won't print. I really haven't changed anything on the PC side (that I know of).

Again, thanks.
0
 

Author Comment

by:newberntech
Comment Utility
SOLVED IT!!!!!!!

In reading another forum, it was suggested that the user do a 'Cold Reset' to solve the problem that they had. I gave it a try and the printer works fine now. The cold reset is performed by holding the 'online' panel button down when turning on the printer. Worked.

Thanks to all for the attempts to help.
I will split the points for your assistance even though I fixed it myself.
0

Featured Post

Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

How to solve seemingly unsolvable printer issues. Users sometimes run into printing issues where all the normal steps do not seem to work. Well the steps below can show users how to take one extra step beyond the normal steps needed to remove old…
This seems to be a very common error related to the Samsung printer driver. First, this is the error we're talking about: Log: System Type: Error Event: 7000 Agent Time: 3:37:24 am 22-Apr-09 Event Time: 6:07:24 pm 21-Apr-09 UTC Source: Se…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
You have products, that come in variants and want to set different prices for them? Watch this micro tutorial that describes how to configure prices for Magento super attributes. Assigning simple products to configurable: We assigned simple products…

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now