Solved

System process uses 100% of the CPU

Posted on 2004-04-23
14
756 Views
Last Modified: 2010-04-13
I have a Windows 2000 Pro with SP4.

I installed Roxio EZ CD 5.  Then I rebooted and my system starting running very slow.  I was able to launch task manager and saw that the system process was taking all the processor.  I've tried booting up in Safe Mode and it does the same thing.  How can I recover from this?
0
Comment
Question by:koujaianh
  • 4
  • 3
  • 2
  • +4
14 Comments
 
LVL 2

Expert Comment

by:jonpaulr
ID: 10905382
I'll ask the obvious just for grins. Have you uninstalled Roxio?
0
 
LVL 20

Expert Comment

by:trailblazzyr55
ID: 10905592
Roxio shouldn't be running when your computer starts by default, have you ran an up-to-date virus scan on your system, also maybe want to check for fragmentation?

Those are just some possibilities, also..

What is your memory on your computer, processor, and hard drive size?

Lemme know?
Regards,
~trail
0
 
LVL 7

Expert Comment

by:wtrmk74
ID: 10905720
is this the only thing that changed your system stability ?

download HijackThis and post the log on your next visit.
http://www.spychecker.com/program/hijackthis.html

We will review your system and let you know if something else is going on.

wtrmk74
0
 
LVL 49

Expert Comment

by:sunray_2003
ID: 10906090
Use these tools as well


Use spybot ,ad-ware ,CWshredder and post the log from Hijackthis here

After installing them, First Update them and then run

Spyware/Adware removal tools:
------------------------------

What is spyware : http://www.spychecker.com/spyware.html

SpyBot-S&D : http://www.safer-networking.org/

Ad-aware : http://www.webattack.com/download/dladaware.shtml

CWShredder: http://www.softpedia.com/public/cat/10/17/10-17-150.shtml

HijackThis : http://www.spychecker.com/program/hijackthis.html

SpywareBlaster  :http://www.javacoolsoftware.com/spywareblaster.html

SpywareGuard :http://www.javacoolsoftware.com/spywareguard.html

SpySites  :http://www.spychecker.com/program/spysites.html

Keylogger Hunter :http://www.styopkin.com/keylogger_hunter.html

BHODemon : http://www.spywareinfo.com/downloads/bhod/

Browser Hijack Blaster : http://www.wilderssecurity.net/bhblaster.html

Other spyware removal instructions:

http://www.spywareinfo.com/~merijn/cwschronicles.html
http://www.pchell.com/support/click2findnow.shtml

0
 
LVL 6

Expert Comment

by:jthow
ID: 10906622
koujaianh,

jonpaulr suggested "just for grins" get rid of Roxio EasyCD: I'd take him seriously.  

I've seen various versions of Roxio software bring W2K (& XP) machines to a grinding halt.  (That is, if it doesn't cause them to fail completely...)  Uninstall EasyCD.  You may also have to trawl through the registry and delete any references it's left behind - the uninstall routine has a tendency not to do a particularly good job of cleaning up.  Hopefully, that'll restore your performance.  [If it doesn't, you may need a total re-install.  We've also had to do that on at least one system. :-( ]  

Once you've got the system behaving stably again, get some other CD burning s/w.  Nero seems to cause far less problems.  

Usual disclaimers.

JohnT

0
 
LVL 2

Expert Comment

by:jonpaulr
ID: 10906634
JohnT and I are in agreement. I've had Roxio troubles in the past. I currently use Nero 6 Ultra. As for the remaining registry entries, use a cleaner such as System Mechanic or any other program that removes orphaned registry entries after programs have been removed.
0
 

Author Comment

by:koujaianh
ID: 10910735
Thanks for all the suggestions.

Here are some answers to your questions:

I can't uninstall Roxio.  As soon as I boot up my PC gets really slow.  When the logon window comes up, I hit CTL-ALT-DEL keys to log on and it takes about 30 seconds for the logon window to enter my password to even show up.  Then when I do enter my password and hit the enter key, it takes about 15 to 20 minutes to show my desktop.  So right from the get to, the system process takes all the processor and doesn't release it.  After about an hour or so, I can finally get my control panel to open then another 30 minutes for it to display the Add/Remove programs.  But the Add/Remove programs window never populates for me to uninstall Roxio.  I may have to wait a few days for it to populate.

My PC has one 2.2 Ghz processor, 1 GB RAM, and a 20GB hard drive.  It's a dual boot with two Windows 2000 Pro SP4.  I can boot up into my other OS and it works fine so I can at lease copy all my files off the hard drive if I need to reinstall.

I can't even launch IE cause the processor is taken so I can't go to any of the site you have mentioned to download these tools.

I have ran the updated virus scan from my other OS on the entire hard drive and it didn't find anything.

I had Roxio EZ CD 5 alread installed.  But I was having problems coping a CD so I uninstalled it then reinstalled it.  That's when I started having this problem.

I am really hoping not to reinstall W2K cause I have a lot of software loaded on it.
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 
LVL 2

Expert Comment

by:jonpaulr
ID: 10910744
If you can access the Roxio program folders from your good dual boot, then try renaming them and/or place them somewhere else. If it's Roxio's app that's in question, this will prevent it from even able to be even loading and you will be able to take it from there (meaning able to actually "work" with your system).
0
 

Author Comment

by:koujaianh
ID: 10910773
I have renamed the folder that Roxio got installed in from my other OS then tried booting up in my problem OS and still the same problem.

Can I delete the Adaptec entries in the problem OS from my working OS?  If yes, how?
0
 

Author Comment

by:koujaianh
ID: 10910777
I meant:  Can I delete the Adaptec entries in the problem OS's registry from my working OS?  If yes, how?
0
 
LVL 6

Expert Comment

by:jthow
ID: 10911251
See:-

http://www.jsiinc.com/SUBA/tip0100/rh0182.htm

for instructions on how to modify a registry from another installation.

JohnT
0
 
LVL 82

Accepted Solution

by:
oBdA earned 500 total points
ID: 10913142
This might not even be directly Roxio related. Did you install the April hotfixes from Microsoft, especially 835732? On W2k in certain configurations, it causes high CPU usage of the system process, on Server 2k3, it seems to disable IE's encryption, and it seems to mess up some NT4 installations as well.
When looking around in the newsgroups, on some W2k installations that had problems with the system process after the hotfix, a solution was to uninstall the hotfix, update the drivers (the culprit was the audio driver, in this case) and reinstall the hotfix. In your case, the problem might be a combination: Your system might have come up OK after the hotfix, then you installed Roxio, which might have added some drivers that the hotfix didn't like.

Here's a description about how to best remove the hotfix if installed; this might help uninstalling Roxio as well:
http://groups.google.com/groups?hl=en&lr=&ie=UTF-8&oe=UTF-8&selm=%23IOM%23EzIEHA.3476%40TK2MSFTNGP11.phx.gbl
or another possibility:
http://groups.google.com/groups?hl=en&lr=&ie=UTF-8&oe=UTF-8&selm=1d1d201c42315%2448f9c3b0%24a501280a%40phx.gbl&rnum=2

If it doesn't work, google groups for "835732" and "CPU usage" or "835732" and "realtime".
Here are the important parts of the articles above, just in case:

====8<----[MICROSOFT IS LOOKING at the KB 835732 issue now]----
To unistall it, I did the following
(1) Boot into Safe mode.
(2) Run TaskManager - and noticed that the SYSTEM process
was using 99% of the CPU time.
(3) From TaskManager set the Priority of the EXPLORER
process to REALTIME, so that I can get to the control
panel.
(4) Run ADD/REMOVE PROGRAM from control panel.
(5) Go back to TaskManager and set the Priority of
MSHTA.exe to REALTIME, so that the ADD/REMOVE PROGRAM can
get some CPU time.
(6) Select and Remove "Windows 2000 Hotfix  - KB835732".
(7) Go back to TaskManager and set the Priority
of "SPUNIST.exe" to REALTIME, for the uninstall program to
run.
(8) Wait a few minutes, and the uninstall program will
eventually ask you to click FINISH to reboot the machine.
It took a long time for the system to shutdown and I just
unplugged the power.
(9) The machine should become normal after reboot.
====8<----[MICROSOFT IS LOOKING at the KB 835732 issue now]----

====8<----[HELP...ME TOO! my machine is doing the exact same thing...]----
I found this solution below,  and it worked great.
Boot into SAFE MODE (no networking or no command prompt).
Go to: Control Panel --> Add / Remove Programs
UNINSTALL Windows Hotfix KB 835732
Reboot...

There's some additional tricks to this that you can use:

1) Instead of using add\remove programs,  run CMD and type
in:
%systemroot%\$Ntuninstallkb835732$\spuninst\spuninst.exe

or
2) if you can get to the desktop,  go to task manager.  
Give the explorer process Realtime priority.  Then go to
the command prompt and follow step #1.  Once you start up
the spuninst.exe program,  go into task manager and give
it Realtime priority as well.
====8<----[HELP...ME TOO! my machine is doing the exact same thing...]----
0
 
LVL 7

Expert Comment

by:wtrmk74
ID: 10913385
boot to CMD prompt

type cd ../
type it again until you get to C:/

now type
msconfig /s

choose.....
Selective Startup now disable "ALL" the programs that are not recognized as services
http://www.blackviper.com/WIN2K/servicecfg.htm
and put a check in the box
SAFEBOOT

Apply and reboot........
if you do not yet have MSCONFIG download it here and copy and paste it into WINNT\System32 directory through the CMD prompt
http://www2.whidbey.com/djdenham/Msconfig.htm

Let us know how it goes
it should boot and you should now be able to delete the items and repair your system

wtrmk74
0
 

Author Comment

by:koujaianh
ID: 10915584
Thank you all for all your suggestions and help.

I used the method that oBdA stated and that solved my problem.  Thank you very much oBdA.
0

Featured Post

Enabling OSINT in Activity Based Intelligence

Activity based intelligence (ABI) requires access to all available sources of data. Recorded Future allows analysts to observe structured data on the open, deep, and dark web.

Join & Write a Comment

Suggested Solutions

NTFS file system has been developed by Microsoft that is widely used by Windows NT operating system and its advanced versions. It is the mostly used over FAT file system as it provides superior features like reliability, security, storage, efficienc…
A safe way to clean winsxs folder from your windows server 2008 R2 editions
In this seventh video of the Xpdf series, we discuss and demonstrate the PDFfonts utility, which lists all the fonts used in a PDF file. It does this via a command line interface, making it suitable for use in programs, scripts, batch files — any pl…
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now