?
Solved

When i restart then cannot connect already. Why?

Posted on 2004-04-23
2
Medium Priority
?
207 Views
Last Modified: 2010-03-18
After i add the default gateway to mail.fschan.com then
"[root@fish root]# route add default gw mail.fschan.com" enter command "[root@fish root]# route -n" the output is below:
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
202.157.213.128 0.0.0.0         255.255.255.248 U     0      0        0 eth0
192.168.2.0     0.0.0.0         255.255.255.0   U     0      0        0 eth1
169.254.0.0     0.0.0.0         255.255.0.0     U     0      0        0 eth1
127.0.0.0       0.0.0.0         255.0.0.0       U     0      0        0 lo
0.0.0.0         202.157.213.131 0.0.0.0         UG    0      0        0 eth0
 After that, i can connect to the internet. But when i restart again then cannot connect to internet. I have to repeat again to type the command "route add default gw mail.fschan.com" then after that can connect throught internet. Why? Have any way to solve this problem?
Thank you.
0
Comment
Question by:joanpe
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
2 Comments
 
LVL 40

Accepted Solution

by:
jlevie earned 210 total points
ID: 10906112
Is your system getting its IP via DHCP or is it statically assigned?

In the case of a static configuration the network parameters may not include a definition of the default route. On a RedHat system or similar this is set by "GATEWAY=202.157.213.131" in /etc/sysconfig/network.

A system that gets its IP via DHCP should get the default gateway setting from the DHCP server.
0
 
LVL 17

Expert Comment

by:owensleftfoot
ID: 10909531
"route add default gw mail.fschan.com"

I have to say that unless you have an entry for mail.fschan.com in your /etc/hosts file I cant understand how this command works :) In order for linux to resolve a host name it needs to be able to access dns servers. You would normally have to be connected to the internet to access dns servers. Unless you have a local dns server?
0

Featured Post

Simple, centralized multimedia control

Watch and learn to see how ATEN provided an easy and effective way for three jointly-owned pubs to control the 60 televisions located across their three venues utilizing the ATEN Control System, Modular Matrix Switch and HDBaseT extenders.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
How to fix incompatible JVM issue while installing Eclipse While installing Eclipse in windows, got one error like above and unable to proceed with the installation. This video describes how to successfully install Eclipse. How to solve incompa…

718 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question