How do I kill off Photo Editor's "Importing... (ProgCtrl)" message when I'm populating an image?

I'm using an Access XP database to store picture file locations, along with a variety of data associated with the picture files.
I use a simple form to browse through my pictures and edit the associated data.
Displaying the pictures on the form is a simple matter:

Private Sub Form_Current()
On Error Resume Next
Me![ImageFrame].Picture = Me![ImagePath]
End Sub

Private Sub ImagePath_AfterUpdate()
On Error Resume Next
Me![ImageFrame].Picture = Me![ImagePath]
End Sub

When I step through the records, Microsoft Photo Editor throws up what appears to be a Progress Bar (ProgCtrl) showing that the image is being imported, ie. "Importing C:\Docs........Pictxxx.jpg", with a "Cancel" button also showing. This is somewhat annoying.

Here's whats really annoying: When I step through the records quickly, the Progress Bar will, in short order, freeze and remain on the screen. This does not affect record navigation, but it does force me to close and restart Access to get rid of the message.

Is there a way to disable/hide this?
melbotAsked:
Who is Participating?
 
PashaModCommented:
Closed, 250 points refunded.
PashaMod
Community Support Moderator
0
 
nico5038Commented:
Did you try:

On Error Resume Next
docmd.setwarnings false
Me![ImageFrame].Picture = Me![ImagePath]
docmd.setwarnings true

Nic;o)
0
 
melbotAuthor Commented:
Tried setwarnings false/true, unfortunately it's not a warning that is coming up so that doesn't kill it. Have also tried a registry change involving setting ShowProgressDialog key to "No" in HKLM\Software\Microsoft\Shared Tools\Graphics Filters\Import\JPEG\Options with no success.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
nico5038Commented:
Hmm, did you try to change the application connected to the .jpg extension to point e.g. to IE instead of the Photoeditor ?
(Open Tools/FolderOptions to change the linked default application)

Nic;o)
0
 
PhillipBurtonCommented:
Worst case, how about uninstalling Microsoft Photo Editor from Office?

Do you actually use MS Photo Editor?

(Having said that, it is good at identifying the date that pictures were taken in Explorer.)
0
 
rockiroadsCommented:
you may wanna check this out

http://www.mvps.org/access/api/api0038.htm
0
 
melbotAuthor Commented:
Rockiroads: Thanks, that's where I picked up the tip on changing the ShowProgressDialog in the registry. As I mentioned earlier, I had no success. The subroutine route didn't help either: it appears to only suppress the dialog coming from Access, it doesn't kill off the message originating from Photo Editor.
0
 
melbotAuthor Commented:
PhillipBurton: I'm SHOCKED and OUTRAGED that you would suggest uninstalling such a valuable and integral component as Photo Editor! It came with Office XP, so it MUST be good! It ranks right up there with Notepad: it functions (sort of), and it's "free". (As to actually using it: Not really, just for cropping pictures!).
0
 
nico5038Commented:
Did you try to change the application connected to the .jpg extension to point e.g. to IE instead of the Photoeditor ?

Nic;o)
0
 
melbotAuthor Commented:
nico5038 (and PhillipBurton): I've tried using the old Kodak Imaging application. It doesn't throw up unwanted dialog at me, but it has the following disadvantages: it doesn't expose a Zoom option to allow for an automatic resize to the Image object, and it throws vert./horiz. sliders at me for pictures larger than the Image object.
0
 
melbotAuthor Commented:
Let me correct my last comment: Kodak Imaging DOES expose a Zoom setting, ie. I can throw a number at it...
This suggests that I can strip off the incoming picture's size and calculate a zoom number to throw back to Kodak Imaging.
0
 
melbotAuthor Commented:
Solved it! Instead of changing the HKLM entry as I had tried earlier, I changed the HKCU entry.  Registry change sets ShowProgressDialog key to "No" in HKCU\Software\Microsoft\Shared Tools\Graphics Filters\Import\JPEG\Options. Just for overkill, you can also set the ...\Export\... ShowProgressDialog to "No".
No more message box, no more frozen Progress Bar!
0
 
nico5038Commented:
OK with me

Nic;o)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.