Solved

Wireless connection says it gets no IP on startup, but it does work after Linux finishes loading

Posted on 2004-04-24
2
190 Views
Last Modified: 2010-03-18
Not really any urgent or important question - I'm just curious as to why. When the system is starting, it gets to the point where it says it is configuring the firewall, and it says that "wlan0" has no IP address yet. Yet some 10 or so lines later, it mentions something about "spoofing" (or maybe "spoof proctection" or something like that...) and gives the right IP address for the connection. Yes, it is turned on even before I start the computer.

I really wouldn't care much about this if it weren't for the fact that it was doing the same thing with my Ethernet connection. My laptop has built-in Ethernet and wireless connections, and in order to get the wireless to work I ended up disabling the Ethernet because it was being assigned the same address and this seemed to confuse the system. Anyway, when I was still using both, the ethernet connection would be reported as having no IP address at startup, but the wireless *did*. Yet, the ethernet connection worked, and the wireless didn't.

Again, this really isn't important, but I am curious...
0
Comment
Question by:beaker67
2 Comments
 
LVL 14

Accepted Solution

by:
pablouruguay earned 500 total points
ID: 10918258
i think you have 2 problems in here.

1 DHCP server, is impossible to assign the some ip to the different MAC address., or you have wrong the MAC address ?:)

The second the firewall start before your eths .

i think was only ideas....
0
 
LVL 2

Author Comment

by:beaker67
ID: 10925860
More clarification...

I originally had both ethernet (eth0) and wireless (wlan0) connections enabled. The ethernet connection would allow me to connect to the internet, but the wireless connection wouldn't. But, at startup (while starting the firewall) the ethernet was listed as not yet having an IP address, while the wireless did have one. In order to get wireless to work, I ended up having to disable the ethernet (apparently they were on the same subnet, or something, and this confused linux) - see all the details of that here - http://www.experts-exchange.com/Networking/Linux_Networking/Q_20957801.html

Although you may be right - the firewall may simply be on before the connection has time to start - although it is turned on even before I turn the computer on.
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
This Micro Tutorial demonstrates using Microsoft Excel pivot tables, how to reverse engineer competitors' marketing strategies through backlinks.
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…

911 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

22 Experts available now in Live!

Get 1:1 Help Now