• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 480
  • Last Modified:

Selectively be a member of a Domain or Workgroup

I just recently received a laptop from my office as a bonus, I've set it up to connect to the domain at the office, so I could do my work on it. I then brought it home, so I could move some files around, however when I logged on to it as not a member of the domain, it took a long time to start and I noticed services giving errors in the event log that it couldn't find my domain controller. Also, I couldn't access my houses workgroup computers.

How would I selectively choose to be on a domain/workgroup on the fly without having to reboot the computer, or having it set in a hardware profile so that I could decide at boot, as opposed to having to start my cpu up, change to workgroup, reboot. Then go to work, and do the reverse.

Also, as an added bonus...where on EE would I ask questions about Laptops (Like general stuff, such as what software to use to monitor battery life, stuff to use to synchronize outlook, etc)
0
Krule
Asked:
Krule
  • 8
  • 7
  • 6
  • +1
2 Solutions
 
sirbountyCommented:
You'll need to setup a hardware profile...one for 'connected' one for 'home'...
http://support.microsoft.com/?kbid=308577
0
 
sirbountyCommented:
http://www.experts-exchange.com/Hardware/Laptops_Notebooks/ is where' laptop hardware questions would go...
0
 
Gareth GudgerCommented:
Just log on to the local compuer instead of the domain......

So when you machine starts up and you are at the domain login hit the drop down and select your computer instead. Then log in with your workgroup account I assume you already have created.
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
JammyPakCommented:
Unfortunately, Hardware profiles don't handle things like domain memberships...but diggisaur's option will work.

I have another idea: when you're at home, still login to the domain account. Even though you aren't at work, you'll still get in using 'cached credentials'. This way you'll still have the same My Documents and Desktop (ie. same profile) when you're at work or at home. You also don't need to remember another name and password, and you don't need to remember to switch your login to choose the laptop instead of the domain. To connect to things at home, you can create a user account with the same name and password as the one you use at work (if you have a 'server' at home).
0
 
sirbountyCommented:
>>Hardware profiles don't handle things like domain memberships<<
No, but if he sets up a "Home"-network disabled profile and a "Work"-network ENabled profile, he can choose the Home profile when at home and will get logged in with cached credentials much faster...
0
 
KruleAuthor Commented:
See, logging in to 'Local Computer' is what I started off doing, and it took _FOREVER_ to start my computer, as some services said they couldn't find the domain controller...also I wasn't a member of my workgroup...

More ideas?
0
 
Gareth GudgerCommented:
Thats weird....logging into your local computer doesnt even authenticate against the domain.
0
 
sirbountyCommented:
Have you tried the hardware profile solution?
0
 
KruleAuthor Commented:
Well I dont quite understand it.
0
 
sirbountyCommented:
1) Log on as an Administrator
2) Right-click My Computer/Properties
3) Hardware/Hardware Profiles
4) Copy the existing one (you can rename them as you see fit)
5) Select each profile and click Properties, choose this is a portable computer and the appropriate docking state as well as the "always include" option.  Click OK
6) Now reboot and select this profile.
7) Start->Run->Devmgmt.msc
8) Navigate to your Network Adapter section
9) Open it and double-click your installed adapter
10) At the bottom for device usage - select disabled in this profile....

Post back if you need more assistance or have questions.
0
 
KruleAuthor Commented:
Uhhh..ok that much i know...

But then i'd have the issue of..not having ANY network when i am using that profile, that'd be just as bad..if not worse than what i do atm
0
 
KruleAuthor Commented:
Hmm..I'm sure many people face this same issue?!
0
 
Gareth GudgerCommented:
If you log into the local computer is should not try and authenticate against the domain every time you access a home resource. As long as you log into the local computer on the domain screen it will be fine. Been here and done this many times.
0
 
Gareth GudgerCommented:
When at the log on screen what are you selecting in the drop down box? Also what Windows OS is this?
0
 
KruleAuthor Commented:
This is windows XP Pro, and i'm selecting 'BensLaptop (Local Computer)'

It starts but takes like 10-15 mins, and when i searched through the event viewer I got things saying 'Could not find domain controller' and whatnot...

Then i changed to my workgroup, and it was fine.
0
 
sirbountyCommented:
>>Then i changed to my workgroup,<<
So, you have your domain, "BensLaptop (Local Computer), and your workgroup all listed in the dropdown box?

You might try disabling unneeded services:
 http://www.blackviper.com/WinXP/servicecfg.htm
 http://www.techspot.com/tweaks/win2k_services/index.shtml

See if that will help.
0
 
KruleAuthor Commented:
The workgroup isn't listed...
0
 
sirbountyCommented:
So you're dropping the computer back into a workgroup under My Computer/Properties?
0
 
KruleAuthor Commented:
Thats how it's working right now, at home i do that, at work I change to the domain, and I gotta restart each time.
0
 
sirbountyCommented:
Hmm...not the way you should have to do it...
Perhaps this will help you:http://www.windowsxpatoz.com/cgi-bin/performance/index.cgi?answer=1036283899&id=1036282433
What it basically states is to alter this setting:

Start->Run->gpedit.msc
Navigate to Computer Configuration-->Administrative Templates-->System-->Logon
Setting: "Always wait for the network at computer startup and logon"

Sounds like you should set yours to "Disabled"

Hope that helps!
0
 
JammyPakCommented:
so what happens when you login to your domain account while at home? (not the local computer account)
0
 
Gareth GudgerCommented:
Can you create a different local account and try logging on with it. Maybe you local account profile you are using is messed up.
0
 
Gareth GudgerCommented:
You could also use a your domain login with cached credentials and connect to the network shares using a different login name (ie your local computer account).....

So.... open up My Computer for example and then go to Tools==>Map Network Drive. Then specify the drive letter and folder (browse to it if need be).

Then right under that click the link labelled, "Connect using a different username" and specify your local account.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 8
  • 7
  • 6
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now