Solved

messages full of DHCP Requests every 30 seconds

Posted on 2004-04-24
10
1,054 Views
Last Modified: 2007-12-19
Apr 25 12:31:52 fixen dhclient: DHCPREQUEST on eth1 to 192.168.1.1 port 67
Apr 25 12:31:52 fixen dhclient: DHCPACK from 192.168.1.1
Apr 25 12:31:52 fixen dhclient: dhclient.c(1217): non-null pointer
Apr 25 12:31:52 fixen dhclient: bound to 218.214.20.102 -- renewal in 30 seconds.

Apr 25 12:32:22 fixen dhclient: DHCPREQUEST on eth1 to 192.168.1.1 port 67
Apr 25 12:32:22 fixen dhclient: DHCPACK from 192.168.1.1
Apr 25 12:32:22 fixen dhclient: dhclient.c(1217): non-null pointer
Apr 25 12:32:22 fixen dhclient: bound to 218.214.20.102 -- renewal in 27 seconds.

Apr 25 12:32:49 fixen dhclient: DHCPREQUEST on eth1 to 192.168.1.1 port 67
Apr 25 12:32:49 fixen dhclient: DHCPACK from 192.168.1.1
Apr 25 12:32:49 fixen dhclient: dhclient.c(1217): non-null pointer
Apr 25 12:32:49 fixen dhclient: bound to 218.214.20.102 -- renewal in 30 seconds.

This goes on and on for pages.... This is a modem in half bride mode thats setup, and it delivers the IP to the linux box over DHCP. The IP it delivers is static, and will never change, so i'm not sure why this is refreshing every 30 seconds...

This was brought to my attention because every 7 days or so the modem just stops working and doesnt give out an IP to my linux box... It just disconnects.. Trying to avoid this from happening.

12:45 was when my internet connection went down. It was back up at 12:55 after rebooting the modem twice.

Apr 25 12:45:57 fixen kernel: eth1: remaining active for wake-on-lan
Apr 25 12:45:57 fixen kernel: eth1: link up.
Apr 25 12:45:57 fixen kernel: eth1: Setting full-duplex based on negotiated link capability.
Apr 25 12:45:58 fixen dhclient: DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 4
Apr 25 12:45:58 fixen dhclient: receive_packet failed on eth1: Network is down
Apr 25 12:46:02 fixen dhclient: DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 10
Apr 25 12:46:12 fixen dhclient: DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 14
Apr 25 12:46:26 fixen dhclient: DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 20
Apr 25 12:46:46 fixen dhclient: DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 8
Apr 25 12:46:54 fixen dhclient: DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 5
Apr 25 12:46:59 fixen dhclient: No DHCPOFFERS received.
Apr 25 12:46:59 fixen dhclient: No working leases in persistent database - sleeping.
Apr 25 12:50:54 fixen dhclient: DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 5
Apr 25 12:50:59 fixen dhclient: DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 12
Apr 25 12:51:11 fixen dhclient: DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 13
Apr 25 12:51:24 fixen dhclient: DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 11
Apr 25 12:51:35 fixen dhclient: DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 13
Apr 25 12:51:48 fixen dhclient: DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 7
Apr 25 12:51:55 fixen dhclient: No DHCPOFFERS received.
Apr 25 12:51:55 fixen dhclient: No working leases in persistent database - sleeping.

Apr 25 12:53:54 fixen kernel: eth1: Autonegotiation advertising 0x5e1  partner 0x00.
Apr 25 12:53:54 fixen kernel: eth1: link down.
Apr 25 12:53:57 fixen kernel: eth1: Autonegotiation advertising 0x5e1  partner 0x41e1.
Apr 25 12:53:57 fixen kernel: eth1: link up.
Apr 25 12:54:01 fixen kernel: eth1: Autonegotiation advertising 0x5e1  partner 0x00.
Apr 25 12:54:01 fixen kernel: eth1: link down.
Apr 25 12:54:02 fixen kernel: eth1: Autonegotiation advertising 0x5e1  partner 0x41e1.
Apr 25 12:54:02 fixen kernel: eth1: link up.
Apr 25 12:55:21 fixen kernel: eth1: Autonegotiation advertising 0x5e1  partner 0x00.
Apr 25 12:55:21 fixen kernel: eth1: link down.
Apr 25 12:55:33 fixen kernel: eth1: Autonegotiation advertising 0x5e1  partner 0x41e1.
Apr 25 12:55:33 fixen kernel: eth1: link up.
Apr 25 12:55:37 fixen kernel: eth1: Autonegotiation advertising 0x5e1  partner 0x00.
Apr 25 12:55:37 fixen kernel: eth1: link down.
Apr 25 12:55:39 fixen kernel: eth1: Autonegotiation advertising 0x5e1  partner 0x41e1.
Apr 25 12:55:39 fixen kernel: eth1: link up.

Apr 25 12:56:24 fixen dhclient: DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 3
Apr 25 12:56:24 fixen dhclient: dhclient.c(1217): non-null pointer
Apr 25 12:56:24 fixen dhclient: DHCPOFFER from 192.168.1.1
Apr 25 12:56:24 fixen dhclient: DHCPREQUEST on eth1 to 255.255.255.255 port 67
Apr 25 12:56:24 fixen dhclient: DHCPACK from 192.168.1.1
Apr 25 12:56:24 fixen dhclient: dhclient.c(1217): non-null pointer
Apr 25 12:56:24 fixen dhclient: bound to 218.214.20.102 -- renewal in 25 seconds.

So is there a way to stop it from doing this every 30 seconds?

I'm running RedHat Fedora

On boot, from rc.local, I run: dhclient eth1

I'm not sure if this is appropriate, but I'm assuming that because ONBOOT=no, that this script doesnt do anything?

/etc/sysconfig/network-scripts/ifcfg-eth1
# National Semi|DP83815 (MacPhyter) Ethernet Controller
DEVICE=eth1
BOOTPROTO=dhcp
HWADDR=00:09:5B:20:FB:69
TYPE=Ethernet
ONBOOT=NO


Thoughts would be great,

Thanks,

Paul.
0
Comment
Question by:H4Inf
  • 5
  • 5
10 Comments
 
LVL 40

Accepted Solution

by:
jlevie earned 500 total points
ID: 10912189
It would appear that the DHCP server is advertising a lease time of 30 seconds or is broken in some way that casues Fedora to think that the lease time is 30 seconds. In either case the problem lies with the DHCP server. Given the IP it sounds like it is your Internet provider's DHCP server and there's probably not much you can do about that other thatn to call them and ask about it.

ONBOOT should be set to yes in ifconfig-eth1 if you are using that interface, and the DHCP negotiation would tend to indicate that you are.
0
 

Author Comment

by:H4Inf
ID: 10912218
This DHCP server is in my modem. The modem acts in half bridge mode.

Regarding ONBOOT. If I set onboot there, it doesnt get the IP, however doing it thru the rc.local script it does...

I will check the modem configuration, however is there a way to override it ?

Thanks,

Paul.
0
 
LVL 40

Expert Comment

by:jlevie
ID: 10912333
It should work with ONBOOT=yes in ifcfg-eth1, if the modem is operating properly and the driver module for eth1 is in modules.conf.

What are you doing in rc.local to bring up the interface?
0
 

Author Comment

by:H4Inf
ID: 10912403
On boot, from rc.local, I run: dhclient eth1

It actually works when I run that. If its set as onboot=yes, it doesnt. It just sits there and doesnt get an IP.

Paul.
0
 
LVL 40

Expert Comment

by:jlevie
ID: 10912623
When set for normal operation and negotiation fails do you see dhclient running once the system is up? What does /etc/modules.conf contain for ethernet modules?
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 

Author Comment

by:H4Inf
ID: 11047761
I cant test to see if dhclient is running in that situation, as the server needs to stay online!

/etc/modules.conf as requested:
alias eth0 natsemi
alias eth1 natsemi
alias eth2 e100
alias usb-controller usb-uhci
alias usb-controller1 ehci-hcd

eth1 is plugged into my modem. I checked my modems conf and the DHCP lease time is supposed to be 3 days.

Paul.
0
 
LVL 40

Expert Comment

by:jlevie
ID: 11051924
After looking over all of the information it seems to me that there may be more than one problem here. And it isn't obvious if the problems are with the Fedora box, the modem, or both.

From the logs:

Apr 25 12:45:57 fixen kernel: eth1: remaining active for wake-on-lan
Apr 25 12:45:57 fixen kernel: eth1: link up.
Apr 25 12:45:57 fixen kernel: eth1: Setting full-duplex based on negotiated link capability.

and:

Apr 25 12:53:54 fixen kernel: eth1: Autonegotiation advertising 0x5e1  partner 0x00.
Apr 25 12:53:54 fixen kernel: eth1: link down.
Apr 25 12:53:57 fixen kernel: eth1: Autonegotiation advertising 0x5e1  partner 0x41e1.
Apr 25 12:53:57 fixen kernel: eth1: link up.

would suggest to me that there's a link mode negotiation problem between the two. Also I have a suspicion that all of the power saving features in your BIOS might not be disabled. A link mode negotiation problem could explain why a normal network config with dhclient starting as a result of the contents of /etc/sysconfig/network-scripts/ifcfg-eth0 (ONBOOT=yes & BOOTPROTO=dhcp). If the NIC doesn't come up immediately dhclient will exit because it doesn't see an active interface. It's possible to keep dhclient from doing this, which is appropriate if the interface is just a bit slow to connect to the remote (sometimes a problem with some switches or wireless links). And BIOS power management could explain the occasional loss of connectivity if the BIOS thought the system was inactive.

It's also possible that there's simply something wrong with the eth1 NIC, the cable, or the modem port it plugs into. One thing that should be pretty easy to try would be to interpose a a good quality 10/100 hub in between eth1 & the modem, using new cables, and see if that makes any difference. I'd use something like a 4-port Netgear, or 3Com hub.

It's possible that the DHCP issue is solely a result of the apparent ethernet problem, or if may be a problem with Fedora or the modem. The only way I know of to debug a DHCP negotiation is to capture the traffic with a sniffer and compare whats seen with what the RFC says should be happening. I suspect that Fedora is defaulting to a 30 second lease because it doesn't understand something in the data offered by the DHCP server. That might be the result of a flawed implementation on the modem, it could be an internal fault in Fedora's dhclient, or it could be the result of a network problem.

Do you have all of the Fedora Core 1 updates installed (as in running up2date)?
0
 

Author Comment

by:H4Inf
ID: 11054891
I have the updates installed, and will review the bios settings next chance I get. Ill also try your hub idea. Hopefully sometime in the next week I have a chance to do so, Thanks!!

Paul.
0
 
LVL 40

Expert Comment

by:jlevie
ID: 11055233
Okay... Waiting for words.
0
 

Author Comment

by:H4Inf
ID: 11157835
There is definitely something wrong with te DHCP server in the modem. I'm currently working on putting the modem into full-bridge mode so the modem will not have to run a dhcp server at all.

Thanks for all the help!

Paul.
0

Featured Post

Enabling OSINT in Activity Based Intelligence

Activity based intelligence (ABI) requires access to all available sources of data. Recorded Future allows analysts to observe structured data on the open, deep, and dark web.

Join & Write a Comment

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
Polish reports in Access so they look terrific. Take yourself to another level. Equations, Back Color, Alternate Back Color. Write easy VBA Code. Tighten space to use less pages. Launch report from a menu, considering criteria only when it is filled…
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now