Solved

Cannot convert folder to subweb

Posted on 2004-04-25
17
205 Views
Last Modified: 2013-12-24
I have a Win2003 Server running IIS with 11 different websites using host headers.  When I attempt to configure Users and Roles (Frontpage 2002 Tools>Server>Administration or Permissions), the default roles do not appear.  I created a new role of "Admin" and selected all of the rights and granted this new role to a user.  When they try to convert a file into a subweb they cannot unless I add them to the local Administrators group of the web server.  I do not want to put the webmasters in the local admins group so what do I need to do to correct this?
0
Comment
Question by:JCRussell
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
17 Comments
 
LVL 29

Accepted Solution

by:
coreybryant earned 250 total points
ID: 10916056
There is one called AdvAuthor - check the permissions there.  If I remember correctly - that should do it.

-Corey
0
 
LVL 14

Expert Comment

by:hhammash
ID: 10916320
Hi,

It happened to me last week.

Change the permissions as Corey said.

100% is a permission thing.

hhammash
0
 
LVL 1

Author Comment

by:JCRussell
ID: 10918720
That is where ny problems begin, none of the default roles appear on any of the virtual servers. They only appear on the default web site.  How do I get them to show up on the rest of the virtual servers?
0
NEW Veeam Agent for Microsoft Windows

Backup and recover physical and cloud-based servers and workstations, as well as endpoint devices that belong to remote users. Avoid downtime and data loss quickly and easily for Windows-based physical or public cloud-based workloads!

 
LVL 29

Expert Comment

by:coreybryant
ID: 10918817
Right click on one of the domains in IIS & choose properties.  Locate the tab - Front Page extensions 2002.  Now hit the button - Settings.  Sign in.  And click on Administration (upper left hand corner).  Now you should see all your webs.  Are they all version 5. something?   Click on Set list of available rights - maek sure all of these are checked.

Now on the one you are having a problem with - click on Administration there - Configure user account limits.  Sign in using the administrator account. Under manage users - who is listed?

-Corey
0
 
LVL 1

Author Comment

by:JCRussell
ID: 10919213
They are all 5.0.2.5012.  All rights are checked as available.
When I go to Administration via IIS Manager, there is no option to  manage users, only configure user account limits (which is set to allow unlimited).  The only way I can get to manage users is through Frontpage (Tools>Server> Admistration).  The correct domain user account is listed with the role of Admin (a role I created since none of the defalt roles appeared, and has all rights checked).
0
 
LVL 29

Expert Comment

by:coreybryant
ID: 10919298
So when you go into the FP administration, do you see something like this:
 mydomain.com  http://mydomain.com  5.0.2.5012  Administration  

And if you click on the Administation link from there, you should see:
Go to Site administration for http://mydomain.com

And if go to Site Administration for "http://mydomain.com" , you should see something for Manage Roles & Manage users.  

-Corey
0
 
LVL 1

Author Comment

by:JCRussell
ID: 10919405
Yes I see all of that.  But when I go into manage roles the only role present is the one I created (which is "Admin" and has all rightsassigned to it).  When I go into manage users and either edit or add a user, the only role present is the one I added. No Administrator, Advanced Administrator, etc.
0
 
LVL 1

Author Comment

by:JCRussell
ID: 10919416
I meant Author, Avanced Author, etc.
0
 
LVL 29

Expert Comment

by:coreybryant
ID: 10919473
And you are signed in as the Administator on the server, right?  And there is no Add role button?  

Web Admin - probably has something like: user.htm at the very end?  Change ti to adduser.htm & see what happens.  

>>
Make sure you have installed Frontpage 2002. Has the advanced author role been removed from the default installation? This role is always created when FP is first installed.

Go into the Frontpage web interface and look under the frontpage site that was added. Click on "Manage Roles" and check to see which roles are in there. There should be the following:

Administrator View, add, and change all server content; manage server settings and accounts.

Advanced author View, add, and change pages, documents, themes, and borders; recalculate hyperlinks.

Author View, add, and change pages and documents.

Contributor View pages and documents, view and contribute to discussions.

Browser View pages and documents.

-Corey
0
 
LVL 1

Author Comment

by:JCRussell
ID: 10919687
I am logging in as Administrator, 2002 is installed, the Advance Author was not removed because it never existed, and not roles appear under Manage roles except for the one I added.  They do exist on the Default Web Site, but none of the other virtual servers.
0
 
LVL 29

Expert Comment

by:coreybryant
ID: 10920012
Can you re-install the FP extensions program to see if you can bring those back?  Or did you want me to possibly login to see what's going on?

-Corey
0
 
LVL 1

Author Comment

by:JCRussell
ID: 10920169
I removed the extensions and re-nstalled and all the roles appeared.  I think that my problem was that instead of using IIS Manager>Configure FP 2002 extensions, I just extended them via the Admin page and they inherited the permissions of the Default Web.  I will ask the user to try and create her subweb and verify that it works.
0
 
LVL 29

Expert Comment

by:coreybryant
ID: 10920257
OK - that should work after you give her the correct permissions.

-Corey
0
 
LVL 6

Expert Comment

by:archerslo
ID: 10925916
FYI...  I've encountered this issue a number of times on my 2003 box.  As you discovered, I've only been able to solve the problem by removing and reinstalling the extensions for a site.

Archer
0
 
LVL 29

Expert Comment

by:coreybryant
ID: 10927454
True - if they are not set up properly in the very beginning, you will have some future problems.

-Corey
0

Featured Post

Announcing the Most Valuable Experts of 2016

MVEs are more concerned with the satisfaction of those they help than with the considerable points they can earn. They are the types of people you feel privileged to call colleagues. Join us in honoring this amazing group of Experts.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Can't connect to Hosgator with Filezilla 8 76
About Wordpress website 3 118
Show/hide areas of web form 10 78
Build and evolve an interactive experience 1 99
In this short web based tutorial, I wanted to show users how they can still use the powers of FrontPage in conjunction with Expression Web 3.  Even though Microsoft eliminated the use of Web components, we can still use them with FrontPage and edit …
This guide will walk you through the essential considerations and tech stack for building scalable websites. Know how to grow your business the smart way!
The purpose of this video is to demonstrate how to connect a WordPress website to Google Analytics. This will be demonstrated using a Windows 8 PC Go to your WordPress login page. This will look like the following: mywebsite.com/wp-login.php :…
The purpose of this video is to demonstrate how to update a WordPress Site’s version. WordPress releases new versions of its software frequently and it is important to update frequently in order to keep your site secure, and to get new WordPress…

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question