Solved

Local Network With Router Not Working

Posted on 2004-04-26
20
2,535 Views
Last Modified: 2013-11-29
I have a two pc's on a small network.   They are connected by a DLink DI804V router.    The pc's cannot connect to each other.  File sharing is enabled and the network was working OK previously.

Here are the settings.

http://www.contactshare.com/ee/

Apprciate suggestions.

Lee.
0
Comment
Question by:lnwright
  • 6
  • 3
  • 3
  • +5
20 Comments
 
LVL 7

Expert Comment

by:magus123
ID: 10916201
if the network was working previously and no software , or device has changed to restrict any access.

reset the dlink , or turn it off and on , then try.

answer these q
1 can the pcs ping the dlink???
2. can the pc ping each other ???
3. if the dlink has a setup page or etc, can your logs or pages  on the dlink see the pcs
4. is the router a dhcp server , proxy server or nat


0
 
LVL 7

Expert Comment

by:Peter Loobuyck
ID: 10916356
in internet options, click connections then lan settings, then advanced and add the ip range int that box (ie 192.168.0.*) that should let your pc search to the pc's w/o checking over the internet...
0
 

Author Comment

by:lnwright
ID: 10916475
1 No can't ping DLink but I don't know that it answers pings anyway
2 No PC's can't ping each other but One can see the other in Network Neighbourhood
3 Yes they can
4 Yes the DLink is NAT & DHCP

Internet is working fine on both machines.
0
Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

 
LVL 7

Expert Comment

by:Peter Loobuyck
ID: 10916498
well, your pc's are going to look for each other over the internet; by adding the IP range in the internet options, your pc's won't look on the internet, but on the lan itself.. try that now
0
 
LVL 1

Assisted Solution

by:etechs
etechs earned 50 total points
ID: 10916951
Hi,

Noticed a couple of things for you to check.

It seems that one machine was the original PPPoE client for Bigpond DSL and still has the DNS settings from that connection.  ie dns suffix is vic.bigpond.net.au
The speedtouch modem has the address of 10.0.0.138 and I presume that you gave the 804V the 10.0.0.100 number.

I'd try a few things and I'll list them for you.  I used to install Bigpond DSL and these things were commonly the problem with LAN access.

1.  Try to set both machines to use a static IP address in the 10.0.0.* range.  Then make sure that both are using 10.0.0.100 (if that's the 804) as the DNS.
2.  Make sure that both machines have the same 'workgroup' name.  
3.  If you have any firewall software installed, uninstall it to make sure it's not the cause.  This can be a major problem on small LANs.
4.  Log into the 804 and just make sure that you have all your settings ok.  Turn off DHCP if you are going to use static addresses.  

Let me know how you go.

Cheers,
Joe

0
 
LVL 11

Expert Comment

by:lbertacco
ID: 10916956
From your config files, it looks like the dlink has dhcp properly configured and giving address in the range 10.0.102..255
The dlink itself seems to be on ip 10.0.0.100
So you should be able to ping each other pc.

From the screenshot of 10.0.0.102, the message "Negotiating IP Security" makes me think that you have an active VPN Policy on this pc which prevents the communication.
0
 

Author Comment

by:lnwright
ID: 10917016
I've not had a chance to try the suggestions yet though they sound good.   In answer to lbertacco's question, yes there is a VPN set up.   I was wondering if the "Negotiating IP Security" was to do with that.  I think it makes sense in light of PeterLbk's comment.   I will try these suggestions as soon as I can.

Regards,


Lee.
0
 
LVL 11

Expert Comment

by:lbertacco
ID: 10917036
If IPs in the range 10.0.0.x are configured as a VPN you won't manage to ping 10.0.0.104. Either disable the VPN or have the router DHCP assign addresses in a different range (not VPN'ed)
0
 
LVL 11

Expert Comment

by:rafael_acc
ID: 10917725
Just for asking! what do you mean by "previously"!? before having the router installed? Maybe you are using the wrong cable type; aren't you using a cross-over cable at the host wich is giving you troubles ?!

Cheers.
0
 
LVL 11

Expert Comment

by:rafael_acc
ID: 10917764
Some quick troubleshooting steps for some simple problems ... However, we sometimes forget about these "simple" issues.

1. ping your loopback addr -> (having or not a network card problem)
2. ping your ip addr -> (having or not a network problem, like a missconfiguration)
3. ping your router -> (having or not a router/routing problem)
4. ping a remote host (on another subnet) -> (having or not a routing problem)
--------------------------------------------------------------------------------------------------

Cheers.
0
 
LVL 7

Expert Comment

by:Peter Loobuyck
ID: 10917825
since he can access the internet, it doesn't seem any of those probs...
0
 
LVL 31

Expert Comment

by:Gareth Gudger
ID: 10917883
I noticed you have IP Security enabled. Can you disable this?
0
 
LVL 3

Expert Comment

by:Tele_tech
ID: 10925326
I'm curious, where did the DNS 10.0.0.138 come from?

Do you have a DNS on a 2 PC network?

what is at that address currently?
Does it ping?

if there is nothing there when searching for an internal address the request is going to get lost in the world of bits and bytes without finding the internal 'DNS' at that address.

if you do not have a DNS server at that address.. remove that from your configuration and see how it goes.
0
 
LVL 3

Expert Comment

by:Tele_tech
ID: 10925327
I'm curious, where did the DNS 10.0.0.138 come from?

Do you have a DNS on a 2 PC network?

what is at that address currently?
Does it ping?

if there is nothing there when searching for an internal address the request is going to get lost in the world of bits and bytes without finding the internal 'DNS' at that address.

if you do not have a DNS server at that address.. remove that from your configuration and see how it goes.
0
 

Author Comment

by:lnwright
ID: 10966278
OK I've finally had time to try a few of the suggestions.    I got rid of the DLink 10.0.0.100 and the Modem 10.0.0.130 and just put in an ordinary hub with static IP's but still no  luck from either machine.   The weird thing is that I still get that message that says "Negotiating IP Security" on with WinXP machine but the Win98 machine just times out.     Again the WinXP machine can see the Win98 machine in network neighbourhood but can't connect.    Appreciate any further comments.
0
 

Author Comment

by:lnwright
ID: 10966329
Also when I try to log into the DLink from the WinXP machine it says "Connection Refused" but the Win98 machine is OK.
0
 
LVL 3

Expert Comment

by:Tele_tech
ID: 10968364
How about the 10.0.0.138 DNS entry that is listed in both your configurations?

What is at that address if anything?

Remove it if not used.

0
 

Author Comment

by:lnwright
ID: 10969208
10.0.0.138 is the cable modem.   Also I can ping the DLink from the Win98 machine but not from XP.
0
 
LVL 11

Accepted Solution

by:
lbertacco earned 450 total points
ID: 10970633
Still seems that on the WinXP machine you have a VPN policy at least for IPs in the range 10.0.0.0/24. You won't be able to communicate with the cable modem until you disable the vpn or change the router/pc addresses to non-vpn'ed addresses.

0
 

Author Comment

by:lnwright
ID: 10971029
Thankyou lbertacco,

The VPN policy on the WinXP machine was the problem exaclty.   I managed to find the policy and disable it.

I can't  tell you how pleased I am to have it working again.

Thanks again lbertacco and also all the others who made suggestions.

:-) Lee.
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Let’s list some of the technologies that enable smooth teleworking. 
Most of the applications these days are on Cloud. Cloud is ubiquitous with many service providers in the market. Since it has many benefits such as cost reduction, software updates, remote access, disaster recovery and much more.
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
Internet Business Fax to Email Made Easy - With  eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, f…

813 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now