Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 177
  • Last Modified:

mail server problem



not sure if this is the right place but what the heck


hey

just wondering if anyone can have a look at this problem i'm having. i have attached the basic layout of my home network. when i go to collect my mail at home i have to put in a private ip yet when i'm on the road i have to put in my public ip. surely there is a way that i can just collect my mail by using th public ip, but i just can't seem to figure it out. any help much appreciated

Trev

can't seem to add the attachment

ok mail server
private ip 192.168.1.9
router/firewall 213.105.x.x

the public ip address 213.105.x.x is mapped to the mail server using sua/nat


 
0
jim_bob2003
Asked:
jim_bob2003
  • 5
  • 4
  • 3
1 Solution
 
Gareth GudgerCommented:
Well some operating systems allow you to add an alternate IP configuration like XP.

Right click on the network connnection and click properties. Select TCP/IP and click properties and click Alternate Configuration and add you external IP info manually. The primary will still be used for your home private network.
0
 
Gareth GudgerCommented:
Alternatively there is also

www.netswitcher.com
0
 
jim_bob2003Author Commented:
nah thats not what i mean.

say i'm on my network i have to use the private ip of the mail server in the pop3 settings of outlook

but if i dial up to the internet i can use my public addrss 213.105.x.x in the pop3 settings of outlook

here's a picture of it
http://www.boards.ie/vbulletin/attachment.php?s=&postid=1575033
0
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
ewtaylorCommented:
What about just using the external address all the time?
0
 
Gareth GudgerCommented:
Oops my mistake....ylack of coffee <G>
0
 
jim_bob2003Author Commented:
Comment from ewtaylor
Date: 04/26/2004 06:38AM PDT
 Comment  


What about just using the external address all the time


tats what i want to do but it won't let me , maybe i didn't explain it proberly sorry
0
 
ewtaylorCommented:
Ok how about putting the mail server name and then adding an entry pointing to the external ip address in the lmhosts file?
0
 
jim_bob2003Author Commented:
tryed that and also tryed adding routes
0
 
ewtaylorCommented:
Hmm you could try dynamic dns then just enter the fqdn http://www.dyndns.org/
0
 
ewtaylorCommented:
Dynamic dns should take care of it, however since he did not get back to us I am not sure.
0
 
jim_bob2003Author Commented:
gave him the points but it didn't work
0
 
ewtaylorCommented:
What did not work with it? Did you get an error or did it still resolve to the internal address?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

  • 5
  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now