Solved

NT server XP clients Gateway problems

Posted on 2004-04-26
12
820 Views
Last Modified: 2010-03-18
I have a Vigor 2600 router
A windows NT server
10 Xp xlient machines

THe router is set correctly and the internet is accesble from the server

i set the default gate on the NT server to the same ip address 192.168.0.10 as the router is on.

I get no internet coonection on the xp machines

When i go on to the XP machines and do ipconfig /all all the correct infomation is there correct DHCP server address (address of my server 192.168.0.1) correct subnet mask(255.255.255.0) but the default gate is blank.

i have rebooted the server and work stations to see if this was the problem

I have also deleted leases and renewed the leases.

Next on the Xp machines i manually put in the gateway address and did ipconfig /all and 192.168.0.10 appeared in default gate way hooraahh i hear you say

But still not net access

What my problem

Thanks in advance

Mark  
0
Comment
Question by:ellandrd
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
  • 2
  • +2
12 Comments
 
LVL 7

Accepted Solution

by:
sr_millar earned 500 total points
ID: 10917682
Mark,

Sounds like a DNS issue.

What DNS are you using in your DHCP scope?  The first thing to test is do an ipconfig /all on the server and look for the DNS information (this will probably be your ISPs DNS server).  Try adding that DNS server to your DHCP scope so that all the client (XP) machines are using that DNS server aswell.  You will need to do a release/renew after the change.

Alternatively, you could setup DNS on your NT box and then configure it as a forwarder - then point all PCs to that DNS server IP address.

Let us know how you get on.

Stuart
0
 
LVL 31

Expert Comment

by:Gareth Gudger
ID: 10917822
I would agree with sr_millar.

It doesnt sound like you are specifying any servers to perform DNS name resolution.
0
 
LVL 16

Expert Comment

by:JammyPak
ID: 10917997
Whoa!

"When i go on to the XP machines and do ipconfig /all all the correct infomation is there correct DHCP server address (address of my server 192.168.0.1) correct subnet mask(255.255.255.0) but the default gate is blank."

The default gateway is blank? If so, then that's the problem. You need to set the router option on your DHCP scope and put the address as the internal ip address of your router.
0
NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

 
LVL 9

Expert Comment

by:jamesreddy
ID: 10918010
I have had almost the exact same problem with one of my clients.  They had an NT Server (not anymore) and Windows 98, Me, 2000, and XP clients.  The 2000 and XP clients frequently would "lose" their default gateway.  I came up with a fix that would work.

Assuming that your NT Server has DNS properly configured and you can successfully connect to the Internet from the server, what I did to resolve the problem is specify the SERVER's IP address in the DHCP scope as the default gateway.  Once I did that, everyone functioned perfectly.

NT and XP DNS settings don't always mix well.  I've had mixed results, but this seemed to permantly fix the problem, until I upgraded them to Windows 2000 Server.

James
0
 
LVL 16

Expert Comment

by:JammyPak
ID: 10918125
James, You made the NT Server the default gateway? Interesting...did you have to turn on ip forwarding on the NT server? 'Cause I don't see that it would act as a router without that...

So Mark, you have the ip address and subnet mask coming from DHCP, but you've hardcoded the default gateway? (sorry for my earlier braincramp...coffee!!!) I don't have an XP machine on hand, but I'm surprised it lets you do that...did you add the DG to the scope options?

To test out DNS, try visiting a website using it's ip address - if that works, then it definitely is DNS...

try going here and see if it works:
http://129.33.162.37
0
 
LVL 31

Expert Comment

by:Gareth Gudger
ID: 10918249
JAmmy.....yes you can hardcode the gateway....of course it would be better if his DHCP was correctly setup....
0
 
LVL 31

Expert Comment

by:Gareth Gudger
ID: 10918257
You can do it in Windows 2000 as well.....try hardcoding only it and then do an IPCONFIG....
0
 
LVL 31

Expert Comment

by:Gareth Gudger
ID: 10918275
When I got to a client I was working on they had 2000 boxes that had DHCP assigned IPs and subnets but to control internet access they only gave the machines they wanted a hardcoded gateway...not very secure LOL....but I guess there users were computer illiterate to know any better.
0
 
LVL 16

Author Comment

by:ellandrd
ID: 10918276
Right i aint at that server today i will look at it tonight and psot the reults up tommorow thanks for the help i reply first thing tommorow.

Mark
0
 
LVL 9

Expert Comment

by:jamesreddy
ID: 10918525
Yeah, I did Jammy.  IP forwarding wasn't neccessary.  (Don't ask).  It just worked.  I have used that same fix at multiple sites so it was not just a coincidence.  I can't exactly explain it either...
0
 
LVL 9

Expert Comment

by:jamesreddy
ID: 10918541
For the record, I've also used the same fix for 98 clients who cannot have multiple gateways but are on a 2000 network.  I simply set the 98 clients DG to be the server's IP address, and everything worked perfectly.  No IP forwarding was ever configured on the 2K server either.
0
 
LVL 16

Author Comment

by:ellandrd
ID: 10926473
Hello all you all been help full

I add the Router option to scop and Global pointing to 192.168.0.10 to DHCP <--- made no effect

I reset up DNS<---- usinf 192.168.0.1  <---address of server made no effect

I manually put in to each work station the Demon DNS servers Bingo internat works

So the first comment was correct

Thanks for all your help

Mark
0

Featured Post

NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

We recently endured a series of broadcast storms that caused our ISP to shut us down for brief periods of time. After going through a multitude of tests, we determined that the issue was related to Intel NIC drivers on some new HP desktop computers …
This is the first one of a series of articles I’ll be writing to address technical issues that are always referred to as network problems. The network boundaries have changed, therefore having an understanding of how each piece in the network  puzzl…
There's a multitude of different network monitoring solutions out there, and you're probably wondering what makes NetCrunch so special. It's completely agentless, but does let you create an agent, if you desire. It offers powerful scalability …
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question