Stop sysprep from running on boot

This should be a simple one, but I'm at a loss to figure out how to do this. I ran sysprep on my machine just as a test, and do not wish to complete the process. Never-the-less, it continues to startup everytime I reboot my machine, and I'd like it to NOT startup. Boot's to XP just fine, loads ok, but comes up with the sysprep selection box on every boot. As I said, it was just a test run, and I don't need to complete it. Any ideas? I am sure it's just a simple reg edit or deleting an .inf file, just don't know which edit or file. TIA for your answer.

Regards,

Sardukar
sardukar78Asked:
Who is Participating?
 
sirbountyConnect With a Mentor Commented:
Think this is it...
>>
WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

When you run Sysprep or Riprep on a source computer, it changes the following registry entries to the following values:
HKEY_LOCAL_MACHINE\SYSTEM\Setup

Cmdline:REG_SZ:setup -newsetup -Mini (Adds the -Mini entry)
MiniSetupInProgress:REG_DWORD:0x1
SetupType:REG_DWORD:0x1
SystemSetupInProgress:REG_DWORD:0x1
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager

SetupExecute:REG_MULTI_SZ:setupcl.exe
When you restart the computer, Setupcl.exe automatically assigns new SIDs to the computer and then starts the Mini-Setup Wizard to complete Setup.

If you want to prevent new SIDs from being assigned and the Mini-Setup Wizard from running, you must modify the Windows 2000 registry to reset the values back to the original values, or you must rename, and then replace the %SystemRoot%\system32\Config\System file from the %SystemRoot%\Repair or %SystemRoot%\Regback folder:
Start the computer with the Windows 2000 installation CD-ROM in Recovery Console.
In Recovery Console, log on to the computer, navigate to the %SystemRoot%\system32\Config folder, and then rename the System file to System.mini.
Copy the %SystemRoot%\repair\System file to the %SystemRoot%\System32\Config folder.
Exit Recovery Console, and then reboot into the original operating system by using the previous System hive.

Note: This is a temporary System hive that does not need to have any installed programs or services; you only need to use it to make the computer bootable so that you can make the following changes.
Start Regedt32.exe, and then click the HKEY_LOCAL_MACHINE key.
On the Registry menu, click Load Hive, open the %SystemRoot%\System32\Config\System.mini registry file, and then type the name in as something other than System, such as Test.
Navigate to the HKEY_LOCAL_MACHINE\Test\Select registry key, and note the value for the Current REG_DWORD entry:
Current:REG_DWORD:value

This value selects which ControlSet00x to load when you start the computer, and this is the ControlSet that you must modify.
Go to the following registry key
HKEY_LOCAL_MACHINE\Test\ControlSet00x\Control\Session Manager

where x is the value in Current:REG_DWORD: value.
Double-click the following entry
SetupExecute:REG_MULTI_SZ:Setupcl.exe

remove the Setupcl.exe entry, and then click OK.
Go to the HEY_LOCAL_MACHINE\Test\Setup registry key, and then change the following registry entries from 0x1 to have a value of 0 (zero):
MiniSetupInProgress:REG_DWORD:0
SetupType:REG_DWORD:0
SystemSetupInProgress:REG_DWORD:0

Double-click the following entry
Cmdline:REG_SZ:setup -newsetup -Mini

and remove only the -Mini entry.
After you make the necessary changes, click the HKEY_LOCAL_MACHINE\Test registry key, and then on the Registry menu, click Unload Hive.
Exit Registry Editor, and then restart Recovery Console.
Navigate to the %SystemRoot%\system32\Config folder, rename the System file to System.erd, and then rename the System.mini file to System.
Exit Recovery Console, and then reboot into the original operating system.
The computer should now be back to its original state, as it was prior to running the Sysprep or Riprep utility with the following exceptions:
Sysprep adds approximately 4 MB to the registry quota each time it runs without completing successfully. Verify that the Maximum Registry Size value meets the needs of your computer; you may want to reduce it. To check this value, in Control Panel, double-click System, click the Advanced tab, click Performance Options, and then click Change.
Two device path registry entries may have been adjusted. If either "OemPnPDriversPath=" or "InstallFilesPath=" were specified in the Sysprep.inf file, you must remove the entries that Sysprep added from the registry entries:
If OemPnPDriversPath= was used in Sysprep.inf, remove entries that were added to the the following default entry:
HKLM\Software\Microsoft\Windows\CurrentVersion\DevicePath:REG_EXPAND_SZ:%SystemRoot%\inf

If InstallFilesPath= was used in Sysprep.inf, remove entries that were added to the the following default entry
HKLM\Software\Microsoft\Windows\CurrentVersion\Setup\SourcePath:REG_SZ:CD_ROM:

where CD_ROM is the local CD-ROM drive letter.<<ref: http://support.microsoft.com/?id=287506
0
 
sirbountyCommented:
Try Start-Run-MSconfig and search for it on the startup tab.
It may be in the HKLM (or HKCU) \software\microsoft\windows\currentversion\run key
0
 
sardukar78Author Commented:
Yeah, I have done the obvious solutions, msconfig and checking the startup folder in the start menu, but i'll certainly try the HKLM solution as soon as I get home. Thanks for the quick response, btw.
0
 
sirbountyCommented:
If memory serves correctly - it's actually in a seperate key in the registry..I was thinking even WindowsNT instead...
I'm not at work now, or else I'd be able to help you further - perhaps another expert will happen along that remembers...(darn this grey matter :(
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.