• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3956
  • Last Modified:

SQL Server does not exist or access denied.

I have been running SQL Server 2000 on my laptop for the past few years without a problem.  Suddenly as of yesterday I am getting the following message whenever I try to connect to the server :

Unable to connect to server {my server name}
Server: Msg 17, Level 16, State 1
[Microsoft][ODBC SQL Server Driver][TCP/IP Sockets]SQL Server does not exist or access denied.

I use mixed mode authentication and both the windows login mode and the sql server login modes fail.  The only thing that has changed is that I did a system restore to an earlier checkpoint, however that checkpoint was only from a few days earlier and shouldn't have affected sql server.  I also ran the WinXPFix utility.  Both were done because my installation is having trouble with the tcp/ip stack becoming corrupted in windows.

Another possibility is that I installed a time limited version of SQL Server developers edition.  I had to re-install SQL server about 2 months ago and I think I used the developer version disk.  However I don't believe this has any sort of time limit.  And even if it does there was no warning, and looking at the program information in the "add/remove programs" section it does not mention the installation being anything other than a normal instance of sql server.  Unforunately I am travelling at the moment and do not have access to the disks for another couple of weeks to check what I actually installed.

The SQLServer instance appears to be running, which is a bit surprising since it should be starting up using the same windows logon as I am using.  However beyond that I cannot tell anything more since I cannot even see the properties of the server registration.
0
eb8931
Asked:
eb8931
  • 5
  • 4
  • 2
  • +2
1 Solution
 
arbertCommented:
It sounds like you have a real hodge-podge going on there.  I don't think you can safely do anything without reinstalling SQL Server.  You reinstalled "who know what version" over an old version of "who know what" with the registry keys still in place.....

Go into services under Administrative tools in Control panel and verify the server startup account.
0
 
eb8931Author Commented:
The re-install done 2 months ago was a fresh re-install.  I had to re-install windows from scratch.  Also just to be clear from the previous message the corrupted tcp/ip stack was a problem in the windows installation, not sql server.  It had been working perfectly ok up until yesterday.
0
 
arbertCommented:
What about "Go into services under Administrative tools in Control panel and verify the server startup account."


Did you happen to maybe get a windows update the last couple of days????
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
arbertCommented:
Or install new software?  What changed?  Things don't just quit working...
0
 
arbertCommented:
Also, please close your question from February....
0
 
Melih SARICACommented:
Did  u check that ur SQL server is running ?
0
 
danblakeCommented:
Unable to connect to server {my server name}
Server: Msg 17, Level 16, State 1
[Microsoft][ODBC SQL Server Driver][TCP/IP Sockets]SQL Server does not exist or access denied.
--->
I have seen this happen also, normally on my machine after setup (I'm also running XP) where you have the TCP/IP Alias incorrectly setup.
WinXP has this lovely habit of disabling the 127.0.0.1 ip address and external broadcast ip addresses if no external network connections are available or your disconnected from the network.

Can you check that you have a local alias setup using the 'localhost' as your ip address to your machine name/service that you are using to connect within Enterprise Manager - this has normally solved the issue for me (once I've checked that SQL Server is setup to autostart every time..)

0
 
eb8931Author Commented:
Since last time it was working windows update has been run.  Also a windows rollback was done, although nothing eventually was rolled back.  And also WinXPFix was run to sort out the recurring windows TCP/IP problem I have been having.  I have run WinXPFix quite a few times previously without problems.

The instance of SQLServer is running.


>> Can you check that you have a local alias setup using the 'localhost' as your ip address to your machine name/service that you are using to connect within Enterprise Manager - this has normally solved the issue for me (once I've checked that SQL Server is setup to autostart every time..)

Can you take me through how to do this in slightly more detail.  I am a home user of SQL Server so although I pick up things quickly, I sometimes need them explained to me slowly :)

Thanks,

Graeme
0
 
danblakeCommented:
Click Start
Click All Programs
Click MS SQl Server (Default Group for SQL Server install)
Start the Client Network Utility (on your local sql-server install)


This then opens the Client Network Utility.

Click the Alias Tab,
Click Add
(A dialog box is now presented)
Put a Server alias in the Server Alias box-- such as MISQLMACHINE
Click TCP/IP on the Network Libraries side
Change the ServerName to localhost (rather than your TCP IP setup for your machine)
Click OK to Save.


Now Open Enterprise Manager,
Expand the Microsoft SQL Server node, Right Click on a SQL Server Group (Default is SQL Server Group)
The wizard apears as default.
On Available Servers there should be the Server Alias you created: MISQLMACHINE (or whatever you called it)
Select MISQLMACHINE  --> Click Add.

Click Next, Add the Authentication you are using (You should be able to use WIN Authentication)
Then Click Next, Choose the SQL Server Group you wish to place the server into, Click Next, Click Finish.

Then Expand EM, Your SQL Server Group that you chose, and Open the Server name you just registered --
this should now be working.

If you are getting a login timeout to the server in EM.  Click on the MMC Menu bar: Tools -> Options
Advanced and modify the login time-out to something a little larger.

Note : It may be a good idea if this is the only server in your group to Choose the Open the console tree to the last active node option. (You'll open your default server up every time then -- as you only have 1 -- ready for work.)

0
 
eb8931Author Commented:
Sorry for the delay in closing this topic.  I found a strange reason that was stopping SQL-Server from connecting.  I noticed after a while that when I was disconnected from the internet SQL Server would allow me to connect again.  I thought the problem might have something to do with then firewall blocking some message that SQL was sending to microsoft.  As it turned out McAfees firewall that I had been running had become corrupted and may have been the cause of the problem.  I removed it and replaced it with Nortons and after a few attempts was able to get SQL-Server running when I connected to the internet.  

Thanks,

Graeme
0
 
eb8931Author Commented:
Although I eventually found the solution, and it seemed unexpected enough that it would have been difficult to find without actually going onto my machine, I will have to give the points to someone so I will give them to Dan.

Thanks,

Graeme
0
 
arbertCommented:
" I will have to give the points to someone so I will give them to Dan."

You never have to award points--if you solved your own problem, you can always request a refund.  No use having some one search the forums in the future and finding and incorrect answer to a question.
0
 
DominicCroninCommented:
Indeed - the alias suggestion doesn't seem to work for me. I have a similar problem.
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 5
  • 4
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now