Runtime Error 20997.

Hi All,

I have a report which contains 4 subreports. When i try to open the report i get "Runtime Error 20997".This happens only for a particular record. The reports are TTX based. I am using CRPEAUTO object to preview the report.

Thanks in Advance.

Regards.
PentechAsked:
Who is Participating?
 
mlmccCommented:
The Crystal Knowledge base doesn't have much help.  All are older versions and most are using the OCX rather than the CRPE method.

What version of Crystal?

Is there anything special about the record in question?

mlmcc
0
 
frodomanCommented:
OLE2 files may need to be registered. To register OLE2 files go to Start | Run, and enter:  C:\windows\system\ole2.reg

If registration was successful the following message will appear: Information in C:\windows\system\ole2.reg was successfully entered into the registry.


0
 
PentechAuthor Commented:
I am using Crystal Reports 7.0

The OLE2.REG file mentioned is not present on my machine. Any info on where to get the file ?

0
 
frodomanConnect With a Mentor Commented:
mlmcc's second link explains the same thing I told you.  I'm not even certain this is relevant in your case but it's the only information I could find.

Since you said it happens on a certain record I'm assuming it's not chart-related.

Can you identify the record when this happens?  Is there anything different about this record?  Do the records involve standard data fields or are you returning OLE Objects?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.