Solved

Ethernet Dial backup isn't working

Posted on 2004-04-27
102
761 Views
Last Modified: 2007-12-19
I got a 2610 router with a us robotics sportster modem.  I made a dial backup for whenever my ethernet fails, the dialer kicks in. But when it kicks in, it doesn't dial out to my desire number.  Here is my running-config:

sh ru
Building configuration...

Current configuration : 1055 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
!
!
!
!
!
ip subnet-zero
!
!
!
!
interface Ethernet0/0
 backup interface Dialer1
 ip address 192.169.1.210 255.255.255.0
ip access-group 102 in
 ip nat inside
!
interface Serial0/0
 no ip address
 shutdown
 no fair-queue
!
interface Dialer1
 ip address 192.169.1.210 255.255.255.0
 ip nat outside
 encapsulation ppp
 dialer pool 1
 dialer remote-name TEST-LAB-Dialer1
 dialer enable-timeout 10
 dialer string 9,18005437890
 dialer-group 1
 ppp authentication ms-chap
!
router rip
 network 192.169.1.0
!
ip classless
ip http server
!
access-list 102 permit tcp any any established
access-list 102 permit ip 192.169.1.0 0.0.0.255 any
dialer-list 1 protocol ip permit
!
line con 0
 password password
 logging synchronous
 login
line aux 0
 password password
 login
 modem InOut
 modem autoconfigure type usr_sportster
 transport input all
 stopbits 1
 speed 300
line vty 0 4
 password pasword
 login
!
no scheduler allocate
end

Router#


Any help would be greatly appreciated.
0
Comment
Question by:Pentrix2
  • 51
  • 35
  • 16
102 Comments
 
LVL 9

Author Comment

by:Pentrix2
Comment Utility
Can somebody please help?????
0
 
LVL 12

Accepted Solution

by:
Scotty_cisco earned 500 total points
Comment Utility
Does it dial at all???

Have you done a debug dialer???

http://www.cisco.com/en/US/tech/tk801/tk36/technologies_configuration_example09186a0080093d2b.shtml

here is a link that may help

I will look further at your config and see what I can figure out... but I wanted to get back to you asap

Thanks
Scott
0
 
LVL 12

Expert Comment

by:Scotty_cisco
Comment Utility
try adding a floating static route to the dialer 1 first and then do a debug dialer... and fail the ethernet

thanks
Scott
0
 
LVL 12

Expert Comment

by:Scotty_cisco
Comment Utility
here is another link

http://www.cisco.com/en/US/tech/tk801/tk36/technologies_configuration_example09186a0080094579.shtml

also make sure that you have typed in EXEC in the line aux 0

thanks
Scott
0
 
LVL 9

Author Comment

by:Pentrix2
Comment Utility
You were right, it doesn't dial out at all.
Can you tell me on exactly how I will put in the floating static route?
0
 
LVL 9

Author Comment

by:Pentrix2
Comment Utility
I did that debug dialer and failed the ethernet.  This is what it gave me but it doesn't dialer out though.  I did put in that exec-timeout 0 0 for line aux 0.

1d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0, changed stat
e to down
Router#
1d02h: Di1: No free dialer - starting fast idle timer
Router#
1d02h: %LINK-3-UPDOWN: Interface Dialer1, changed state to up
Router#
0
 
LVL 12

Expert Comment

by:Scotty_cisco
Comment Utility
Another problem that I see is that your dialer has the same IP as your ethernet change that to something else....  and to put the floating static route you would do the following

IP ROUTE 0.0.0.0 0.0.0.0 dialer 1 150

that is assuming that this will be your default route.

also I only see one interface can you more clearly describe your network design??/
0
 
LVL 9

Author Comment

by:Pentrix2
Comment Utility
My network design isl ike this:

Right now I"m just testing the ethernet connection to see if it will work, then when it does I will put it to the serial line.

I got routerA over in Florida connected to me in Maine.  I also have a Routing and Remote Access Server (Windows 2000) that has a huge phone bank in it.  I want it when a Serial Connection (But in this case I was just Ethernet) then my dial back up interface will kick in and dial my RRAS.  I then have another problem, how will I make those two connections authenticate.  I know cisco router to cisco router can authenticate but I don't know how to do the other way around which is Microsoft RRAS to cisco router to authenticate.

I tried those commands but why won't my modem dial out?  Is there something wrong with my config in the line aux 0?
0
 
LVL 28

Expert Comment

by:mikebernhardt
Comment Utility
The main problem is that the dialer interface is configured with dialer pool 1 but nothing is set up as a pool-member 1. You need to set up an async interface and configure it with dialer pool-member 1. The number of the asynce interface should be the line number of the aux port (type show line and see what line number aux 0 is).

the proof is in your debug output:
1d02h: Di1: No free dialer - starting fast idle timer

It can't find an interface to dial from.

the 2nd URL that soctty gave you shows you exactly what to do when you're using a dialer interface, as you are. The first one uses "legacy dialing" which doesn't require the dialer interface. Either one would work for you.
0
 
LVL 12

Expert Comment

by:Scotty_cisco
Comment Utility
well the problem comes in the dialer actually... I would change things a bit... since this is not a production box I would create an async interface.  and route through it... I will get you a config that I know works and then we will move on to authentication...
0
 
LVL 12

Expert Comment

by:Scotty_cisco
Comment Utility
LOL like Mike said one mintue before
0
 
LVL 9

Author Comment

by:Pentrix2
Comment Utility
How would I setup a dialer pool-member 1?  So I can just get rid of my interface dialer1, is that correct?
0
 
LVL 12

Expert Comment

by:Scotty_cisco
Comment Utility
no ... create an interface async.... let me get you a config ... just a second
0
 
LVL 28

Expert Comment

by:mikebernhardt
Comment Utility
You can do it with a dialer interface which must link with an async interface via a "pool." Or you can use the "legacy" method which doesn;t use a dialer interface. You do all the configuration right on the async interface. This is actually much simpler to follow if you only have one modem.

By the way, why do you have nat inside and nat outside configured on your interfaces? If you're not using nat you should remove that partial config.
0
 
LVL 12

Expert Comment

by:Scotty_cisco
Comment Utility
the second link that I sent you shows the setup of the async interface  

see the dialer-pool member in the interface async 65 ... you would tie the dialer to the async interface using dialer-pool member 1
0
 
LVL 12

Expert Comment

by:Scotty_cisco
Comment Utility
Here is a legacy example .... look at the BRI interface... though no async but it will give you an Idea
0
 
LVL 12

Expert Comment

by:Scotty_cisco
Comment Utility
0
 
LVL 9

Author Comment

by:Pentrix2
Comment Utility
Alright, I'll get rid of NAT, would I put in the same thing in dialer pool-member 1 like i did dialer1 or should I put it in the e0/0
0
 
LVL 12

Expert Comment

by:Scotty_cisco
Comment Utility
no nothing should go in e0/0

I would use legacy dialers but that is just me... they also seem to work better than dialer pools I have had issues with that
0
 
LVL 28

Expert Comment

by:mikebernhardt
Comment Utility
In this case I'd use legacy dialing too, as I said it's simpler when you only have one modem.

I would suggest a couple more things:

If you use a floating static route, set it up so that the default route points to the IP address on the other side of the modem connection, i.e.
ip route 0.0.0.0 0.0.0.0 192.169.2.2 150

The 150 is the administrative distance, which says to only believe it if there's nothing better advertised by another routing protocol. But for this to work, you also have to have your NORMAL default route also. This can also be static, pointing to the other side of the ethernet/serial i.e.
ip route 0.0.0.0 0.0.0.0 192.169.1.2
(note no distance added, which gives it a default distance of 1)
or since you're running RIP you are hopefully injecting a default route into rip on the other side. (rip's administrative distance is 120 which is better than 150 also). Without a default route you won't be able to leave your site. And if your only default route is the floating one, well that will be your default route and the modem will keep dialing.

I don't like using the backup-interface command on the ethernet/serial because depending on the problem, it doesn't always work. And you can't even test the line unless you take down the ethernet first.  But if you don't have a default route for the ethernet serial link you must keep it in.

0
 
LVL 12

Expert Comment

by:Scotty_cisco
Comment Utility
again mike is accurate... I just did not want to speculate on the far side... you can also in your dialer have it IP negotiated and have your ras box hand the dialer and IP address is that is easier...
0
 
LVL 9

Author Comment

by:Pentrix2
Comment Utility
I'm using IOS 12.1.  I'll try those and give you guys an update.
0
 
LVL 9

Author Comment

by:Pentrix2
Comment Utility
Alright, can you guys give me a running config with just the commands with any ip address you want.  I will just have to clear out my running-config because it's a big mess.  Is there a running-config that I can use from scratch?  I'll give this point to scotty cisco.  Sorry for the confusion and patiences you 2.
0
 
LVL 12

Expert Comment

by:Scotty_cisco
Comment Utility
ok I will need to construct this I am going to use the following ok???

  192.168.2.1------router--------serial line 192.168.3.1----------------main office192.168.1.1--------
        \                                                                                                 /
         \                                                                                               /
           dial line----------------------------------------------------------------ras server 192.168.1.10

0
 
LVL 9

Author Comment

by:Pentrix2
Comment Utility
Sure, use whatever you want.  When it's done, I'll just put in my own ip.  Just for now, I can use your ip address and settings into my lab before I deploy it into production.
0
 
LVL 12

Expert Comment

by:Scotty_cisco
Comment Utility
this is closest to what you have but is not legacy... try this and let me know


ip subnet-zero
ip routing

modemcap entry usr_sportster:FD=&F:AA=S0=1:CD=&C1:DTR=&D3:HFL=&H1&R2:SPD=&B1:BER=&M4:BCP=&K1:NER=&M0:NCP=&K0:NEC=E0:NRS=Q1
!
interface Dialer 1
 description connected to CorporateNetwork
 ip unnumbered Ethernet 0/0
 encapsulation ppp
 dialer in-band
 dialer idle-timeout 120
 dialer string 918005437890
 dialer hold-queue 10
 dialer-group 1
 ppp authentication ms-chap callin
 ppp ms-chap hostname router
 ppp ms-chap password testme
 no cdp enable
!
interface Ethernet 0/0
 ip address 192.168.2.1 255.255.255.0
!
interface Async 65
 no shutdown
 description connected to CorporateNetwork
 no ip address
 async mode dedicated
 dialer rotary-group 1
!
interface Serial 0/0
 ip address 192.168.3.2 255.255.255.252
!
ip route 0.0.0.0 0.0.0.0 192.168.3.1
ip route 0.0.0.0 0.0.0.0 192.168.1.10 150
!
line aux 0
 autoselect ppp
 modem InOut
 modem autoconfigure type usr_sportster
 transport input all
 stopbits 1
 speed 38400
 flowcontrol hardware
!
end
0
 
LVL 12

Expert Comment

by:Scotty_cisco
Comment Utility
I can get a known working config that uses legacy tonight when I go home .... and I will post that as well..

I also would not use a routing protocol as your network is not one that really needs it.... from what I can tell you are using the corprate network as the default network for all traffic ... but correct me if I am wrong
0
 
LVL 28

Expert Comment

by:mikebernhardt
Comment Utility
Scotty, that was my thinking also- RIP sucks anyway :-)

Nice job!
0
 
LVL 9

Author Comment

by:Pentrix2
Comment Utility
You are really great Scotty, thanks for all the help.  I'm looking forward to the next post and giving it a try.  You gave me hope, :)
0
 
LVL 9

Author Comment

by:Pentrix2
Comment Utility
Any updates Scotty?
0
 
LVL 12

Expert Comment

by:Scotty_cisco
Comment Utility
working on it sorry.... dug through backups last night will have it soon I hope
0
 
LVL 9

Author Comment

by:Pentrix2
Comment Utility
No problem, beggers(which is me) can't be greedy.    :)
0
 
LVL 12

Expert Comment

by:Scotty_cisco
Comment Utility
have you tried the other config?  does it work?? or I should say does it work the way you want it to?

Thanks
Scott
0
 
LVL 9

Author Comment

by:Pentrix2
Comment Utility
I just signed up and accidently posted this same question in the VPN.  You can just post a comment and I will accept it that way you can get the credit since you have been very patient with me too.

http://www.experts-exchange.com/Networking/Broadband/VPN/Q_20967802.html
0
 
LVL 12

Expert Comment

by:Scotty_cisco
Comment Utility
no just delete the question not a big deal
0
 
LVL 9

Author Comment

by:Pentrix2
Comment Utility
I tried the above config but when I fail the line on purpose the modem doesn't dial out.  On that post you said it wasn't meant for legacy though.
0
 
LVL 9

Author Comment

by:Pentrix2
Comment Utility
Those 2 command doesn't work when I put it into dialer1

ppp ms-chap hostname router
ppp ms-chap password testme

0
 
LVL 12

Expert Comment

by:Scotty_cisco
Comment Utility
then put this in the command

router(config)# username testme password testme

this is in the global command


then do a debug dialer
and debug ppp auth
0
 
LVL 9

Author Comment

by:Pentrix2
Comment Utility
I tried that, but why won't the modem dial out?
0
 
LVL 9

Author Comment

by:Pentrix2
Comment Utility
Dont' we need this in the e0/0 because the dialer1 isn't kicking in.

back int dialer1
0
 
LVL 28

Expert Comment

by:mikebernhardt
Comment Utility
That's why I was saying that backup interface is not reliable. Here's what I would suggest to force the dialer to at least try: Put in a static route pointing to the other side of the modem, to a specific host. Do not use backup interface. Then when you ping that host, you will force the modem to dial, if it's going to. Before you do it, use
debug dialer
debug dialer packets

This will show you exactly what is happening including which packets are causing, or not causing, the dialer to kick in.
0
 
LVL 9

Author Comment

by:Pentrix2
Comment Utility
ohhh, I got you now.  I'm going to try that now.
0
 
LVL 9

Author Comment

by:Pentrix2
Comment Utility
How would I make the static route pointing to the other side of the modem?

would it be:


ip route 192.169.1.2
0
 
LVL 9

Author Comment

by:Pentrix2
Comment Utility
and will this go to the global config or e0/0?
0
 
LVL 28

Expert Comment

by:mikebernhardt
Comment Utility
ip route 192.169.1.2 255.255.255.255 192.169.1.10

Assuming that 192.169.1.2 is the host you want to ping and 192.169.1.10 is the RAS that answers the phone (the next hop)

Once you get it to dial, if it hadnshakes but eventually hangs up, use
debug ppp authentication
to figure out what's failing. Probably a mismatched user name or password on one side or the other.
0
 
LVL 9

Author Comment

by:Pentrix2
Comment Utility
Once it does dial out, then how will my windows 2000 RRAS authenticate to my cisco router?  I know that now the cisc router has a username and password but where will I put the authentication at?
0
 
LVL 9

Author Comment

by:Pentrix2
Comment Utility
Scotty, I'm getting my other router in this friday then I will give it a full test.  I will let you know the results on Friday.
0
 
LVL 28

Expert Comment

by:mikebernhardt
Comment Utility
In dialer 1, you have "ppp authentication ms-chap callin"

That is what does it. Set up your RAS with the name and password you had in dialer 1
ppp ms-chap hostname router
ppp ms-chap password testme

Read http://www.cisco.com/en/US/tech/tk713/tk507/technologies_tech_note09186a00800b4131.shtml for more
0
 
LVL 9

Author Comment

by:Pentrix2
Comment Utility
How will I configure the windows 2000 server (with routing and remote access) to have the username and password?  Will that be in active directory or is there a security setting in RRAS that let's me put in a username and password.
0
 
LVL 12

Expert Comment

by:Scotty_cisco
Comment Utility
I am not an expert on windows but I do know that there will need to be a ras account with the username and password.... sorry for the neglect today but I am working on some very important issues.

Thanks
Scott
0
 
LVL 28

Expert Comment

by:mikebernhardt
Comment Utility
I think in Active Directory you can enable remote access for a user. You will have to ask that in the windows area though.

I'd like to suggest however that you first make sure your router is dialing successfully, and verify that it is even trying to authenticate using the debug ppp commands I gave you. Work on one step at a time so you know where your problem is.
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 
LVL 28

Expert Comment

by:mikebernhardt
Comment Utility
In the meantime you can also read the link I gave you so you understand ppp authentication on a Cisco router. It will help you troubleshoot later.
0
 
LVL 9

Author Comment

by:Pentrix2
Comment Utility
Alright, thanks.  The links you guys provided me have been very useful and gave me a much more in depth understanding of the protocols.  When the other router comes in this Friday I will do the configs with the modem dialing out and go from there.  I will give you two an update when I get a little further.
0
 
LVL 9

Author Comment

by:Pentrix2
Comment Utility
I tried and got this error message:

00:33:13: %LINK-3-UPDOWN: Interface Serial0/0, changed state to down
00:33:14: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to down
Router#
00:33:21: Di1 DDR: cdp, 269 bytes, outgoing uninteresting (dialer-list 1 not defined)
00:33:21: Di1 DDR: sending broadcast to default destination -- failed, not connected

Then every couple of seconds it keeps on repeating the last 2 lines(above).  It looks like it's trying to use dialer-list 1 for outgoing packets but it can't find it, how will I define it?  Modem still doesn't dial out and here's my current run-config.


sh ru
Building configuration...

Current configuration : 1132 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
!
username testme password 0 testme
!
!
!
!
ip subnet-zero
!
!
!
!
interface Ethernet0/0
 ip address 192.168.2.1 255.255.255.0
!
interface Serial0/0
 ip address 192.168.3.2 255.255.255.0
!
interface Serial0/1
 no ip address
 shutdown
!
interface Async65
 description connected to CorporateNetwork
 no ip address
 encapsulation ppp
 dialer in-band
 dialer rotary-group 1
 async mode dedicated
 no cdp enable
!
interface Dialer1
 description connected to CorporateNetwork
 ip unnumbered Ethernet0/0
 encapsulation ppp
 dialer in-band
 dialer string 9,17039690679
 dialer hold-queue 10
 dialer-group 1
 ppp authentication ms-chap callin
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.3.1
ip route 0.0.0.0 0.0.0.0 192.168.1.10 150
ip route 192.168.1.2 255.255.255.255 192.168.1.10
ip http server
!
!
line con 0
 logging synchronous
line aux 0
 modem InOut
 modem autoconfigure type usr_sportster
 transport input all
 autoselect ppp
 stopbits 1
 speed 19200
 flowcontrol hardware
line vty 0 4
 login
!
end

Router#
0
 
LVL 9

Author Comment

by:Pentrix2
Comment Utility
I inserted thsi command to try to answer the error message -  
00:33:21: Di1 DDR: cdp, 269 bytes, outgoing uninteresting (dialer-list 1 not defined)
00:33:21: Di1 DDR: sending broadcast to default destination -- failed, not connected

dialer-list 1 protocol ip permit <------- command that I inserted.

But now it's saying this now:

04:55:21: Di1 DDR: cdp, 287 bytes, outgoing uninteresting (no list matched)
04:55:21: Di1 DDR: sending broadcast to default destination -- failed, not connected

Modem still doesnt' dial out when I fail my serial line?
0
 
LVL 12

Expert Comment

by:Scotty_cisco
Comment Utility
Ahh you need a dialer-list


router(config t)#dialer-list 1 protocol ip permit
0
 
LVL 9

Author Comment

by:Pentrix2
Comment Utility
I did add that command but it now gives me this error message.

05:04:21: Di1 DDR: cdp, 269 bytes, outgoing uninteresting (no list matched)
05:04:21: Di1 DDR: sending broadcast to default destination -- failed, not connected
0
 
LVL 12

Expert Comment

by:Scotty_cisco
Comment Utility
what does your dialer-list say specifically
0
 
LVL 9

Author Comment

by:Pentrix2
Comment Utility
What do you mean?  The only thing I have for a dialer-list is your command.

dialer-list 1 protocol ip permit
0
 
LVL 12

Expert Comment

by:Scotty_cisco
Comment Utility
try pinging the other side it was cdp that tried to brin up the connection.... and nothing else
0
 
LVL 9

Author Comment

by:Pentrix2
Comment Utility
Tried but modem still doesn't dial out?
0
 
LVL 12

Expert Comment

by:Scotty_cisco
Comment Utility
what does your debug dialer say though.....

what lights are on ... on the modem
0
 
LVL 9

Author Comment

by:Pentrix2
Comment Utility
My debugger only says same this and nothing else:

05:16:21: Di1 DDR: cdp, 269 bytes, outgoing uninteresting (no list matched)
05:16:21: Di1 DDR: sending broadcast to default destination -- failed, not connected

I'm using a USRobotics modem, only light is on is:  CS   (Clear to Send)
0
 
LVL 12

Expert Comment

by:Scotty_cisco
Comment Utility
what cable are you using between the AUX port and the modem.... and while pinging the far side from the router  you see nothing other than

05:16:21: Di1 DDR: cdp, 269 bytes, outgoing uninteresting (no list matched)
05:16:21: Di1 DDR: sending broadcast to default destination -- failed, not connected

so happens that I have almost the same router and modem you do I am going to set this up quickly and look at the modem... see if I can get into it...

What is the model of the modem
0
 
LVL 9

Author Comment

by:Pentrix2
Comment Utility
I'm using one of those modem adapters i think it's a db25, then I connect it straight ethernet cable to the aux port of the router.  

Model of modem is:  US Robotics Sportsters Faxmodem with X2 (56k)

Yupe, when I ping I get nothing which is this:

Router#ping 192.168.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.3.3, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
Router#192.168.3.3
Trying 192.168.3.3 ...
% Destination unreachable; gateway or host down
0
 
LVL 12

Expert Comment

by:Scotty_cisco
Comment Utility
ok I do not understand your setup with your cable.... you should be using one of the ones that came with the router.... it should be a pre-made black cable with an rj45 on one end and a db25 on the other.   Or a cisco db25 to rj45 adapter and a roll over cable (pins 1-8 8-1) ..  Is this what you mean?

Thanks
Scott
0
 
LVL 9

Author Comment

by:Pentrix2
Comment Utility
My bad, that's what I meant. sorrie.
0
 
LVL 12

Expert Comment

by:Scotty_cisco
Comment Utility
ok I am going to use your config and test this see what I come up with
0
 
LVL 9

Author Comment

by:Pentrix2
Comment Utility
My bad again, I used the wrong cable.  Now i'm using the roll over cable and lights on the modem are:


AA (Auto-answer)
TR (Terminal Ready)
CS (Clear to Send)


Modem still doesn't dial out when I ping the other side.  Let me know what results you get.
0
 
LVL 12

Expert Comment

by:Scotty_cisco
Comment Utility
ok but now what does the debug dialer tell you do you have dip switches set
0
 
LVL 9

Author Comment

by:Pentrix2
Comment Utility
The debug dialer doesn't tell me anything, what are the settings for the dip switches?  I didn't know they had to be set a certain way?
0
 
LVL 12

Expert Comment

by:Scotty_cisco
Comment Utility
ok started looking at your config really close and came up with some more questions


ip route 0.0.0.0 0.0.0.0 192.168.3.1  I undertand this route
ip route 0.0.0.0 0.0.0.0 192.168.1.10 150   what is this route for
ip route 192.168.1.2 255.255.255.255 192.168.1.10  Where is the ip address 192.168.1.2

ok ... also does your ras server hand out the address to the router or is it static

thanks



0
 
LVL 9

Author Comment

by:Pentrix2
Comment Utility
I got the second line from you:

-------------------
Another problem that I see is that your dialer has the same IP as your ethernet change that to something else....  and to put the floating static route you would do the following

IP ROUTE 0.0.0.0 0.0.0.0 dialer 1 150

that is assuming that this will be your default route.
------------------

The third line is just made up addresses to make a static route pointing to the other side.  You can change any of the configs if you want.
0
 
LVL 28

Expert Comment

by:mikebernhardt
Comment Utility
ip route 192.168.1.2 255.255.255.255 192.168.1.10  Where is the ip address 192.168.1.2

192.168.1.2 was supposed to be some device on the other side of the Win2K RAS.

The reason it never dials out is that the router has no idea where 192.168.1.10 is. If you use IP unnumbered as you are (and that's fine), you must have a static route that says where your next hop is, i.e.

ip route 192.168.1.10 255.255.255.255 dialer 1

Now you have a nailed-down route to 192.168.1.10. Any traffic that is supposed to go via that address will kick off the dialer.
----------------------
Also, FYI...
05:16:21: Di1 DDR: cdp, 269 bytes, outgoing uninteresting (no list matched)
05:16:21: Di1 DDR: sending broadcast to default destination -- failed, not connected

1st line means that a cdp packet on the dialer interface was not interesting because it didn't match any dialer list. This is good.
2nd line means that it didn't send some broadcast packet because you didn't have a connection already. This is good too.
0
 
LVL 9

Author Comment

by:Pentrix2
Comment Utility
Right now, the ip address of thw Win2k RAS can be anything you want because I can always change it later.  I just want this thing to dial out when I purposely fail my serial line.  I will be putting in that command now:

ip route 192.168.1.10 255.255.255.255 dialer 1

Should I get rid of this line?:

ip route 192.168.1.2 255.255.255.255 192.168.1.10
0
 
LVL 28

Expert Comment

by:mikebernhardt
Comment Utility
I just suggest that line because it will force the router to dial any time you try to ping 192.168.1.2 instead of having to fail the serial line. You should take it out later once your pings are successful, but you can do it now if you want.
0
 
LVL 9

Author Comment

by:Pentrix2
Comment Utility
BINGO!!!!!!!!!!!  I got it to dial out, my problem was I forgot I had ab access-list 102 in there.  Once I took it out it dial out like a champ.
0
 
LVL 28

Expert Comment

by:mikebernhardt
Comment Utility
What access-list 102?
0
 
LVL 9

Author Comment

by:Pentrix2
Comment Utility
It's able to dial and connect but it disconnects, it now gives me this error message.  Any clue why it would disconnect?


08:28:08: CHAT65: Chat script d0efault-d0ials0cript finished, status = Success
Router#
08:28:10: %LINK-3-UPDOWN: Interface Async65, changed state to up
08:28:10: As65 DDR: Dialer statechange to up
08:28:10: As65 DDR: Dialer call has been placed
08:28:10: As65 PPP: Treating connection as a callout
08:28:10: As65 PPP: Phase is ESTABLISHING, Active Open
08:28:10: As65 PPP: No remote authentication for call-out
08:28:10: As65 LCP: O CONFREQ [Closed] id 11 len 20
08:28:10: As65 LCP:    ACCM 0x000A0000 (0x0206000A0000)
08:28:10: As65 LCP:    MagicNumber 0x326596E6 (0x0506326596E6)
08:28:10: As65 LCP:    PFC (0x0702)
08:28:10: As65 LCP:    ACFC (0x0802)
08:28:10: As65 LCP: I CONFREQ [REQsent] id 0 len 59
08:28:10: As65 LCP:    ACCM 0x00000000 (0x020600000000)
08:28:10: As65 LCP:    AuthProto CHAP/129 (0x0305C22381)
08:28:10: As65 LCP:    MagicNumber 0x22484F9A (0x050622484F9A)
08:28:10: As65 LCP:    PFC (0x0702)
08:28:10: As65 LCP:    ACFC (0x0802)
08:28:10: As65 LCP:    Callback 6  (0x0D0306)
08:28:10: As65 LCP:    MRRU 1614 (0x1104064E)
08:28:10: As65 LCP:    EndpointDisc 1 Local
08:28:10: As65 LCP:     (0x13170185203370E6664037A61D00EBAF)
08:28:10: As65 LCP:     (0xFE0AB700000000)
08:28:10: As65 LCP:    LinkDiscriminator 406 (0x17040196)
08:28:10: As65 LCP: O CONFREJ [REQsent] id 0 len 15
08:28:10: As65 LCP:    Callback 6  (0x0D0306)
08:28:10: As65 LCP:    MRRU 1614 (0x1104064E)
08:28:10: As65 LCP:    LinkDiscriminator 406 (0x17040196)
08:28:10: As65 LCP: I CONFACK [REQsent] id 11 len 20
08:28:10: As65 LCP:    ACCM 0x000A0000 (0x0206000A0000)
08:28:10: As65 LCP:    MagicNumber 0x326596E6 (0x0506326596E6)
08:28:10: As65 LCP:    PFC (0x0702)
08:28:10: As65 LCP:    ACFC (0x0802)
08:28:10: As65 LCP: I CONFREQ [ACKrcvd] id 1 len 48
08:28:10: As65 LCP:    ACCM 0x00000000 (0x020600000000)
08:28:10: As65 LCP:    AuthProto CHAP/129 (0x0305C22381)
08:28:10: As65 LCP:    MagicNumber 0x22484F9A (0x050622484F9A)
08:28:10: As65 LCP:    PFC (0x0702)
08:28:10: As65 LCP:    ACFC (0x0802)
08:28:10: As65 LCP:    EndpointDisc 1 Local
08:28:10: As65 LCP:     (0x13170185203370E6664037A61D00EBAF)
08:28:10: As65 LCP:     (0xFE0AB700000000)
08:28:10: As65 LCP: O CONFNAK [ACKrcvd] id 1 len 9
08:28:10: As65 LCP:    AuthProto CHAP (0x0305C22305)
08:28:10: As65 LCP: I CONFREQ [ACKrcvd] id 2 len 48
08:28:10: As65 LCP:    ACCM 0x00000000 (0x020600000000)
08:28:10: As65 LCP:    AuthProto MS-CHAP (0x0305C22380)
08:28:10: As65 LCP:    MagicNumber 0x22484F9A (0x050622484F9A)
08:28:10: As65 LCP:    PFC (0x0702)
08:28:10: As65 LCP:    ACFC (0x0802)
08:28:10: As65 LCP:    EndpointDisc 1 Local
08:28:10: As65 LCP:     (0x13170185203370E6664037A61D00EBAF)
08:28:10: As65 LCP:     (0xFE0AB700000000)
08:28:10: As65 LCP: O CONFACK [ACKrcvd] id 2 len 48
08:28:10: As65 LCP:    ACCM 0x00000000 (0x020600000000)
08:28:10: As65 LCP:    AuthProto MS-CHAP (0x0305C22380)
08:28:10: As65 LCP:    MagicNumber 0x22484F9A (0x050622484F9A)
08:28:10: As65 LCP:    PFC (0x0702)
08:28:10: As65 LCP:    ACFC (0x0802)
08:28:10: As65 LCP:    EndpointDisc 1 Local
08:28:10: As65 LCP:     (0x13170185203370E6664037A61D00EBAF)
08:28:10: As65 LCP:     (0xFE0AB700000000)
08:28:10: As65 LCP: State is Open
08:28:10: As65 PPP: Phase is AUTHENTICATING, by the peer
08:28:10: As65 MS-CHAP: I CHALLENGE id 0 len 20 from "SERVERNAME"
08:28:10: As65 CHAP: Username NETAPPS not found
08:28:10: As65 CHAP: Unable to authenticate for peer
08:28:10: As65 PPP: Phase is TERMINATING
08:28:10: As65 LCP: O TERMREQ [Open] id 12 len 4
08:28:11: As65 LCP: I TERMACK [TERMsent] id 12 len 4
08:28:11: As65 LCP: State is Closed
08:28:11: As65 PPP: Phase is DOWN
08:28:11: As65 PPP: Phase is ESTABLISHING, Passive Open
08:28:11: As65 PPP: No remote authentication for call-out
08:28:11: As65 LCP: State is Listen
08:28:13: As65 LCP: TIMEout: State Listen
08:28:13: As65 PPP: No remote authentication for call-out
08:28:13: As65 LCP: O CONFREQ [Listen] id 13 len 20
08:28:13: As65 LCP:    ACCM 0x000A0000 (0x0206000A0000)
08:28:13: As65 LCP:    MagicNumber 0x3265A20C (0x05063265A20C)
08:28:13: As65 LCP:    PFC (0x0702)
08:28:13: As65 LCP:    ACFC (0x0802)
08:28:13: %LINK-5-CHANGED: Interface Async65, changed state to reset
08:28:13: DDR: Call disconnected, 5 packets unqueued and discarded
08:28:13: As65 LCP: State is Closed
08:28:13: As65 PPP: Phase is DOWN
Router#
Router#
0
 
LVL 12

Expert Comment

by:Scotty_cisco
Comment Utility
this is an authentication error.... ok sho what does your new configuration look like
0
 
LVL 12

Expert Comment

by:Scotty_cisco
Comment Utility
looks like it is looking for account netapp
08:28:10: As65 PPP: Phase is AUTHENTICATING, by the peer            
08:28:10: As65 MS-CHAP: I CHALLENGE id 0 len 20 from "SERVERNAME"
08:28:10: As65 CHAP: Username NETAPPS not found
08:28:10: As65 CHAP: Unable to authenticate for peer


looking for a username that is not defined

change your authentication line to call out.... not callin
Under your dialer

ppp authentication chap ms-chap callout
ppp chap hostname username
ppp chap password password


username and password are as defined on your ras server



0
 
LVL 28

Expert Comment

by:mikebernhardt
Comment Utility
Looks like a ppp authentication problem:
08:28:10: As65 LCP: State is Open
08:28:10: As65 PPP: Phase is AUTHENTICATING, by the peer
08:28:10: As65 MS-CHAP: I CHALLENGE id 0 len 20 from "SERVERNAME"
08:28:10: As65 CHAP: Username NETAPPS not found
08:28:10: As65 CHAP: Unable to authenticate for peer
08:28:10: As65 PPP: Phase is TERMINATING
08:28:10: As65 LCP: O TERMREQ [Open] id 12 len 4
08:28:11: As65 LCP: I TERMACK [TERMsent] id 12 len 4

1. I don't know how the other end is set up. Make sure you have an account and password set up for this. This is tricky: By default the router sends it'sown name as the user name, NOT the username you configured with "username." So make the user's name in your RAS the same as the router's hostname (right now it's "router"). The username in your config should be (I think) "NETAPPS." The password for NETAPPS must be the password you set for the account. So if the account password is test, you end up with
username NETAPPS password test
on the router and
username Router password test on your RAS.

2. Make sure you are allowing mschap on the RAS also.

3. In dialer 1, unless the actual name of the other end is "TEST-LAB-Dialer1" then remove the line "dialer remote-name TEST-LAB-Dialer1" from your config. You are essentially saying that if that isn't the remote end's name, you won't authenticate.

4. You may also speed up the authentication process if you add the line "ppp authentication ms-chap callin" to interface async 65 as well as leaving it on dialer 1
0
 
LVL 28

Expert Comment

by:mikebernhardt
Comment Utility
Actually Scotty's right. I didn't catch callin. And you can try his way for the user name and password, I wan't sure if that would work for ms-chap or only open-standard chap.
0
 
LVL 9

Author Comment

by:Pentrix2
Comment Utility
The access-list 102, no clue where I got that from, lol.

I'm going to have to try this tomorrow, I'll give you guys an update tomorrow.  Again, thanks for the patiences and help!!!!
0
 
LVL 9

Author Comment

by:Pentrix2
Comment Utility
I'm confused, which line should I take out or modify?

ip route 0.0.0.0 0.0.0.0 192.168.3.1
ip route 0.0.0.0 0.0.0.0 192.168.1.10 150
ip route 192.168.1.2 255.255.255.255 192.168.1.10
ip route 192.168.1.10 255.255.255.255 Dialer1
0
 
LVL 9

Author Comment

by:Pentrix2
Comment Utility
What I have so far.

The second line I deleted because I have no clue where that's going.

The third line I modified like this.

192.168.1.158 255.255.255.255 192.168.1.24
My computer ip                        win2k ras server

the fourth line I modified like this:

192.168.1.24 255.255.255.255 Dialer1
win2k ras server

Is this correct?  I'm wondring now where the 1st line is going?
0
 
LVL 9

Author Comment

by:Pentrix2
Comment Utility
For some reason CHAP is looking for a username called, netapps.  I created a local account and domain account in the username of netapps but it still can't authenticate.  This is the error message I get.

Router#
1d00h: As65 DDR: Dialer statechange to up
1d00h: As65 DDR: Dialer call has been placed
1d00h: As65 PPP: Treating connection as a callout
1d00h: As65 PPP: Phase is ESTABLISHING, Active Open
1d00h: As65 LCP: O CONFREQ [Closed] id 70 len 25
1d00h: As65 LCP:    ACCM 0x000A0000 (0x0206000A0000)
1d00h: As65 LCP:    AuthProto MS-CHAP (0x0305C22380)
1d00h: As65 LCP:    MagicNumber 0x35E75AEC (0x050635E75AEC)
1d00h: As65 LCP:    PFC (0x0702)
1d00h: As65 LCP:    ACFC (0x0802)
1d00h: As65 LCP: I CONFREQ [REQsent] id 0 len 59
1d00h: As65 LCP:    ACCM 0x00000000 (0x020600000000)
1d00h: As65 LCP:    AuthProto CHAP/129 (0x0305C22381)
1d00h: As65 LCP:    MagicNumber 0x22A357B8 (0x050622A357B8)
1d00h: As65 LCP:    PFC (0x0702)
1d00h: As65 LCP:    ACFC (0x0802)
1d00h: As65 LCP:    Callback 6  (0x0D0306)
1d00h: As65 LCP:    MRRU 1614 (0x1104064E)
1d00h: As65 LCP:    EndpointDisc 1 Local
1d00h: As65 LCP:     (0x13170185203370E6664037A61D00EBAF)
1d00h: As65 LCP:     (0xFE0AB700000000)
1d00h: As65 LCP:    LinkDiscriminator 431 (0x170401AF)
1d00h: As65 LCP: O CONFREJ [REQsent] id 0 len 15
1d00h: As65 LCP:    Callback 6  (0x0D0306)
1d00h: As65 LCP:    MRRU 1614 (0x1104064E)
1d00h: As65 LCP:    LinkDiscriminator 431 (0x170401AF)
1d00h: As65 LCP: I CONFACK [REQsent] id 70 len 25
1d00h: As65 LCP:    ACCM 0x000A0000 (0x0206000A0000)
1d00h: As65 LCP:    AuthProto MS-CHAP (0x0305C22380)
1d00h: As65 LCP:    MagicNumber 0x35E75AEC (0x050635E75AEC)
1d00h: As65 LCP:    PFC (0x0702)
1d00h: As65 LCP:    ACFC (0x0802)
1d00h: As65 LCP: I CONFREQ [ACKrcvd] id 1 len 48
1d00h: As65 LCP:    ACCM 0x00000000 (0x020600000000)
1d00h: As65 LCP:    AuthProto CHAP/129 (0x0305C22381)
1d00h: As65 LCP:    MagicNumber 0x22A357B8 (0x050622A357B8)
1d00h: As65 LCP:    PFC (0x0702)
1d00h: As65 LCP:    ACFC (0x0802)
1d00h: As65 LCP:    EndpointDisc 1 Local
1d00h: As65 LCP:     (0x13170185203370E6664037A61D00EBAF)
1d00h: As65 LCP:     (0xFE0AB700000000)
1d00h: As65 LCP: O CONFNAK [ACKrcvd] id 1 len 9
1d00h: As65 LCP:    AuthProto CHAP (0x0305C22305)
1d00h: As65 LCP: I CONFREQ [ACKrcvd] id 2 len 48
1d00h: As65 LCP:    ACCM 0x00000000 (0x020600000000)
1d00h: As65 LCP:    AuthProto MS-CHAP (0x0305C22380)
1d00h: As65 LCP:    MagicNumber 0x22A357B8 (0x050622A357B8)
1d00h: As65 LCP:    PFC (0x0702)
1d00h: As65 LCP:    ACFC (0x0802)
1d00h: As65 LCP:    EndpointDisc 1 Local
1d00h: As65 LCP:     (0x13170185203370E6664037A61D00EBAF)
1d00h: As65 LCP:     (0xFE0AB700000000)
1d00h: As65 LCP: O CONFACK [ACKrcvd] id 2 len 48
1d00h: As65 LCP:    ACCM 0x00000000 (0x020600000000)
1d00h: As65 LCP:    AuthProto MS-CHAP (0x0305C22380)
1d00h: As65 LCP:    MagicNumber 0x22A357B8 (0x050622A357B8)
1d00h: As65 LCP:    PFC (0x0702)
1d00h: As65 LCP:    ACFC (0x0802)
1d00h: As65 LCP:    EndpointDisc 1 Local
1d00h: As65 LCP:     (0x13170185203370E6664037A61D00EBAF)
1d00h: As65 LCP:     (0xFE0AB700000000)
1d00h: As65 LCP: State is Open
1d00h: As65 PPP: Phase is AUTHENTICATING, by both
1d00h: As65 CHAP: Using alternate hostname ciscorouting
1d00h: As65 MS-CHAP: O CHALLENGE id 8 len 25 from "ciscorouting"
1d00h: As65 MS-CHAP: I CHALLENGE id 0 len 20 from "NETAPPS"
1d00h: As65 CHAP: Using alternate hostname ciscorouting
1d00h: As65 CHAP: Username NETAPPS not found
1d00h: As65 CHAP: Using default password
1d00h: As65 MS-CHAP: O RESPONSE id 0 len 66 from "ciscorouting"
1d00h: As65 MS-CHAP: I SUCCESS id 0 len 4
1d00h: As65 LCP: I CONFREQ [Open] id 4 len 59
1d00h: As65 LCP:    ACCM 0x00000000 (0x020600000000)
1d00h: As65 LCP:    AuthProto CHAP/129 (0x0305C22381)
1d00h: As65 LCP:    MagicNumber 0x2DCC5970 (0x05062DCC5970)
1d00h: As65 LCP:    PFC (0x0702)
1d00h: As65 LCP:    ACFC (0x0802)
1d00h: As65 LCP:    Callback 6  (0x0D0306)
1d00h: As65 LCP:    MRRU 1614 (0x1104064E)
1d00h: As65 LCP:    EndpointDisc 1 Local
1d00h: As65 LCP:     (0x13170185203370E6664037A61D00EBAF)
1d00h: As65 LCP:     (0xFE0AB700000000)
1d00h: As65 LCP:    LinkDiscriminator 431 (0x170401AF)
1d00h: As65 PPP: Phase is TERMINATING
1d00h: As65 PPP: Phase is ESTABLISHING
1d00h: As65 LCP: O CONFREQ [Open] id 71 len 25
1d00h: As65 LCP:    ACCM 0x000A0000 (0x0206000A0000)
1d00h: As65 LCP:    AuthProto MS-CHAP (0x0305C22380)
1d00h: As65 LCP:    MagicNumber 0x35E75F6F (0x050635E75F6F)
1d00h: As65 LCP:    PFC (0x0702)
1d00h: As65 LCP:    ACFC (0x0802)
1d00h: As65 LCP: O CONFREJ [Open] id 4 len 15
1d00h: As65 LCP:    Callback 6  (0x0D0306)
1d00h: As65 LCP:    MRRU 1614 (0x1104064E)
1d00h: As65 LCP:    LinkDiscriminator 431 (0x170401AF)
1d00h: As65 LCP: I CONFREJ [REQsent] id 71 len 9
1d00h: As65 LCP:    AuthProto MS-CHAP (0x0305C22380)
1d00h: As65 LCP: O CONFREQ [REQsent] id 72 len 25
1d00h: As65 LCP:    ACCM 0x000A0000 (0x0206000A0000)
1d00h: As65 LCP:    AuthProto MS-CHAP (0x0305C22380)
1d00h: As65 LCP:    MagicNumber 0x35E75F6F (0x050635E75F6F)
1d00h: As65 LCP:    PFC (0x0702)
1d00h: As65 LCP:    ACFC (0x0802)
1d00h: As65 LCP: I CONFREQ [REQsent] id 5 len 48
1d00h: As65 LCP:    ACCM 0x00000000 (0x020600000000)
1d00h: As65 LCP:    AuthProto CHAP/129 (0x0305C22381)
1d00h: As65 LCP:    MagicNumber 0x2DCC5970 (0x05062DCC5970)
1d00h: As65 LCP:    PFC (0x0702)
1d00h: As65 LCP:    ACFC (0x0802)
1d00h: As65 LCP:    EndpointDisc 1 Local
1d00h: As65 LCP:     (0x13170185203370E6664037A61D00EBAF)
1d00h: As65 LCP:     (0xFE0AB700000000)
1d00h: As65 LCP: O CONFNAK [REQsent] id 5 len 9
1d00h: As65 LCP:    AuthProto CHAP (0x0305C22305)
1d00h: As65 LCP: I CONFREJ [REQsent] id 72 len 9
1d00h: As65 LCP:    AuthProto MS-CHAP (0x0305C22380)
1d00h: As65 LCP: O CONFREQ [REQsent] id 73 len 25
1d00h: As65 LCP:    ACCM 0x000A0000 (0x0206000A0000)
1d00h: As65 LCP:    AuthProto MS-CHAP (0x0305C22380)
1d00h: As65 LCP:    MagicNumber 0x35E75F6F (0x050635E75F6F)
1d00h: As65 LCP:    PFC (0x0702)
1d00h: As65 LCP:    ACFC (0x0802)
1d00h: As65 LCP: I CONFREQ [REQsent] id 6 len 48
1d00h: As65 LCP:    ACCM 0x00000000 (0x020600000000)
1d00h: As65 LCP:    AuthProto MS-CHAP (0x0305C22380)
1d00h: As65 LCP:    MagicNumber 0x2DCC5970 (0x05062DCC5970)
1d00h: As65 LCP:    PFC (0x0702)
1d00h: As65 LCP:    ACFC (0x0802)
1d00h: As65 LCP:    EndpointDisc 1 Local
1d00h: As65 LCP:     (0x13170185203370E6664037A61D00EBAF)
1d00h: As65 LCP:     (0xFE0AB700000000)
1d00h: As65 LCP: O CONFACK [REQsent] id 6 len 48
1d00h: As65 LCP:    ACCM 0x00000000 (0x020600000000)
1d00h: As65 LCP:    AuthProto MS-CHAP (0x0305C22380)
1d00h: As65 LCP:    MagicNumber 0x2DCC5970 (0x05062DCC5970)
1d00h: As65 LCP:    PFC (0x0702)
1d00h: As65 LCP:    ACFC (0x0802)
1d00h: As65 LCP:    EndpointDisc 1 Local
1d00h: As65 LCP:     (0x13170185203370E6664037A61D00EBAF)
1d00h: As65 LCP:     (0xFE0AB700000000)
1d00h: As65 LCP: I CONFREJ [ACKsent] id 73 len 9
1d00h: As65 LCP:    AuthProto MS-CHAP (0x0305C22380)
1d00h: As65 LCP: O CONFREQ [ACKsent] id 74 len 25
1d00h: As65 LCP:    ACCM 0x000A0000 (0x0206000A0000)
1d00h: As65 LCP:    AuthProto MS-CHAP (0x0305C22380)
1d00h: As65 LCP:    MagicNumber 0x35E75F6F (0x050635E75F6F)
1d00h: As65 LCP:    PFC (0x0702)
1d00h: As65 LCP:    ACFC (0x0802)
1d00h: As65 LCP: I CONFREJ [ACKsent] id 74 len 9
1d00h: As65 LCP:    AuthProto MS-CHAP (0x0305C22380)
1d00h: As65 LCP: O CONFREQ [ACKsent] id 75 len 25
1d00h: As65 LCP:    ACCM 0x000A0000 (0x0206000A0000)
1d00h: As65 LCP:    AuthProto MS-CHAP (0x0305C22380)
1d00h: As65 LCP:    MagicNumber 0x35E75F6F (0x050635E75F6F)
1d00h: As65 LCP:    PFC (0x0702)
1d00h: As65 LCP:    ACFC (0x0802)
1d00h: As65 LCP: I CONFREJ [ACKsent] id 75 len 9
1d00h: As65 LCP:    AuthProto MS-CHAP (0x0305C22380)
1d00h: As65 LCP: O CONFREQ [ACKsent] id 76 len 25
1d00h: As65 LCP:    ACCM 0x000A0000 (0x0206000A0000)
1d00h: As65 LCP:    AuthProto MS-CHAP (0x0305C22380)
1d00h: As65 LCP:    MagicNumber 0x35E75F6F (0x050635E75F6F)
1d00h: As65 LCP:    PFC (0x0702)
1d00h: As65 LCP:    ACFC (0x0802)
1d00h: As65 LCP: I TERMREQ [ACKsent] id 7 len 16 (0x2DCC5970003CCD74000002DC)
1d00h: As65 LCP: O TERMACK [ACKsent] id 7 len 4
1d00h: As65 LCP: TIMEout: State REQsent
1d00h: As65 LCP: O CONFREQ [REQsent] id 77 len 25
1d00h: As65 LCP:    ACCM 0x000A0000 (0x0206000A0000)
1d00h: As65 LCP:    AuthProto MS-CHAP (0x0305C22380)
1d00h: As65 LCP:    MagicNumber 0x35E762B9 (0x050635E762B9)
1d00h: As65 LCP:    PFC (0x0702)
1d00h: As65 LCP:    ACFC (0x0802)
1d00h: %LINK-5-CHANGED: Interface Async65, changed state to reset
1d00h: DDR: Call disconnected, 5 packets unqueued and discarded
1d00h: As65 LCP: State is Closed
1d00h: As65 PPP: Phase is DOWN
1d00h: %LINK-3-UPDOWN: Interface Async65, changed state to down
Router#
Router#
1d00h: As65 LCP: State is Closed
Router#
0
 
LVL 12

Expert Comment

by:Scotty_cisco
Comment Utility
do you have ppp authentication set to callout ???? it looks like both sides are doing authentication
0
 
LVL 9

Author Comment

by:Pentrix2
Comment Utility
Yes, I did set the router to callin and got rid of the callout.  And why does it keep on looking for netapps username?
0
 
LVL 9

Author Comment

by:Pentrix2
Comment Utility
The second line I deleted because I have no clue where that's going.

The third line I modified like this.

192.168.1.158 255.255.255.255 192.168.1.24
My computer ip                        win2k ras server

the fourth line I modified like this:

192.168.1.24 255.255.255.255 Dialer1
win2k ras server

Is this correct?  I'm wondring now where the 1st line is going?

I'm confused, which line should I take out or modify?

ip route 0.0.0.0 0.0.0.0 192.168.3.1
ip route 0.0.0.0 0.0.0.0 192.168.1.10 150
ip route 192.168.1.2 255.255.255.255 192.168.1.10
ip route 192.168.1.10 255.255.255.255 Dialer1
0
 
LVL 12

Expert Comment

by:Scotty_cisco
Comment Utility
The router should be CALLOUT not Callin

ok who is 192.168.1.2 and who is 192.168.1.10 ??? in the routing table

the dialer should have the next hop set to where it is connecting too.  
0
 
LVL 9

Author Comment

by:Pentrix2
Comment Utility
oh my bad, i meant the other way around. it's set to callout.

how will i set the next hope?  I can get rid of the 1.2 and 1.10.
0
 
LVL 12

Expert Comment

by:Scotty_cisco
Comment Utility
no ip route 192.168.x.x 255.255.255.x 192.168.1.1

to remove routes
0
 
LVL 9

Author Comment

by:Pentrix2
Comment Utility
I got that part down but what would you suggest be my next hop and how would i do the next hop?
0
 
LVL 9

Author Comment

by:Pentrix2
Comment Utility
I was thinking of putting this in place:

192.168.1.158 255.255.255.255 192.168.1.24
My computer ip                        win2k ras server
0
 
LVL 9

Author Comment

by:Pentrix2
Comment Utility
The above as in the next hop?
0
 
LVL 28

Expert Comment

by:mikebernhardt
Comment Utility
It looked like your router successfully authenticated to the RAS, but the RAS tried to authenticate to the router and failed.  I don't know if ms-chap supports callin/callout. And the RAS is trying to authenticate to you using chap, not ms-chap.  You could try using plain chap on the router instead of ms-chap:
ppp authentication chap
no ppp authentication ms-chap

An explanation of your static routes. You need to make the correct addresses:
ip route 0.0.0.0 0.0.0.0 192.168.3.1   Normal static route that sends traffic over the serial line- points to the other end

ip route 0.0.0.0 0.0.0.0 192.168.1.24 150   Floating static route if the serial line fails- points to the RAS

ip route 192.168.1.2 255.255.255.255 192.168.1.24   A route to make it easy to bring up the modem and prove that everything works- first address is a workstation on the OTHER SIDE of the RAS.  2nd is the RAS. If you can ping a workstation on the other side of the RAS, you know that routing from the RAS back to the router works.

ip route 192.168.1.24 255.255.255.255 Dialer1   A route that tells your router where the RAS is- first address is the RAS
0
 
LVL 9

Author Comment

by:Pentrix2
Comment Utility
When I used that, I'm getting this:


01:11:06: CHAT65: Chat script d0efault-d0ials0cript finished, status = Success
Router#
01:11:08: %LINK-3-UPDOWN: Interface Async65, changed state to up
Router#
01:11:08: As65 DDR: Dialer statechange to up
01:11:08: As65 DDR: Dialer call has been placed
01:11:08: As65 PPP: Treating connection as a callout
01:11:09: As65 MS-CHAP: I CHALLENGE id 0 len 20 from "NETAPPS"
01:11:09: As65 CHAP: Using alternate hostname ciscorouting
01:11:09: As65 CHAP: Username NETAPPS not found
01:11:09: As65 CHAP: Using default password
01:11:09: As65 MS-CHAP: O RESPONSE id 0 len 66 from "ciscorouting"
01:11:09: As65 MS-CHAP: I FAILURE id 0 len 18 msg is "E=649 R=0  V=3"
Router#
01:11:12: %LINK-5-CHANGED: Interface Async65, changed state to reset
Router#
01:11:12: DDR: Call disconnected, 5 packets unqueued and discarded
Router#
0
 
LVL 12

Expert Comment

by:Scotty_cisco
Comment Utility
Ok you must use MS-chap or so it looks
0
 
LVL 9

Author Comment

by:Pentrix2
Comment Utility
Yupe, I put it back.  I just don't understand why it keeps on looking for the username: netapps

I put the username netapps every on my network and it still can't find it.  dang, so frustrating to get this far and get the authentication not completing, :(
0
 
LVL 28

Expert Comment

by:mikebernhardt
Comment Utility
The RAS doesn't seem to care that your set up the router for callout. One thing you could try, just for fun:
username NETAPPS nopassword
Unless you can figure out what password that username would have associated with it. Or even better, figure out how to make the RAS stop trying to do 2-way authentication.

I'd like to make a suggestion- your question is answered, I think. Your router is dialing, and actually it is authenticating to the RAS also (at least when you used ms-chap it did). Your question now is different, which is how to get the RAS authenticate the way you need it to. You may want to ask that one on a Win2K forum instead of this one.
0
 
LVL 9

Author Comment

by:Pentrix2
Comment Utility
Alright, thanks there Mike and Scotty!!  I'll post it to the win2k forum.  Very true, my original question wasjust to get the dumb modem to dial out and authenticate through chap or ms-chap which it is doing, now it's just the win2k ras not authenticate.  Thanks both of you, :)
0

Featured Post

Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

Join & Write a Comment

Suggested Solutions

It happens many times that access list (ACL) have to be applied to outgoing router interface in order to limit some traffic.This article is about how to test ACL from the router which is not very intuitive for everyone. Below scenario shows simple s…
In the world of WAN, QoS is a pretty important topic for most, if not all, networks. Some WAN technologies have QoS mechanisms built in, but others, such as some L2 WAN's, don't have QoS control in the provider cloud.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now